User Tag List

Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11

Thread: App Store connect delivery issue

  1. #1
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleXNA Export Module
    Dobermann's Avatar
    Join Date
    Feb 2009
    Location
    France
    Posts
    697
    Mentioned
    27 Post(s)
    Tagged
    0 Thread(s)

    App Store connect delivery issue

    I got this mail from App Store Connect after uploading my app :

    ITMS-90809: Deprecated API Usage - Apple will stop accepting submissions of apps that use UIWebView APIs . See https://developer.apple.com/document...ikit/uiwebview for more information.
    How to fix this?

  2. #2
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,180
    Mentioned
    167 Post(s)
    Tagged
    3 Thread(s)
    remaking the object entirely

    thanks for the info though, added to my todo list
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  3. #3
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,180
    Mentioned
    167 Post(s)
    Tagged
    3 Thread(s)
    This Object was redone with latest API WKWebView, please let me know if you want to test it in your project to see if fullly compatible.
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  4. #4
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleXNA Export Module
    Dobermann's Avatar
    Join Date
    Feb 2009
    Location
    France
    Posts
    697
    Mentioned
    27 Post(s)
    Tagged
    0 Thread(s)
    Yes i do, please send it

  5. #5
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleXNA Export Module
    Dobermann's Avatar
    Join Date
    Feb 2009
    Location
    France
    Posts
    697
    Mentioned
    27 Post(s)
    Tagged
    0 Thread(s)
    Just a reminder that the fix you sent me doesn't work. If you have anything else to test.

    I'm a bit scared as they say that they will not accept new build with this warning soon and that i can't create app with Fusion in Xcode11...

  6. #6
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,180
    Mentioned
    167 Post(s)
    Tagged
    3 Thread(s)
    mm no, inside the webview2 object there is not trace of UIWebview anymore, and this object is fully implemented with WKWebView

    please make a search and find the UIWebView code
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  7. #7
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleXNA Export Module
    Dobermann's Avatar
    Join Date
    Feb 2009
    Location
    France
    Posts
    697
    Mentioned
    27 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Fernando View Post
    mm no, inside the webview2 object there is not trace of UIWebview anymore, and this object is fully implemented with WKWebView

    please make a search and find the UIWebView code
    I don't find "UIWebView" while using the glass icon on Xcode, but i still get the warning by mail after each submission.

    But i find something when i look for "webview": Default encoding for webview ios is isolatin1


    I've found on some forums that it can comes from a Google library as people get the error even while they don't use webview, so maybe it's, again, because of admob?

  8. #8
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,180
    Mentioned
    167 Post(s)
    Tagged
    3 Thread(s)
    mm never heard of it


    did you try with version 7.50 SDK ?
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  9. #9
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleXNA Export Module
    Dobermann's Avatar
    Join Date
    Feb 2009
    Location
    France
    Posts
    697
    Mentioned
    27 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Fernando View Post
    mm never heard of it
    I've found that on google:
    https://stackoverflow.com/questions/...issions-of-app


    Quote Originally Posted by Fernando View Post
    did you try with version 7.50 SDK ?
    I can't get it to work.

  10. #10
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,180
    Mentioned
    167 Post(s)
    Tagged
    3 Thread(s)
    the missing framework that is what is reflected in the log.
    Regards,


    Fernando Vivolo

    ... new things are coming ...

Page 1 of 2 1 2 LastLast

Similar Threads

  1. Error On Application Delivery
    By zenvision in forum iOS Export Module 2.5
    Replies: 3
    Last Post: 31st December 2016, 08:31 PM
  2. Replies: 5
    Last Post: 1st June 2016, 11:32 AM
  3. Can't... connect... to anything...
    By Konidias in forum Lacewing
    Replies: 12
    Last Post: 18th June 2011, 04:42 AM
  4. Connect 4
    By Deano in forum The Games Factory 2 - Technical Support
    Replies: 8
    Last Post: 29th January 2007, 02:28 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •