User Tag List

Results 1 to 4 of 4

Thread: Google Play Developer API?

  1. #1
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleiOS Export ModuleInstall Creator Pro

    Join Date
    Feb 2014
    Posts
    32
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Google Play Developer API?

    Today i got the following message in my google play developer console :

    "We've detected that your app is using an old version of the Google Play Developer API. From December 1 2019, versions 1 and 2 of this API will no longer be available. Update to version 3 before this date."

    Am i using some old version or is there an update on the way?

  2. #2
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)iOS Export Module (Steam)

    Join Date
    May 2014
    Posts
    193
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    I got this message again just now too, but I haven't uploaded an apk with version 292.14 yet. I will upload a new version today with 292.14 and I'll see if I will still get the message. I know that Fernando was working on version 3 of the IAP object, but what worries me a little is that Google seems to have added a later part to the message, saying that it's not related to the AIDL/Billing Library deprecation, so I'm a little confused at what they mean. Could anyone from Clickteam take a look at this updated message from Google to make sure that they are making all of the modifications required by Google? Here is the message:

    "We've detected that your app is using an old version of the Google Play Developer API. From December 1 2019, versions 1 and 2 of this API will no longer be available. Update to version 3 before this date. Note that this is not related to the AIDL/Billing Library deprecation."

  3. #3
    Clicker Fusion 2.5 MacFusion 2.5 DeveloperFusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleSWF Export ModuleXNA Export ModuleMac Export Module
    Sloxone's Avatar
    Join Date
    Nov 2011
    Location
    France
    Posts
    499
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi ,
    I got this message from Google Play:
    "This is a reminder that starting November 1, 2019, updates to apps and games on Google Play will be required to target Android 9 (API level 28) or higher. After this date, the Play Console will prevent you from submitting new APKs with a targetSdkVersion less than 28.
    Configuring your app to target a recent API level ensures that users benefit from significant security and performance improvements, while still allowing your app to run on older Android versions (down to the minSdkVersion).
    "

  4. #4
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)iOS Export Module (Steam)

    Join Date
    May 2014
    Posts
    193
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    @ Sloxone

    You need to change your target version from Clickteam Fusion to be at least 28. (Preferably 29)

    You can already do this with the latest version. Just make sure that you also have the appropriate sdk installed on your computer.

Similar Threads

  1. Replies: 0
    Last Post: 4th July 2019, 09:08 AM
  2. Replies: 3
    Last Post: 24th May 2016, 02:18 PM
  3. Issues on my recent game on google Developer Console
    By Sloxone in forum Android Export Module 2.5
    Replies: 10
    Last Post: 18th February 2016, 07:25 PM
  4. No statistics in google developer console?
    By gnodab2 in forum Android Export Module Version 2.0
    Replies: 0
    Last Post: 10th March 2014, 09:10 AM
  5. google play...
    By Sevennemesis in forum Android Export Module Version 2.0
    Replies: 3
    Last Post: 15th June 2012, 03:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •