User Tag List

Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 24

Thread: Xcode version 11.0 doesn't install my app on my phone for testing

  1. #1
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleXNA Export Module
    Dobermann's Avatar
    Join Date
    Feb 2009
    Location
    France
    Posts
    713
    Mentioned
    27 Post(s)
    Tagged
    0 Thread(s)

    Xcode version 11.0 doesn't install my app on my phone for testing

    I just got an update of Xcode (version 11.0) and each time i try to test my app on my iphone i get the same error message saying that the install claimed to have succeeded but app could not be found on device.
    And when i check my device i see that the app isn't installed.

    Am i missing something? A lots of things have changed in this new xcode version but i was able to find everything i need and to build the app with no error (just warnings as always).

  2. #2
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,233
    Mentioned
    175 Post(s)
    Tagged
    3 Thread(s)
    mm no, i am using xcode 11.0 and is fine for both ios and mac (i am running catalina here)

    teh first time did it mention to install some components that took like an hour to install?
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  3. #3
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleXNA Export Module
    Dobermann's Avatar
    Join Date
    Feb 2009
    Location
    France
    Posts
    713
    Mentioned
    27 Post(s)
    Tagged
    0 Thread(s)
    I don't remember,, but i think yes it asked me to add components. Actually i've just found that there is a new update 11.1, i'm waiting for the download and install and will report if it works with it.

  4. #4
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleXNA Export Module
    Dobermann's Avatar
    Join Date
    Feb 2009
    Location
    France
    Posts
    713
    Mentioned
    27 Post(s)
    Tagged
    0 Thread(s)
    Now i'm sure that Xcode has installed the components but it still doesn't work, i'm running ios 12.4.2 on my iphone 5s, i'm installing the new os version right now to see if it changes anything.

    It also doesn't work on my iphone 7 running ios 13.1.2...

    I don't know what to do, i have an update to publish and i'm stuck.

  5. #5
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleXNA Export Module
    Dobermann's Avatar
    Join Date
    Feb 2009
    Location
    France
    Posts
    713
    Mentioned
    27 Post(s)
    Tagged
    0 Thread(s)
    It still fail everytime, I have changed nothing in my app before to make the Xcode upgrade. Everything was working fine before the upgrade.

    I can't even test it on the emulator, I get this error message regarding the plis file:

    This app could not be installed at this time.
    Domain: IXUserPresentableErrorDomain
    Code: 1
    Failure Reason: Could not install at this time.
    Recovery Suggestion: Failed to load Info.plist from bundle at path /Users/dobermannstudios/Library/Developer/CoreSimulator/Devices/0FB7025F-CCBC-4B04-9BBD-C385AF2B32D0/data/Library/Caches/com.apple.mobile.installd.staging/temp.kxsEkm/extracted/SpartanFirefight.app/Frameworks/GoogleMobileAds.framework
    --
    Failed to load Info.plist from bundle at path /Users/dobermannstudios/Library/Developer/CoreSimulator/Devices/0FB7025F-CCBC-4B04-9BBD-C385AF2B32D0/data/Library/Caches/com.apple.mobile.installd.staging/temp.kxsEkm/extracted/SpartanFirefight.app/Frameworks/GoogleMobileAds.framework
    Domain: MIInstallerErrorDomain
    Code: 35
    User Info: {
    FunctionName = "-[MIBundle _validateWithError:]";
    LegacyErrorString = PackageInspectionFailed;
    SourceFileLine = 39;
    }
    --


    It seems for that part, that the problem comes from google admob sdk, what version of the sdk shoul i use with Xcode11?

  6. #6
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,233
    Mentioned
    175 Post(s)
    Tagged
    3 Thread(s)
    mm tested xcode 11 with a big game almost 400 MB and seems Ok for iphone 5s 12.4 and ipad air 2 with 13.1.2

    for admob please check here https://community.clickteam.com/threads/106084-AdMob-error-in-main-m?highlight=admob+ios+version

    but it must be 7.39, just check and seems OK


    check your signing and capabilities just in case.
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  7. #7
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleXNA Export Module
    Dobermann's Avatar
    Join Date
    Feb 2009
    Location
    France
    Posts
    713
    Mentioned
    27 Post(s)
    Tagged
    0 Thread(s)
    I've checked my signong, certificates, provisionning, capabilities and all is fine, i don't know why i can't install app on any of my devices while everything was working before this update. I'm nor familiarized with xcode enough to solve this issue, i always follow a process i've write down to compile my apps and publish them. Don't know where to look and why it's happening..

  8. #8
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleXNA Export Module
    Dobermann's Avatar
    Join Date
    Feb 2009
    Location
    France
    Posts
    713
    Mentioned
    27 Post(s)
    Tagged
    0 Thread(s)
    I've reinstalled Xcode, and created a blank app from it, and I can install it on my iPhone with no problem, but none of my Clickteam projects can be installed on my iPhones, I think it has something to do with ADMOB, maybe some codes that aren't supported on Xcode 11 makes the install to fail? It truly has something to see with the error message I've posted above.

  9. #9
    Clickteam Clickteam

    Join Date
    Jun 2006
    Location
    France
    Posts
    13,290
    Mentioned
    151 Post(s)
    Tagged
    2 Thread(s)
    Sorry if this seems obvious, but have you tried cleaning the project before rebuilding it?

  10. #10
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleXNA Export Module
    Dobermann's Avatar
    Join Date
    Feb 2009
    Location
    France
    Posts
    713
    Mentioned
    27 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Yves View Post
    Sorry if this seems obvious, but have you tried cleaning the project before rebuilding it?
    Yes, i alwasy do a clean before building just in case. I'm installing Xcode10.3 right now (it's taking forever time) to see if i can unlock my situation, but i do know that i will encounter this issue as soon as i'll update to iOS 11... :'(

Page 1 of 3 1 2 3 LastLast

Similar Threads

  1. .apk is not installing on my phone for testing.
    By Thatdamnlobster in forum Android Export Module 2.5
    Replies: 13
    Last Post: 15th May 2017, 03:24 PM
  2. play testing a game on android phone
    By blurymind in forum Android Export Module 2.5
    Replies: 7
    Last Post: 19th December 2015, 08:24 PM
  3. OUYA testing on Phone with controller
    By Perry in forum Android Export Module 2.5
    Replies: 4
    Last Post: 5th October 2014, 03:19 AM
  4. I phone update and Xcode 5.1
    By Sloxone in forum iOS Export Module 2.5
    Replies: 7
    Last Post: 9th April 2014, 03:58 AM
  5. Testing your games on a phone
    By Jeff in forum Android Export Module Version 2.0
    Replies: 7
    Last Post: 6th April 2013, 05:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •