User Tag List

Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14

Thread: Changes to the Google Play Developer API

  1. #1
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleXNA Export Module
    Dobermann's Avatar
    Join Date
    Feb 2009
    Location
    France
    Posts
    713
    Mentioned
    27 Post(s)
    Tagged
    0 Thread(s)

    Changes to the Google Play Developer API

    Hello,
    I've got a message from google on my Developer Console, saying that my app use an old version of Google Play Developer API.
    It also says that version 1 and 2 of this API will no longer be supported on december 1st and that we must to pass to version 3.
    What must i do? Is it an update Clickteam must do?
    Thank you.

  2. #2
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,247
    Mentioned
    176 Post(s)
    Tagged
    3 Thread(s)
    We use the version 3 in inapp, i must check why it still mention this
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  3. #3
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleXNA Export Module
    Dobermann's Avatar
    Join Date
    Feb 2009
    Location
    France
    Posts
    713
    Mentioned
    27 Post(s)
    Tagged
    0 Thread(s)
    I didn"t got the message for my new update, and i don't use the Inapp API actually in this game, so maybe it was a bug from the console if everything is fine with the API version?

  4. #4
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)iOS Export Module (Steam)

    Join Date
    May 2014
    Posts
    199
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Was your game built with 292.14 or an earlier version of Fusion? I know I received a message like that on 11th of October when my app was uploaded with 292.10 (I think), but I haven't seen the message since I uploaded with 292.14.

    It's difficult to say if the message still applies, because it used to appear pretty randomly even when the app was 'not compliant'.

    It's worth noting that in one of the messages that I received, Google said something that seemed to imply that they weren't talking about the in app purchases, or at least that's what I understood from what they said. Here was their message:

    "We've detected that your app is using an old version of the Google Play Developer API. From December 1 2019, versions 1 and 2 of this API will no longer be available. Update to version 3 before this date. Note that this is not related to the AIDL/Billing Library deprecation."

  5. #5
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,247
    Mentioned
    176 Post(s)
    Tagged
    3 Thread(s)
    @Nemeean_lion & @Dobermann can you post a list of the extensions used in this game/app to get this report.

    thanks in advance


    ===========================================

    the only information i have here is https://android-developers.googleblo...loper-api.html
    and it mention that there won't be any problem in the In-App flow using AIDL.
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  6. #6
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)iOS Export Module (Steam)

    Join Date
    May 2014
    Posts
    199
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Is there a way to list all of the extensions I'm using in a project using Clickteam Fusion 2.5+?

    As far as I know, the extensions I'm using are: String Parser, Font Packer and Google Play Games.

  7. #7
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,247
    Mentioned
    176 Post(s)
    Tagged
    3 Thread(s)
    right click over you title project ---> data elements ----> tab extensions and grab this image using snip (snipping Tool).
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  8. #8
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)iOS Export Module (Steam)

    Join Date
    May 2014
    Posts
    199
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Alright. Here is the screenshot: fusion data elements.PNG

  9. #9
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,247
    Mentioned
    176 Post(s)
    Tagged
    3 Thread(s)
    Oh it could come from GPG Objects, which are now deprecated by Google
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  10. #10
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleXNA Export Module
    Dobermann's Avatar
    Join Date
    Feb 2009
    Location
    France
    Posts
    713
    Mentioned
    27 Post(s)
    Tagged
    0 Thread(s)
    Here's my list of extensions:
    extensions.png

    Quote Originally Posted by Fernando View Post
    Oh it could come from GPG Objects, which are now deprecated by Google
    All objects are deprecated? My game needs GPG Connect to identificate the players...

Page 1 of 2 1 2 LastLast

Similar Threads

  1. Google Play Developer API?
    By medron in forum Android Export Module 2.5
    Replies: 3
    Last Post: 14th October 2019, 03:15 PM
  2. Replies: 0
    Last Post: 4th July 2019, 09:08 AM
  3. Replies: 3
    Last Post: 24th May 2016, 02:18 PM
  4. Issues on my recent game on google Developer Console
    By Sloxone in forum Android Export Module 2.5
    Replies: 10
    Last Post: 18th February 2016, 07:25 PM
  5. No statistics in google developer console?
    By gnodab2 in forum Android Export Module Version 2.0
    Replies: 0
    Last Post: 10th March 2014, 09:10 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •