User Tag List

Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13

Thread: AndroidPlus needs a build.gradle?

  1. #1
    Clicker Multimedia Fusion 2 DeveloperSWF Export Module
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)
    warlords's Avatar
    Join Date
    Oct 2011
    Location
    Dk
    Posts
    472
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    AndroidPlus needs a build.gradle?

    How do I install build.gradle into fusion 2.5?

    I use AndroidPlus and I can't make a apk file?


    -----------------------
    > Configure project :
    it is windows 10

    FAILURE: Build failed with an exception.

    * Where:
    Build file 'C:\Users\Bruger\AppData\Local\Temp\AndE276.tmp\ap p\build.gradle'

    * What went wrong:
    Could not compile build file 'C:\Users\Bruger\AppData\Local\Temp\AndE276.tmp\ap p\build.gradle'.
    > startup failed:
    General error during semantic analysis: Unsupported class file major version 57

  2. #2
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,561
    Mentioned
    257 Post(s)
    Tagged
    4 Thread(s)
    what JAVA SDK version are you using in preferences inside FUSION
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  3. #3
    Clicker Multimedia Fusion 2 DeveloperSWF Export Module
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)
    warlords's Avatar
    Join Date
    Oct 2011
    Location
    Dk
    Posts
    472
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    I use C:\Program Files\Java\jdk-13.0.1

    sdk.jpg

  4. #4
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,561
    Mentioned
    257 Post(s)
    Tagged
    4 Thread(s)
    Nice, you must not work java 13 you must use java 8
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  5. #5
    Clicker Multimedia Fusion 2 DeveloperSWF Export Module
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)
    warlords's Avatar
    Join Date
    Oct 2011
    Location
    Dk
    Posts
    472
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Okay I tryed to install Java 8 but get another error...

    > Configure project :
    it is windows 10

    > Configure project :app
    WARNING: The option setting 'android.overridePathCheck=true' is experimental and unsupported.
    The current default is 'false'.


    > Task :app:preBuild UP-TO-DATE
    > Task :app:preDebugBuild UP-TO-DATE
    > Task :app:compileDebugAidl NO-SOURCE
    > Task :app:compileDebugRenderscript NO-SOURCE
    > Task :app:checkDebugManifest
    > Task :app:generateDebugBuildConfig
    > Task :app:mainApkListPersistenceDebug
    > Task :app:generateDebugResValues
    > Task :app:generateDebugResources
    > Task :app:javaPreCompileDebug
    > Task :app:createDebugCompatibleScreenManifests
    > Task :app:processDebugManifest
    > Task :app:mergeDebugShaders
    > Task :app:compileDebugShaders
    > Task :app:generateDebugAssets
    > Task :app:mergeDebugAssets
    > Task :app:processDebugJavaRes NO-SOURCE
    > Task :app:checkDebugDuplicateClasses
    > Task :app:mergeDebugResources
    > Task :app:processDebugResources
    > Task :app:compileDebugJavaWithJavac FAILED
    > Task :app:mergeExtDexDebug

    FAILURE: Build failed with an exception.

    * What went wrong:
    Execution failed for task ':app:compileDebugJavaWithJavac'.
    > Could not find tools.jar. Please check that C:\Program Files (x86)\Java\jre1.8.0_241 contains a valid JDK installation.

    * Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

    * Get more help at https://help.gradle.org

    BUILD FAILED in 8s
    15 actionable tasks: 15 executed

    prefrences.JPG


    Do I need to release mode = keystore name ect...?

  6. #6
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Mac Export Module (Steam)Universal Windows Platform Export Module (Steam)SWF Export Module (Steam)Firefly 3D Module (Steam)

    Join Date
    Feb 2017
    Posts
    381
    Mentioned
    18 Post(s)
    Tagged
    0 Thread(s)
    @warlords i think you need jdk not jre.

    Here is a link where you can download different versions without register/account -> https://adoptopenjdk.net/

    Install OpenJDK8 with HotSpot, i use that it works with android plus.

    Path will look something like this -> C:\Program Files\AdoptOpenJDK\jdk-8.0.242.08-hotspot

  7. #7
    Clicker Multimedia Fusion 2 DeveloperSWF Export Module
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)
    warlords's Avatar
    Join Date
    Oct 2011
    Location
    Dk
    Posts
    472
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Great man It now works right. Big Thanks

  8. #8
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)

    Join Date
    Jan 2016
    Posts
    3
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Senhores estou com um problema parecido, estou usando o Java 8 porém estou recebendo o erro:


    FAILURE: Build failed with an exception.

    * What went wrong:
    Could not write cache value to 'C:\Users\Lima Advocacia\.gradle\daemon\5.4.1\registry.bin'.

    * Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

    * Get more help at https://help.gradle.org

    Alguém pode me ajudar?

  9. #9
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)

    Join Date
    Jan 2016
    Posts
    3
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Senhores estou com um problema parecido, estou usando o Java 8 e recebo o erro:


    FAILURE: Build failed with an exception.

    * What went wrong:
    Could not write cache value to 'C:\Users\Lima Advocacia\.gradle\daemon\5.4.1\registry.bin'.

    * Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

    * Get more help at https://help.gradle.org

    Alguém pode me ajudar?

  10. #10
    Clickteam Clickteam

    Join Date
    Jun 2006
    Location
    France
    Posts
    13,631
    Mentioned
    229 Post(s)
    Tagged
    3 Thread(s)
    In theory you do not need JDK 8, Android Studio installs its own version of Java, usually in C:\Program Files\Android\Android Studio\jre. Verify this directory exists on your machine and use it as "Java SDK directory" in the preferences of Fusion.

Page 1 of 2 1 2 LastLast

Similar Threads

  1. AndroidTV controller + AndroidPlus sensor crash
    By Dobermann in forum Android Export Module 2.5
    Replies: 27
    Last Post: 29th May 2020, 04:12 AM
  2. Odd compile error Gradle / Admob with latest built.
    By Perry in forum Android Export Module 2.5
    Replies: 11
    Last Post: 28th May 2019, 11:01 PM
  3. AndroidPlus Flashlight Now Working
    By Kracker in forum Android Export Module 2.5
    Replies: 14
    Last Post: 19th October 2016, 11:50 PM
  4. AndroidPlus preferences saving issue
    By EBMan in forum Android Export Module 2.5
    Replies: 3
    Last Post: 13th March 2016, 05:10 PM
  5. Questions about the AndroidPlus object and Share
    By Outcast in forum Android Export Module 2.5
    Replies: 23
    Last Post: 9th November 2015, 06:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •