User Tag List

Results 1 to 9 of 9

Thread: java.net.BindException: Address already in use: Cannot bind

  1. #1
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)Universal Windows Platform Export Module (Steam)

    Join Date
    Nov 2017
    Posts
    9
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    java.net.BindException: Address already in use: Cannot bind

    I get this message, if i want to built an application on MMF 2.5 dev

    __________________________________

    FAILURE: Build failed with an exception.

    * What went wrong:
    java.net.BindException: Address already in use: Cannot bind

    * Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

    * Get more help at https://help.gradle.org

    ___________________________________

    MMF DEV • 2.5 Buit r292.10

    Who can help me???


    App building worked great half a year ago...

  2. #2
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,592
    Mentioned
    268 Post(s)
    Tagged
    4 Thread(s)
    can you register your products to give you a better help
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  3. #3
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)Universal Windows Platform Export Module (Steam)

    Join Date
    Nov 2017
    Posts
    9
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    I registered the products... look community passport

  4. #4
    Clickteam Clickteam

    Join Date
    Jun 2006
    Location
    France
    Posts
    13,697
    Mentioned
    236 Post(s)
    Tagged
    3 Thread(s)
    Maybe a conflict with another process, try to close other programs.

  5. #5
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,592
    Mentioned
    268 Post(s)
    Tagged
    4 Thread(s)
    @schmittfotos this can happens because several things

    1.- your antivirus is blocking gradle to do his job during building and stopping it to reach internet.
    2.- you firewall could blocked teh internet connection for gradle.

    can you provide with the specs of the pc you are having this result. also please check that your antivirus is not affecting the execution of gradle during building.
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  6. #6
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)Universal Windows Platform Export Module (Steam)

    Join Date
    Nov 2017
    Posts
    9
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Hello, i tested the software with different Java JDKs, at the moment i'm using jdk1.8.0_251.
    The error is now:


    Starting a Gradle Daemon, 3 incompatible and 1 stopped Daemons could not be reused, use --status for details

    > Configure project :
    it is windows 10

    > Configure project :app
    WARNING: The option setting 'android.overridePathCheck=true' is experimental and unsupported.
    The current default is 'false'.

    File C:\Users\USERNAME\.android\repositories.cfg could not be loaded.
    Checking the license for package Android SDK Platform-Tools in C:\Program Files\Java\licenses
    Warning: License for package Android SDK Platform-Tools not accepted.
    Checking the license for package SDK Patch Applier v4 in C:\Program Files\Java\licenses
    Warning: License for package SDK Patch Applier v4 not accepted.
    Checking the license for package Android Emulator in C:\Program Files\Java\licenses
    Warning: License for package Android Emulator not accepted.
    Checking the license for package Android SDK Tools in C:\Program Files\Java\licenses
    Warning: License for package Android SDK Tools not accepted.
    Checking the license for package Android SDK Build-Tools 28.0.3 in C:\Program Files\Java\licenses
    Warning: License for package Android SDK Build-Tools 28.0.3 not accepted.
    Checking the license for package Android SDK Platform 24 in C:\Program Files\Java\licenses
    Warning: License for package Android SDK Platform 24 not accepted.

    FAILURE: Build failed with an exception.

    * What went wrong:
    Could not determine the dependencies of task ':app:compileDebugJavaWithJavac'.
    > Failed to install the following Android SDK packages as some licences have not been accepted.
    patcher;v4 SDK Patch Applier v4
    build-tools;28.0.3 Android SDK Build-Tools 28.0.3
    platforms;android-24 Android SDK Platform 24
    emulator Android Emulator
    tools Android SDK Tools
    platform-tools Android SDK Platform-Tools
    To build this project, accept the SDK license agreements and install the missing components using the Android Studio SDK Manager.
    Alternatively, to transfer the license agreements from one workstation to another, see http://d.android.com/r/studio-ui/export-licenses.html

    Using Android SDK: C:\Program Files\Java



    BUILD FAILED in 41s

  7. #7
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,592
    Mentioned
    268 Post(s)
    Tagged
    4 Thread(s)
    you need to update your android sdk version, you can not build using version 24 anymore

    platforms;android-24 Android SDK Platform 24


    Regards,


    Fernando Vivolo

    ... new things are coming ...

  8. #8
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)Universal Windows Platform Export Module (Steam)

    Join Date
    Nov 2017
    Posts
    9
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Yes, i have to latest software installed, but the error still appears:

    > Configure project :
    it is windows 10

    > Configure project :app
    WARNING: The option setting 'android.overridePathCheck=true' is experimental and unsupported.
    The current default is 'false'.

    Checking the license for package Android SDK Platform-Tools in C:\Program Files\Android\licenses
    Warning: License for package Android SDK Platform-Tools not accepted.
    Checking the license for package SDK Patch Applier v4 in C:\Program Files\Android\licenses
    Warning: License for package SDK Patch Applier v4 not accepted.
    Checking the license for package Android Emulator in C:\Program Files\Android\licenses
    Warning: License for package Android Emulator not accepted.
    Checking the license for package Android SDK Tools in C:\Program Files\Android\licenses
    Warning: License for package Android SDK Tools not accepted.
    Checking the license for package Android SDK Build-Tools 28.0.3 in C:\Program Files\Android\licenses
    Warning: License for package Android SDK Build-Tools 28.0.3 not accepted.
    Checking the license for package Android SDK Platform 24 in C:\Program Files\Android\licenses
    Warning: License for package Android SDK Platform 24 not accepted.

    FAILURE: Build failed with an exception.

    * What went wrong:
    Could not determine the dependencies of task ':app:compileDebugJavaWithJavac'.
    > Failed to install the following Android SDK packages as some licences have not been accepted.
    patcher;v4 SDK Patch Applier v4
    build-tools;28.0.3 Android SDK Build-Tools 28.0.3
    platforms;android-24 Android SDK Platform 24
    emulator Android Emulator
    tools Android SDK Tools
    platform-tools Android SDK Platform-Tools
    To build this project, accept the SDK license agreements and install the missing components using the Android Studio SDK Manager.
    Alternatively, to transfer the license agreements from one workstation to another, see http://d.android.com/r/studio-ui/export-licenses.html

    Using Android SDK: C:\Program Files\Android

    screen.PNG

  9. #9
    Clickteam Clickteam

    Join Date
    Jun 2006
    Location
    France
    Posts
    13,697
    Mentioned
    236 Post(s)
    Tagged
    3 Thread(s)
    The "license not accepted" message is described in the post that describes the installation requirements: https://community.clickteam.com/threads/105484-Android-Runtime-Build-292

    Possible errors the first time you build an application and/or you use a new API

    + Gradle automatically downloads the libraries and build tools it needs, however it doesn't ask you for accepting licenses. If you get an error message that says "License for package XXXXX not accepted.", do this:

    1. open an explorer window and go to the Android SDK folder (usually C:\Users\YourName\AppData\Local\Android\Sdk)
    2. open the tools/bin sub-directory
    3. open a command prompt window in this directory and type "sdkmanager --licenses" (or sdkmanager --update for old versions of the SDK), this will allow you to review and accept the licenses of the downloaded files. You can also simply open the SDK Manager and update the build API/Tools, this may work.
    Also on a side note, you say you use the Java SDK, you should probably use the JDK that comes with Android Studio:

    Android Studio installs its own version of Java, usually in C:\Program Files\Android\Android Studio\jre. Verify this directory exists on your machine and use it as "Java SDK directory" in the preferences of Fusion.

Similar Threads

  1. Get link address
    By oasuke in forum Multimedia Fusion 2 - Technical Support
    Replies: 2
    Last Post: 7th March 2012, 08:56 AM
  2. Big problem with trying to bind object to another!
    By Outcast in forum Multimedia Fusion 2 - Technical Support
    Replies: 6
    Last Post: 21st February 2011, 02:15 PM
  3. IP Address
    By Game_Master in forum Multimedia Fusion 2 - Technical Support
    Replies: 6
    Last Post: 25th April 2009, 09:19 PM
  4. MAC Address
    By Renatos in forum Multimedia Fusion 2 - Technical Support
    Replies: 11
    Last Post: 12th April 2008, 09:20 PM
  5. Suggestion: Bind To Object
    By Michael_Gummelt in forum Multimedia Fusion 2 - Technical Support
    Replies: 11
    Last Post: 26th July 2006, 03:29 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •