User Tag List

Results 1 to 5 of 5

Thread: Failed to build Android .apk

  1. #1
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    mrknd94's Avatar
    Join Date
    Jun 2017
    Location
    United Kingdom
    Posts
    23
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Failed to build Android .apk

    Hey guys,

    Here's what the output file says:


    * What went wrong:
    Execution failed for task ':app:processDebugResources'.
    > A failure occurred while executing com.android.build.gradle.internal.tasks.Workers$Ac tionFacade
    > Android resource linking failed
    C:\Users\Josh\.gradle\caches\transforms-2\files-2.1\66f12a7200af14e0f85c231d9d9cbd07\appcompat-v7-27.1.1\res\values-v26\values-v26.xml:5:5-8:13: AAPT: error: resource android:attr/colorError not found.

    C:\Users\Josh\.gradle\caches\transforms-2\files-2.1\66f12a7200af14e0f85c231d9d9cbd07\appcompat-v7-27.1.1\res\values-v26\values-v26.xml:9:5-12:13: AAPT: error: resource android:attr/colorError not found.

    C:\Users\Josh\.gradle\caches\transforms-2\files-2.1\66f12a7200af14e0f85c231d9d9cbd07\appcompat-v7-27.1.1\res\values-v26\values-v26.xml:13:5-16:13: AAPT: error: style attribute 'android:attr/keyboardNavigationCluster' not found.

    C:\Users\Josh\.gradle\caches\transforms-2\files-2.1\6931bc3fe5868b0ab5606c1192ce8d93\support-compat-27.1.1\res\values\values.xml:16:5-19:208: AAPT: error: resource android:attr/fontStyle not found.

    C:\Users\Josh\.gradle\caches\transforms-2\files-2.1\6931bc3fe5868b0ab5606c1192ce8d93\support-compat-27.1.1\res\values\values.xml:16:5-19:208: AAPT: error: resource android:attr/font not found.

    C:\Users\Josh\.gradle\caches\transforms-2\files-2.1\6931bc3fe5868b0ab5606c1192ce8d93\support-compat-27.1.1\res\values\values.xml:16:5-19:208: AAPT: error: resource android:attr/fontWeight not found.


    * Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

    * Get more help at https://help.gradle.org

    Deprecated Gradle features were used in this build, making it incompatible with Gradle 6.0.
    Use '--warning-mode all' to show the individual deprecation warnings.
    See https://docs.gradle.org/5.4.1/usergu..._line_warnings

    BUILD FAILED in 2m 23s
    18 actionable tasks: 18 executed


    Any help?

  2. #2
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,673
    Mentioned
    283 Post(s)
    Tagged
    4 Thread(s)
    Android 292.22 now use 28+ as building API(es)
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  3. #3
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    mrknd94's Avatar
    Join Date
    Jun 2017
    Location
    United Kingdom
    Posts
    23
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi,

    Does that mean I have to install API 28+ then? I don't really know hahah...

    Thanks, I appreciate the help :-)

  4. #4
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export Module
    Janette5's Avatar
    Join Date
    Dec 2014
    Location
    Western Cape, SA
    Posts
    1,061
    Mentioned
    171 Post(s)
    Tagged
    0 Thread(s)
    If you're aiming to publish in Google Play you really should install and use build 29 - api 29 - Google will stop accepting new apps with a build below 29 some time this year.

  5. #5
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    mrknd94's Avatar
    Join Date
    Jun 2017
    Location
    United Kingdom
    Posts
    23
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I've figured it out. Thanks guys! I appreciate the help :-)

Similar Threads

  1. Replies: 56
    Last Post: 26th December 2017, 08:53 PM
  2. Build failed Android
    By Melubnio in forum Android Export Module 2.5
    Replies: 2
    Last Post: 17th October 2016, 04:32 PM
  3. Help: Android build failed?
    By King_Cool in forum Android Export Module 2.5
    Replies: 2
    Last Post: 30th January 2016, 01:44 AM
  4. Android build failed to generate apk
    By ramyhakam in forum Android Export Module 2.5
    Replies: 8
    Last Post: 26th January 2015, 10:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •