User Tag List

Results 1 to 9 of 9

Thread: [292.26]WARNING: The option 'android.useDeprecatedNdk' is deprecated.

  1. #1
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)

    Join Date
    Sep 2019
    Posts
    60
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Exclamation [292.26]WARNING: The option 'android.useDeprecatedNdk' is deprecated.

    Export to Android:
    The build API 29 was set up in V292.22 and the compilation was successful.
    After upgrading to V292.26, compilation failed.

    The minimum is set to 6.0 or 4.3, and the target is set to 10.0 or 7.0.None of these attempts were successful.

  2. #2
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)

    Join Date
    Sep 2019
    Posts
    60
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    > Configure project :app
    WARNING: The option 'android.useDeprecatedNdk' is deprecated.
    The current default is 'false'.
    It has been removed from the current version of the Android Gradle plugin.
    NdkCompile is no longer supported
    IOException: https://dl.google.com/android/reposi...ons_list-3.xml
    java.io.IOException: Unable to tunnel through proxy. Proxy returns "HTTP/1.1 400 Bad Request"
    IOException: https://dl.google.com/android/reposi...ons_list-2.xml
    java.io.IOException: Unable to tunnel through proxy. Proxy returns "HTTP/1.1 400 Bad Request"
    IOException: https://dl.google.com/android/reposi...ons_list-1.xml
    java.io.IOException: Unable to tunnel through proxy. Proxy returns "HTTP/1.1 400 Bad Request"
    Failed to download any source lists!
    IO exception while downloading manifest:
    java.io.IOException: Unable to tunnel through proxy. Proxy returns "HTTP/1.1 400 Bad Request"
    at sun.net.http://www.protocol.http.HttpURLConn...ion.java:2142)
    at sun.net.http://www.protocol.https.AbstractDe...tion.java:183)
    at sun.net.http://www.protocol.https.HttpsURLCo...Impl.java:162)
    at com.android.sdklib.repository.legacy.remote.intern al.DownloadCache.openUrl(DownloadCache.java:247)
    at com.android.sdklib.repository.legacy.remote.intern al.DownloadCache.downloadAndCache(DownloadCache.ja va:624)
    at com.android.sdklib.repository.legacy.remote.intern al.DownloadCache.openCachedUrl(DownloadCache.java: 455)
    at com.android.sdklib.repository.legacy.LegacyDownloa der.downloadAndStream(LegacyDownloader.java:61)
    at com.android.repository.impl.downloader.LocalFileAw areDownloader.downloadAndStream(LocalFileAwareDown loader.java:51)
    at com.android.repository.impl.manager.RemoteRepoLoad erImpl.lambda$fetchPackages$0(RemoteRepoLoaderImpl .java:139)
    at java.util.concurrent.Executors$RunnableAdapter.cal l(Executors.java:511)
    at java.util.concurrent.FutureTask.run(FutureTask.jav a:266)
    at java.util.concurrent.ThreadPoolExecutor.runWorker( ThreadPoolExecutor.java:1149)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run (ThreadPoolExecutor.java:624)
    at java.lang.Thread.run(Thread.java:748)

    Still waiting for package manifests to be fetched remotely.

    FAILURE: Build failed with an exception.

    * What went wrong:
    Could not determine the dependencies of task ':app:compileDebugJavaWithJavac'.
    > Failed to find Build Tools revision 29.0.2

    * Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

  3. #3
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)

    Join Date
    Sep 2019
    Posts
    60
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    I searched the Internet for some solutions and made some upgrades.
    Now:

    studio64_n4Hp9Y0IQI.png

    studio64_QmiFMuyfMj.png

    studio64_uwnUF8SWw5.png


    But the breakdown is still there

  4. #4
    Clickteam Clickteam

    Join Date
    Jun 2006
    Location
    France
    Posts
    13,713
    Mentioned
    251 Post(s)
    Tagged
    3 Thread(s)
    maybe uninstall the NDK? I think you
    don't need it to build fusion apps. Also make sure the Android build tools for API 29 are installed if the Build API property is set to 29 in your app.

  5. #5
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)

    Join Date
    Sep 2019
    Posts
    60
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    I've uninstalled the NDK.
    In Fusion, the path of Android SDK is modified as follows:C:\AndroidSDK
    I set the wrong path before (the path of gradle)
    Now, the error is still related to the NDK.

  6. #6
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)

    Join Date
    Sep 2019
    Posts
    60
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    > Configure project :app
    WARNING: The option 'android.useDeprecatedNdk' is deprecated.
    The current default is 'false'.
    It has been removed from the current version of the Android Gradle plugin.
    NdkCompile is no longer supported

    > Task :app:preBuild UP-TO-DATE
    > Task :app:preDebugBuild UP-TO-DATE
    > Task :app:compileDebugAidl NO-SOURCE
    > Task :app:compileDebugRenderscript NO-SOURCE
    > Task :app:generateDebugBuildConfig
    > Task :app:generateDebugResValues
    > Task :app:generateDebugResources
    > Task :app:mergeDebugResources FAILED
    > Task :app:javaPreCompileDebug

    FAILURE: Build failed with an exception.

    * What went wrong:
    Execution failed for task ':app:mergeDebugResources'.
    > Could not resolve all files for configuration ':app:debugRuntimeClasspath'.
    > Could not resolve com.android.support:support-v4:27.1.1.
    Required by:
    project :app
    > Could not resolve com.android.support:support-v4:27.1.1.
    > Could not get resource 'https://dl.google.com/dl/android/maven2/com/android/support/support-v4/27.1.1/support-v4-27.1.1.pom'.
    > Could not GET 'https://dl.google.com/dl/android/maven2/com/android/support/support-v4/27.1.1/support-v4-27.1.1.pom'. Received status code 400 from server: Bad Request
    > Could not resolve com.android.support:support-v4:27.1.1.
    > Could not get resource 'https://jcenter.bintray.com/com/android/support/support-v4/27.1.1/support-v4-27.1.1.pom'.
    > Could not GET 'https://jcenter.bintray.com/com/android/support/support-v4/27.1.1/support-v4-27.1.1.pom'. Received status code 400 from server: Bad Request
    > Could not resolve com.android.support:support-v4:27.1.1.
    > Could not get resource 'https://repo.maven.apache.org/maven2/com/android/support/support-v4/27.1.1/support-v4-27.1.1.pom'.
    > Could not GET 'https://repo.maven.apache.org/maven2/com/android/support/support-v4/27.1.1/support-v4-27.1.1.pom'. Received status code 400 from server: Bad Request
    > Could not resolve com.android.support:support-v4:27.1.1.
    > Could not get resource 'https://maven.google.com/com/android/support/support-v4/27.1.1/support-v4-27.1.1.pom'.
    > Could not GET 'https://maven.google.com/com/android/support/support-v4/27.1.1/support-v4-27.1.1.pom'. Received status code 400 from server: Bad Request
    > Could not resolve com.android.support:appcompat-v7:27.1.1.
    Required by:
    project :app
    > Could not resolve com.android.support:appcompat-v7:27.1.1.
    > Could not get resource 'https://dl.google.com/dl/android/maven2/com/android/support/appcompat-v7/27.1.1/appcompat-v7-27.1.1.pom'.
    > Could not GET 'https://dl.google.com/dl/android/maven2/com/android/support/appcompat-v7/27.1.1/appcompat-v7-27.1.1.pom'. Received status code 400 from server: Bad Request
    > Could not resolve com.android.support:appcompat-v7:27.1.1.
    > Could not get resource 'https://jcenter.bintray.com/com/android/support/appcompat-v7/27.1.1/appcompat-v7-27.1.1.pom'.
    > Could not GET 'https://jcenter.bintray.com/com/android/support/appcompat-v7/27.1.1/appcompat-v7-27.1.1.pom'. Received status code 400 from server: Bad Request
    > Could not resolve com.android.support:appcompat-v7:27.1.1.
    > Could not get resource 'https://repo.maven.apache.org/maven2/com/android/support/appcompat-v7/27.1.1/appcompat-v7-27.1.1.pom'.
    > Could not GET 'https://repo.maven.apache.org/maven2/com/android/support/appcompat-v7/27.1.1/appcompat-v7-27.1.1.pom'. Received status code 400 from server: Bad Request
    > Could not resolve com.android.support:appcompat-v7:27.1.1.
    > Could not get resource 'https://maven.google.com/com/android/support/appcompat-v7/27.1.1/appcompat-v7-27.1.1.pom'.
    > Could not GET 'https://maven.google.com/com/android/support/appcompat-v7/27.1.1/appcompat-v7-27.1.1.pom'. Received status code 400 from server: Bad Request

    * Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

    * Get more help at https://help.gradle.org

    BUILD FAILED in 1s
    4 actionable tasks: 4 executed

  7. #7
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)

    Join Date
    Sep 2019
    Posts
    60
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    I installed these Android SDK build-Tools versions:
    30.0.1
    29.0.3
    29.0.2
    29.0.0
    28.0.3
    28.0.2

    -------------------
    Will it be automatically identified by API when compiled?
    Or how do I set it up?

  8. #8
    Clickteam Clickteam

    Join Date
    Jun 2006
    Location
    France
    Posts
    13,713
    Mentioned
    251 Post(s)
    Tagged
    3 Thread(s)
    Actually the NDK error is a simple warning, I think it's not important. Not sure what happens.

    Your Android Studio installation is unusual, usually the Android SDK is installed in C:\Users\YourUserName\AppData\Local\Android\Sdk.

  9. #9
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)

    Join Date
    Sep 2019
    Posts
    60
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    There's nothing wrong with the path, I set it up deliberately.
    According to your hint, I reinstalled the API 29 SDK, and I set GRADLE_USER_HOME, which was not set before (suspect related to this).
    Android Studio has downloaded a few more Jars that appear to be related to the phone this time.

    Now, it's finally working!Compile successfully!Excited!
    Thanks for your help!

Similar Threads

  1. Option: Switch Touch Joystick to D-Pad (ios, android)
    By iamjot in forum iOS Export Module 2.5
    Replies: 8
    Last Post: 16th April 2016, 02:43 PM
  2. Replies: 2
    Last Post: 25th January 2015, 09:26 AM
  3. Android Exporter Option not appear in Fusion 2.5
    By cheanary in forum Android Export Module 2.5
    Replies: 2
    Last Post: 2nd January 2015, 08:51 PM
  4. Built in IOS 8.0 warning "TransactionReceipt" is deprecated
    By Decoamorim in forum iOS Export Module 2.5
    Replies: 3
    Last Post: 30th December 2014, 08:33 AM
  5. Android option..compass and location...
    By KLiK-iT in forum Android Export Module 2.5
    Replies: 0
    Last Post: 19th July 2014, 07:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •