User Tag List

Results 1 to 10 of 10

Thread: Sample pan on iOS doesn't work

  1. #1
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)iOS Export Module (Steam)
    evi1ove's Avatar
    Join Date
    Jun 2014
    Location
    Kyiv, Ukraine
    Posts
    77
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Exclamation Sample pan on iOS doesn't work

    Dear community!
    I ran into a problem with sample pan on ios. Pan is set by the formula, the value is shown on the counter. On Windows and Android everything works correctly, the counter shows the correct value and the sound plays as expected. But on ios - the value on the counter is correct, but regardless of it, the sound is not reproduced correctly, the balance is always 0 and the sound is reproduced from both headphones. Using Channel pan does not change anything, the result is the same. Please advice me how is it possible to solve this problem? Is this a bug or some feature of the sample pan on ios that I do not take into account?
    MF2 version is R292.26.

  2. #2
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,650
    Mentioned
    280 Post(s)
    Tagged
    4 Thread(s)
    can you show a small mfa for this?
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  3. #3
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)iOS Export Module (Steam)
    evi1ove's Avatar
    Join Date
    Jun 2014
    Location
    Kyiv, Ukraine
    Posts
    77
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Fernando View Post
    can you show a small mfa for this?
    Fernando it's a bug i think. I checked right now, with simple test on ios, where i set sample pan -80, without any formula, but it doesn't work, sound is reproduced from both headphones. I thought the problem with 292.26, because i have old version saves, and they worked correctly. For example, it's simple test doesn't work now:
    https://drive.google.com/drive/folde...uV?usp=sharing

  4. #4
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,650
    Mentioned
    280 Post(s)
    Tagged
    4 Thread(s)
    Thanks for the example, if the sound is a pure WAV it work OK, i will check why.
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  5. #5
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)iOS Export Module (Steam)
    evi1ove's Avatar
    Join Date
    Jun 2014
    Location
    Kyiv, Ukraine
    Posts
    77
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Fernando View Post
    Thanks for the example, if the sound is a pure WAV it work OK, i will check why.
    Ok, thank you for advise. But problem is with OGG, and with WAV too. I have checked both variants.

  6. #6
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,650
    Mentioned
    280 Post(s)
    Tagged
    4 Thread(s)
    mm may i have that wav to check here? All my wav are OK, tested with your example a little bit modified
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  7. #7
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)iOS Export Module (Steam)
    evi1ove's Avatar
    Join Date
    Jun 2014
    Location
    Kyiv, Ukraine
    Posts
    77
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Fernando View Post
    mm may i have that wav to check here? All my wav are OK, tested with your example a little bit modified
    That wav was in example. And it works? How? Maybe problem with xcode. What xcode version do you have?

  8. #8
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,650
    Mentioned
    280 Post(s)
    Tagged
    4 Thread(s)
    no i added is one from me that i add as second frame to compare behavior
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  9. #9
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)iOS Export Module (Steam)
    evi1ove's Avatar
    Join Date
    Jun 2014
    Location
    Kyiv, Ukraine
    Posts
    77
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Fernando View Post
    no i added is one from me that i add as second frame to compare behavior
    And what, it's works or no?

  10. #10
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,650
    Mentioned
    280 Post(s)
    Tagged
    4 Thread(s)
    as mentioned using a WAV (PCM) work OK, but still not found the reason why the conversion from OGG or MP3 doesn't work

    ==================================================

    Seems that is working fine with Mono sounds, i can not find the reason why spatial is not working in stereo sounds less than 15 secs

    notice that if you increase your sound above 15 secs it will be played by Audioplayer and there PAN work perfect for stereo sounds.
    Regards,


    Fernando Vivolo

    ... new things are coming ...

Similar Threads

  1. Replies: 3
    Last Post: 8th November 2019, 04:41 PM
  2. Play Sample File on a specific Channel, doesn't seem to work?
    By steakor in forum Android Export Module 2.5
    Replies: 7
    Last Post: 15th March 2019, 12:10 AM
  3. Sample doesn't work
    By Sluke35 in forum Fusion 2.5
    Replies: 4
    Last Post: 29th May 2016, 02:06 PM
  4. No Sample Is Playing does not work on iOS (257.20)
    By Diablohead in forum iOS Export Module Version 2.0
    Replies: 0
    Last Post: 23rd June 2013, 12:15 PM
  5. Playing sample from file doesn't work
    By chrilley in forum Multimedia Fusion 2 - Technical Support
    Replies: 5
    Last Post: 17th August 2008, 11:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •