User Tag List

Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11

Thread: Could not find or use auto-linked framework 'FBLPromises'

  1. #1
    Clicker Fusion 2.5
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    tk22's Avatar
    Join Date
    Dec 2014
    Posts
    92
    Mentioned
    9 Post(s)
    Tagged
    0 Thread(s)

    Exclamation Could not find or use auto-linked framework 'FBLPromises'

    I am having trouble building my project on xcode it fails and gives this error

    Code:
    ld: warning: Could not find or use auto-linked framework 'FBLPromises'
    Undefined symbols for architecture x86_64:
      "_OBJC_CLASS_$_JSContext", referenced from:
          objc-class-ref in GoogleMobileAds(GADOMIDLightJSExecutor_d3a64554b4a6045014e82064e4e99494.o)
    ld: symbol(s) not found for architecture x86_64
    clang: error: linker command failed with exit code 1 (use -v to see invocation)
    I have followed the instructions here added the frame works and SKAdNetworkIdentifier and -ObjC

    I am using CTF2.5 build R292.26 on steam and google ads sdk 7.64

    @Fernando is there something i am missing?

  2. #2
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,676
    Mentioned
    284 Post(s)
    Tagged
    4 Thread(s)
    i am checking what are the changes needed @tk22 @Dobermann

    ============================================


    @tk22 @Dobermann i just tested admob with 7.64 SDK the only missing framework is JavaScriptCore.framework

    and target version 9.0
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  3. #3
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleXNA Export Module
    Dobermann's Avatar
    Join Date
    Feb 2009
    Location
    France
    Posts
    776
    Mentioned
    37 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Fernando View Post
    i am checking what are the changes needed @tk22 @Dobermann

    ============================================


    @tk22 @Dobermann i just tested admob with 7.64 SDK the only missing framework is JavaScriptCore.framework

    and target version 9.0
    So we need a new version of the iphone runtime or we need to add it manually?

  4. #4
    Clicker Fusion 2.5
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    tk22's Avatar
    Join Date
    Dec 2014
    Posts
    92
    Mentioned
    9 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Fernando View Post
    i am checking what are the changes needed @tk22 @Dobermann

    ============================================


    @tk22 @Dobermann i just tested admob with 7.64 SDK the only missing framework is JavaScriptCore.framework

    and target version 9.0
    yes ty it worked! I added JavaScriptCore.framework and set target version to 9.0
    Thank you for checking Fernando

  5. #5
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,676
    Mentioned
    284 Post(s)
    Tagged
    4 Thread(s)
    Quote Originally Posted by Dobermann View Post
    So we need a new version of the iPhone runtime or we need to add it manually?
    External framework needed by external SDK must be added by developer in their project.
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  6. #6
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleXNA Export Module
    Dobermann's Avatar
    Join Date
    Feb 2009
    Location
    France
    Posts
    776
    Mentioned
    37 Post(s)
    Tagged
    0 Thread(s)
    Thanks it worked. So we can use last SDK but can we make our app compatible with iOS14+ standards?
    I mean, they ask us to add "Privacy - Tracking Usage Description" key in ou plist file, but this item doesn't exist. They also speak about calling "requestTrackingAuthorizationWithCompletionHandler " before to display ads, but i thinks it's something we can't do on our side right?

    https://developers.google.com/admob/ios/ios14

  7. #7
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,676
    Mentioned
    284 Post(s)
    Tagged
    4 Thread(s)
    tracking needs to be added in future version when android is fully migrated to androidX so can be present in both runtimes, but this doesn't stop to get full ads

    this feature you mention is a regulation asked where to be able to track an application now requieres the user approval, since actual object doesn't do tracking in an app this methods is not required.
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  8. #8
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleiOS Export Module

    Join Date
    Jun 2015
    Posts
    75
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Hi Fernando. I am getting a similar message. Same AdMob as you. Adding the JavaScriptCore removed 1 of 3 issues related. I've attached screenshots. Any advice?

    s1.jpg
    Untitled-2.jpg
    Untitled-3.jpg

  9. #9
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,676
    Mentioned
    284 Post(s)
    Tagged
    4 Thread(s)
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  10. #10
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleXNA Export Module
    Dobermann's Avatar
    Join Date
    Feb 2009
    Location
    France
    Posts
    776
    Mentioned
    37 Post(s)
    Tagged
    0 Thread(s)
    Targeting iOS 9 seems to don't be required, as i forgot to do it on one of my app (so it's still targeting iOS 8) and it got compiled with no error and published with last Admob Sdk. Just saying.

Page 1 of 2 1 2 LastLast

Similar Threads

  1. [Fusion 3] Linked events
    By Darkhog in forum Fusion 2.5
    Replies: 0
    Last Post: 7th November 2016, 09:19 PM
  2. Linked to. Everyone please ignore.
    By legocacher in forum File Archive
    Replies: 4
    Last Post: 6th August 2010, 09:01 PM
  3. Linked Comments
    By Blood_Wist in forum Multimedia Fusion 2 - Technical Support
    Replies: 1
    Last Post: 16th September 2009, 03:59 PM
  4. where can I get the Phizix linked object tutorial
    By Oreo in forum Multimedia Fusion 2 - Technical Support
    Replies: 0
    Last Post: 8th January 2009, 11:24 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •