User Tag List

Results 1 to 6 of 6

Thread: Need enemy to launch an object at a certain animation frame

  1. #1
    Clicker Fusion 2.5

    Join Date
    Dec 2019
    Posts
    113
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Need enemy to launch an object at a certain animation frame

    I set the enemy to shoot at the player at a certain animation frame with the launching animation, but for some reason, it's not doing it. It waits until it starts moving again to shoot. I'm using loops. Any way to fix this?
    Attached files Attached files

  2. #2
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export Module
    Janette5's Avatar
    Join Date
    Dec 2014
    Location
    Western Cape, SA
    Posts
    1,159
    Mentioned
    199 Post(s)
    Tagged
    0 Thread(s)
    If something must happen while a loop is running, you need to include that in the loops. I changed it in your example lines 98 + 99 in your global events - I think that's what you were referring to.

    However, I can't really tell if it makes a difference or not as I'm not sure what should be happening there.
    Attached files Attached files

  3. #3
    Clicker Fusion 2.5

    Join Date
    Dec 2019
    Posts
    113
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    That didn't make a difference. It's not supposed to move when it shoots. It's supposed to shoot when the animation is at a certain frame, finish the animation, and then start moving.

  4. #4
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export Module
    Janette5's Avatar
    Join Date
    Dec 2014
    Location
    Western Cape, SA
    Posts
    1,159
    Mentioned
    199 Post(s)
    Tagged
    0 Thread(s)
    As far as I can see there isn't any problem with your code. It works, but there is a problem with Fusion's handling of the function - launch an object, it seems to delay executing that command.

    If I change that to manually create and send the object - the GoopsterShot - then everything works like you want - the Goopster stops, shoots, then continues moving.

    Note that the animation counts from 0 - so frame 2, is the 3rd frame of 5 frames - so the Goopster almost immediately starts moving after shooting. (I slowed down the animation to a speed of 5 - where I could clearly see the Goopster stops, then shoots, then continues moving.)

    Attached is what I did.
    Attached files Attached files

  5. #5
    Clicker Fusion 2.5

    Join Date
    Dec 2019
    Posts
    113
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Good to go. Thanks. By the way, you said that you set the animation speed to 5. When I checked your MFA, it was set to 30.

  6. #6
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export Module
    Janette5's Avatar
    Join Date
    Dec 2014
    Location
    Western Cape, SA
    Posts
    1,159
    Mentioned
    199 Post(s)
    Tagged
    0 Thread(s)
    I set it to 5 to test it - then set it back to 30 - the speed you had it - before uploading it.

Similar Threads

  1. Replies: 6
    Last Post: 9th November 2018, 08:28 AM
  2. Throw knife when playing frame 4 of animation Launch
    By dantehavenaar in forum Fusion 2.5
    Replies: 8
    Last Post: 12th October 2017, 08:41 PM
  3. Replies: 1
    Last Post: 27th January 2017, 03:18 PM
  4. Replies: 2
    Last Post: 27th July 2015, 10:48 AM
  5. Launch an object and animation question
    By ASD in forum Multimedia Fusion 2 - Technical Support
    Replies: 3
    Last Post: 31st January 2010, 11:16 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •