User Tag List

Results 1 to 5 of 5

Thread: Mystery Fonts error showing

  1. #1
    Forum Moderator

    Fusion 2.5 MacFusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleMac Export ModuleUniversal Windows Platform Export ModuleSWF Export ModuleInstall Creator Pro
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)
    Perry's Avatar
    Join Date
    Dec 2013
    Location
    Watertown, WI
    Posts
    4,415
    Mentioned
    60 Post(s)
    Tagged
    0 Thread(s)

    Mystery Fonts error showing

    All the sudden I am getting this popup in my project, and can't seem to get rid of it.

    I am just using the standard fonts, so idk what is happening.
    This started after I installed the last 2 updates.

    How do I get rid of those errors. Is there a way to find out, where those fonts are used?
    f1.PNG

    f2.PNG

  2. #2
    Clickteam Clickteam

    Join Date
    Jun 2006
    Location
    France
    Posts
    13,988
    Mentioned
    279 Post(s)
    Tagged
    3 Thread(s)
    This new message is displayed in DX11 mode when Fusion cannot find True Type fonts to embed in the EXE (as the DX11 runtime only supports true type fonts). Those fonts will be replaced by others at runtime. I think the message can display standard font names if the font is not installed and Windows replaced it by another one, but I need to check.

    I think Terminal is not a True Type font. What's the last one in the Data Elements screen shot?

  3. #3
    Forum Moderator

    Fusion 2.5 MacFusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleMac Export ModuleUniversal Windows Platform Export ModuleSWF Export ModuleInstall Creator Pro
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)
    Perry's Avatar
    Join Date
    Dec 2013
    Location
    Watertown, WI
    Posts
    4,415
    Mentioned
    60 Post(s)
    Tagged
    0 Thread(s)
    I have everything set for Android.

    Not sure what the last one is.. I checked and I only use the Tahoma Font and nothing else.
    so I am puzzled as of why the rest is showing.
    it's randomly showing a japanse font as well for the 1st line. no idea where it gets it from

    set it to Directx9, and the box is gone.


    edit:
    @Yves
    the odd font is coming from the Admob object

  4. #4
    Clickteam Clickteam

    Join Date
    Jun 2006
    Location
    France
    Posts
    13,988
    Mentioned
    279 Post(s)
    Tagged
    3 Thread(s)
    I see, it's a bug in lots of objects made by Fernando, a function says the object supports text features although it doesn't, so the font name gets randomly initialized. He probably created all his objects from an original bugged template. I'll tell him what to change in those objects. In the meantime I attach a fixed version of Admob.
    Attached files Attached files

  5. #5
    Forum Moderator

    Fusion 2.5 MacFusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleMac Export ModuleUniversal Windows Platform Export ModuleSWF Export ModuleInstall Creator Pro
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)
    Perry's Avatar
    Join Date
    Dec 2013
    Location
    Watertown, WI
    Posts
    4,415
    Mentioned
    60 Post(s)
    Tagged
    0 Thread(s)
    That was quick

    Thank you @Yves .

Similar Threads

  1. Android list and button fonts arenít showing correctly
    By ratty in forum Android Export Module 2.5
    Replies: 3
    Last Post: 6th January 2020, 02:56 PM
  2. Replies: 3
    Last Post: 14th November 2019, 08:53 PM
  3. Admob Ads not showing, getting Code Error
    By Anton in forum Android Export Module 2.5
    Replies: 6
    Last Post: 14th June 2018, 09:14 AM
  4. Two frames showing at same time error
    By droberson in forum Fusion 2.5
    Replies: 1
    Last Post: 16th March 2015, 10:21 PM
  5. Isometric Mystery...
    By WEich1213 in forum Fusion 2.5
    Replies: 1
    Last Post: 21st March 2014, 07:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •