User Tag List

Results 1 to 10 of 10

Thread: Active Picture Object and URL images

  1. #1
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleXNA Export Module
    Dobermann's Avatar
    Join Date
    Feb 2009
    Location
    France
    Posts
    834
    Mentioned
    38 Post(s)
    Tagged
    0 Thread(s)

    Active Picture Object and URL images

    Hello there,

    I'm using Active pictures object to load images from my FTP, while it works greate on iOS and Android exporter, it doesn't work at all on Windows and UWP exporters, it simply don't load anything... Any idea on whay i'm doing wrong?

    + NOT message-img: a picture is loaded
    message-img : New picture : "http://apps.dobermannstudios.com/spartanfirefight/img/standard.jpg"
    message-img : Set Size to (380, 80)

  2. #2
    Clickteam Clickteam

    Join Date
    Jun 2006
    Location
    France
    Posts
    13,956
    Mentioned
    275 Post(s)
    Tagged
    3 Thread(s)
    The APO doesn't download images on Windows, you have to use the Download object for this.

    It works on UWP though, I've just tested it with the link you mention above.

  3. #3
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleXNA Export Module
    Dobermann's Avatar
    Join Date
    Feb 2009
    Location
    France
    Posts
    834
    Mentioned
    38 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Yves View Post
    The APO doesn't download images on Windows, you have to use the Download object for this.

    It works on UWP though, I've just tested it with the link you mention above.
    Ah, maybe it doesn't work because of the GET object issue. On UWP if you send two "GET" commands (with two separate GET Objects) only one of the "ON GET COMPLETE" will be triggered. So maybe it's why i can't load a picture on my UWP game...

    And thank you for the tip about the windows process, now it's working!


    Edit:

    I've made a MFA where the APO doesn't show the image, i've set the same parameters as my game so maybe it could be coming from the get object, or the layers or something else...
    Test_APO.mfa

  4. #4
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export Module

    Join Date
    Dec 2013
    Posts
    156
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    get.jpg

    This is what I get.

  5. #5
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleXNA Export Module
    Dobermann's Avatar
    Join Date
    Feb 2009
    Location
    France
    Posts
    834
    Mentioned
    38 Post(s)
    Tagged
    0 Thread(s)
    Yes on windows it works (thanks to Yves types about download object), but on UWP i can't get it to work the standard way (like i do on Android and iOS).

  6. #6
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleXNA Export Module
    Dobermann's Avatar
    Join Date
    Feb 2009
    Location
    France
    Posts
    834
    Mentioned
    38 Post(s)
    Tagged
    0 Thread(s)
    @Yves can you please look to my MFA to see why it doesn't work on UWP? Maybe i'm doing something wrong, or maybe the APO object doesn't work if we use an action to paste the link...

  7. #7
    Clickteam Clickteam

    Join Date
    Jun 2006
    Location
    France
    Posts
    13,956
    Mentioned
    275 Post(s)
    Tagged
    3 Thread(s)
    I'm sorry I'm extremely busy right now, it's NOT the APO object as I've already checked it loads your URL fine, so probably your event is not executed, the name is incorrect, etc.

  8. #8
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleXNA Export Module
    Dobermann's Avatar
    Join Date
    Feb 2009
    Location
    France
    Posts
    834
    Mentioned
    38 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Yves View Post
    I'm sorry I'm extremely busy right now, it's NOT the APO object as I've already checked it loads your URL fine, so probably your event is not executed, the name is incorrect, etc.
    Everything works on Android, iOS and PC (with the dwnload objects as you said), but not on UWP. The event is simple, it just pass the same URL into an event to the APO. I'm pretty sure the issue comes from that. If i try to put the URL directly in the object properties it should work i guess, but i need a dynamic URL. I'll try to contact Fernando.

  9. #9
    Clickteam Clickteam

    Join Date
    Jun 2006
    Location
    France
    Posts
    13,956
    Mentioned
    275 Post(s)
    Tagged
    3 Thread(s)
    No, I didn't enter the URL in the object's properties, I tested with your URL with a simple New Picture action and the URL as parameter and it worked. Did you test this without any other event?

  10. #10
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleXNA Export Module
    Dobermann's Avatar
    Join Date
    Feb 2009
    Location
    France
    Posts
    834
    Mentioned
    38 Post(s)
    Tagged
    0 Thread(s)
    I use this where filename is set to "million.jpg" or "standard.jpg" like in the first example:
    Code:
    * filename <> ""
    + NOT message-img: a picture is loaded
    + Only one action when event loops
    
    		 message-img : New picture : "http://apps.dobermannstudios.com/spartanfirefight/img/" + filename
    		 message-img : Set Size to (380, 80)
    I can confirm that the event "NOT APO: a picture is loaded" does not work on UWP, removing it made everything to works.

Similar Threads

  1. Replies: 0
    Last Post: 26th February 2016, 10:06 AM
  2. Replies: 2
    Last Post: 15th May 2015, 06:59 PM
  3. Quick, possibly stupid, question about Active Picture images
    By CBSection31 in forum iOS Export Module Version 2.0
    Replies: 5
    Last Post: 18th February 2014, 12:15 AM
  4. Take picture and make from it Active Object / Active picture
    By qenio in forum Android Export Module Version 2.0
    Replies: 3
    Last Post: 3rd February 2014, 08:34 AM
  5. Good Example of the Animated Picture Object using Images
    By Gullyking in forum Multimedia Fusion 2 - Technical Support
    Replies: 0
    Last Post: 26th June 2012, 07:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •