User Tag List

Page 22 of 36 FirstFirst ... 12 20 21 22 23 24 32 ... LastLast
Results 211 to 220 of 357

Thread: Build 293.1 - Release version

  1. #211
    Clickteam Clickteam

    Join Date
    Jun 2006
    Location
    France
    Posts
    14,047
    Mentioned
    279 Post(s)
    Tagged
    3 Thread(s)
    The formats that are supported by default by DirectShow are listed here: https://docs.microsoft.com/en-us/win...-in-directshow

    For other formats you need to install specific codecs.

    In the example you posted, the MP4 file uses the H.264 codec, that is in theory supported by default. Do you have problems with this file?

    BTW in your example there is a mistake in your filename, it should be AppPath$ instead of AppDir$ (as AppDir$ doesn't contain the drive name), and "video.mp4" instead of "\video.mp4" (as AppPaths$ ends with a '\').

  2. #212
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Firefly 3D Module (Steam)
    Tyrexchip's Avatar
    Join Date
    Jan 2016
    Posts
    11
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Yves View Post
    The formats that are supported by default by DirectShow are listed here: https://docs.microsoft.com/en-us/win...-in-directshow

    For other formats you need to install specific codecs.

    In the example you posted, the MP4 file uses the H.264 codec, that is in theory supported by default. Do you have problems with this file?

    BTW in your example there is a mistake in your filename, it should be AppPath$ instead of AppDir$ (as AppDir$ doesn't contain the drive name), and "video.mp4" instead of "\video.mp4" (as AppPaths$ ends with a '\').
    Going to call "Use Media Foundation with DirectX 11" UMFDX11

    Swapped the AppDir$ for AppPath$. AVI and WMV work fine with DX9 and DX11 even with UMFDX11 ticked. just mp4s don't work at all, only when its in dx11 and UMFDX11 is ticked.

    Made two test EXEs that plays MP4, WMV, and AVI. One is DX9 other is DX11. Gave them to 5 friends to test. Each one reported back that same file on DX9 MP4 didn't show, but WMV and AVI showed up on all.
    I Don't think it's just me on this if others isn't working

    Link to the zip I sent them with MFA
    Pressing 1 plays MP4, 2 plays WMV and 3 plays AVI.

  3. #213
    Clickteam Clickteam

    Join Date
    Jun 2006
    Location
    France
    Posts
    14,047
    Mentioned
    279 Post(s)
    Tagged
    3 Thread(s)
    Quote Originally Posted by Tyrexchip View Post
    Going to call "Use Media Foundation with DirectX 11" UMFDX11

    Swapped the AppDir$ for AppPath$. AVI and WMV work fine with DX9 and DX11 even with UMFDX11 ticked. just mp4s don't work at all, only when its in dx11 and UMFDX11 is ticked.

    Made two test EXEs that plays MP4, WMV, and AVI. One is DX9 other is DX11. Gave them to 5 friends to test. Each one reported back that same file on DX9 MP4 didn't show, but WMV and AVI showed up on all.
    I Don't think it's just me on this if others isn't working

    Link to the zip I sent them with MFA
    Pressing 1 plays MP4, 2 plays WMV and 3 plays AVI.
    Tested on my machine, everything works fine, the MP4 file plays correctly.

    Tested on the Windows sandbox, i.e. quite similar to a fresh Windows 10 install, the MP4 doesn't play. So probably the H.264 codec is not installed by default, and it was installed on my machine by some application. So you have to install a H.264 DirectShow codec if you want to play this file.

  4. #214
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Firefly 3D Module (Steam)
    Tyrexchip's Avatar
    Join Date
    Jan 2016
    Posts
    11
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Yves View Post
    Tested on my machine, everything works fine, the MP4 file plays correctly.

    Tested on the Windows sandbox, i.e. quite similar to a fresh Windows 10 install, the MP4 doesn't play. So probably the H.264 codec is not installed by default, and it was installed on my machine by some application. So you have to install a H.264 DirectShow codec if you want to play this file.
    Is it possible for DX9 to have a toggle to use Media Foundation sometime in the future or a newer object? I looked more the forums and saw concept of a VLC object.

  5. #215
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleMac Export ModuleSWF Export ModuleXNA Export ModuleInstall Creator Pro
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    waw_demmon's Avatar
    Join Date
    Oct 2006
    Location
    Saguenay, Québec
    Posts
    306
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I notice that the Active picture seem to have some problem with physic movement after image change or hotspot change.

  6. #216
    Clickteam Clickteam

    Join Date
    Jun 2006
    Location
    France
    Posts
    14,047
    Mentioned
    279 Post(s)
    Tagged
    3 Thread(s)
    Quote Originally Posted by MuddyMole View Post
    Importing of sprite sheets in box mode is not working correctly when images have an alpha channel (it loads sprites in column order, instead of row order).
    I suspect it may be related to another issue, mentioned previously in the changelog:

    Build 292.5 - Change log
    ------------------------
    ...
    - Picture editor: wrong export of sprites sheets in box mode when images have an alpha channel.
    I cannot reproduce this, could you post an image file that contains images that are imported in the wrong order?

  7. #217
    Forum Moderator Fusion 2.5 MacFusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export Module
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)Firefly 3D Module (Steam)
    NaitorStudios's Avatar
    Join Date
    May 2010
    Location
    Brazil
    Posts
    484
    Mentioned
    9 Post(s)
    Tagged
    0 Thread(s)
    Effects/Shaders are great, but I think having more special variables like fPixelWidth/fPixelHeight would be nice, here some suggestions:

    fTime: Basically Fusion's internal timer being retrieved by the shader, would be pretty useful for spontaneously animated shader, if this can work with backdrops, it would be amazing so we could get animated backdrops!
    fResolution: A float2 that bundles the object/layer size in pixels, it should consider the current object scale.
    fMouse: Mouse pixel coords, basically a float2 that bundles xmouse and ymouse, should be relative to the object/layer.
    fPosition: The object/layer position in a float2, could be used to have a scrolling texture that's relative to the position of the object/layer without messing with parameters.

    Stacking shaders as well would be really useful, but I understand that it must be difficult to implement at this point...

    Changing a bit of subjects, I just noticed that we can copy behaviors from one object to another and it automatically replace all instances of the original object by the new one, which honestly got me amazed, never knew it could do that!
    I also thought about how BEHAVIORS could be more useful:

    First would be nice if we could have something like library does, where you could have a "Select existing behavior" button, it then shows a window with the current mfa and a list of mfas from a new special folder called "Behaviors", where people could put mfas containing actives with behaviors inside, clicking on the mfa (like in the library) it would show the objects icons and names of that mfa, clicking these objects it would show it's behaviors, selecting a behavior would copy this the selected objects, and with the amazing built-in feature that replaces the original object from the events with the current one, it would be a fantastic way of sharing custom stuff (Eg: custom movements, custom interface elements, AI related stuff, etc)
    Alternatively we could also have a new toolbar for behaviors, works exactly the same as the Library toolbar, but after double clicking a object it shows all its behaviors names... Double clicking the behavior name with object selected in frame or dragging it to a object would copy the behavior to the object...

    I hope I explained it well, cause it would be pretty cool
    But one thing that would make this extremely more useful would be the capability of add or remove behaviors of objects, so for example a custom movement or AI could be applied to objects during runtime, changing how it behaves, which makes total sense with the Behavior thing.

  8. #218
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    Volnaiskra's Avatar
    Join Date
    Jan 2014
    Location
    www.sprykegame.com
    Posts
    2,580
    Mentioned
    133 Post(s)
    Tagged
    0 Thread(s)
    One improvement I'd like to see regarding Behaviours is speeding up searching for them in Find All. When I do Find All with Behaviours unchecked, it takes less than half a second. When I do it with Behaviours checked, it takes about 7 seconds (ie. ~20 times longer). I use Find All dozens of times per session, so it's a big difference. And I don't actually have any objects with behaviours!

    To my [amateur] mind, it seems like there might be a simple solution. Have an internal list somewhere in Fusion that keeps track of which objects contain behaviours. Each time a behaviour is added, add that object to the list. (I assume something along theses lines is already being done to tell Fusion which icons to put a "B" on). Then, when performing a Find All search, don't search through every object to see if it has behaviours (which I assume is what's happening now). Only search the objects that appear on that list instead.

    On a related note, I really think "Objects" need to be unchecked in Find All by default, because the slowdown they cause is crazy. When I search with Objects checked, the search takes ~23 seconds. When unchecked it takes, like I said, less than half a second. It probably took me like two months to discover this difference though, and I'm sure many others are the same. I think it really undersells the awesomeness of this feature to present it in 'ultra-slow mode' by default.

  9. #219
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleUniversal Windows Platform Export ModuleSWF Export Module

    Join Date
    Jun 2014
    Posts
    62
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Don't know if this has been brought up by anyone else (apologies if it has), but I'm having an issue installing this update.

    Click team Fusion Developer 2.5 has not been totally installed because of the following reason:

    Examples/AdMob/Test AdMob iOS.mfa: This file contains invalid data (error 11FD)

    You will have to run this utility again to completely install Clickteam Fusion Developer 2.5

  10. #220
    Forum Moderator Fusion 2.5 MacFusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export Module
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)Firefly 3D Module (Steam)
    NaitorStudios's Avatar
    Join Date
    May 2010
    Location
    Brazil
    Posts
    484
    Mentioned
    9 Post(s)
    Tagged
    0 Thread(s)
    Could we get the index on the list of Alt Values/Strings for objects like it does on Global Values/Strings? It feels like this was overlooked...

Page 22 of 36 FirstFirst ... 12 20 21 22 23 24 32 ... LastLast

Similar Threads

  1. Build 289.0 - Beta version
    By Yves in forum Fusion 2.5
    Replies: 19
    Last Post: 28th May 2017, 08:06 PM
  2. Build 285.2 - beta version
    By Olivier in forum Fusion 2.5
    Replies: 39
    Last Post: 4th May 2016, 09:20 PM
  3. Build 285.0 - beta version
    By Yves in forum Fusion 2.5
    Replies: 69
    Last Post: 12th September 2015, 11:55 PM
  4. Build 284.2 - beta version
    By Yves in forum Fusion 2.5
    Replies: 89
    Last Post: 17th April 2015, 04:41 PM
  5. Build 283.0 - beta version
    By Yves in forum Fusion 2.5
    Replies: 89
    Last Post: 30th October 2014, 05:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •