User Tag List

Results 1 to 2 of 2

Thread: Sprite growing over 100x in side on specific animation

  1. #1
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)

    Join Date
    Feb 2015
    Posts
    49
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Sprite growing over 100x in side on specific animation

    https://www.youtube.com/watch?v=Hp_ghLvGf4A

    All code is at the start of video; keep an eye on the debugger, specifically the sprite's size.

    Video should be self explanatory but I will explain: This enemy is supposed to lunge at the player, it plays one animation while lunging and then changes the animation upon colliding with the player.

    So the first part works fine, but for some reason the second part of this animation, on the first frame it will cause the object to grow insanely huge for no reason. I've tried making separate animations that are the same thing but different slot/name and tried activating them on just a single hotkey instead of the collision, but no matter what I do the first frame of the Attack animation causes this problem. I've got absolutely no idea why, this has never happened to me before in an capacity.

    All of the other animations work fine, it's just this one specific one. Everything is the same, hotspots/action points, size of the frame etc...

  2. #2
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)

    Join Date
    Feb 2015
    Posts
    49
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Figured it out, I guess at some point the sprite had duplicated itself and was directly on top of the other, so they moved perfectly with each other. Deleted one and the one left started to work. How weird

Similar Threads

  1. Move sprite in a continuous side scrolling
    By Junix in forum Fusion 2.5
    Replies: 2
    Last Post: 24th October 2019, 03:57 PM
  2. I can't fix this specific animation problem
    By Sprayerdude220 in forum Fusion 2.5
    Replies: 4
    Last Post: 25th April 2018, 07:21 PM
  3. Server Side Saving/Loading iOS Specific
    By cfullerNY in forum iOS Export Module Version 2.0
    Replies: 6
    Last Post: 10th May 2013, 05:27 PM
  4. specific animation has played a specific frame?
    By mobichan in forum Multimedia Fusion 2 - Technical Support
    Replies: 15
    Last Post: 22nd April 2008, 04:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •