User Tag List

Results 1 to 4 of 4

Thread: Strange delay issue when pausing

  1. #1
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)

    Join Date
    Aug 2020
    Location
    Canada
    Posts
    32
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Strange delay issue when pausing

    Hello

    I am having a strange issue with a pause function I created, I uploaded a quick MFA I made to show this problem if anyone could help me figure this one out!

    The main frame contains a sub app which is where the entire game would be played (done to implement integer scaling based on user's resolution and screen size to keep the pixel art looking crisp).

    So there is a flag, on an active in the main frame called "Pauser". When the flag is set, the sub app pauses and hides, and layer 2 of the main frame (would be the pause menu) appears. When the flag is not set, the sub app resumes and shows itself again, and layer 2 hides.

    It's working fine but...

    There is a delay in resuming the sub app when after pausing and unpausing (flag = 0), which lasts for exactly the amount of time the game is paused (flag = 1).

    If you check out the MFA, run it with f8 not f7. G pauses, 1-4 sets window size.

    So in this case, I push G, the pause screen happens. If I leave it on there for 5 seconds, then push G to unpause, there is a 5 second wait until the sub app resumes. I added a moving object to observe this delay.

    I can't see a reason for this, but maybe one of you guys can.

    Thanks for any advice!
    Attached files Attached files

  2. #2
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCHTML5 Export ModuleiOS Export ModuleSWF Export ModuleFirefly 3D ModuleInstall Creator Pro
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    chrilley's Avatar
    Join Date
    Jul 2006
    Posts
    1,016
    Mentioned
    17 Post(s)
    Tagged
    1 Thread(s)
    Based on those conditions it looks like you are calling the pause/unpause loops for every tick, even when the app is already paused or unpaused. If you put an "Only one action when event loops" condition underneath the Flag is On/Off conditions on event 3 and 4 you'll make sure to only call the loop once.

  3. #3
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)

    Join Date
    Aug 2020
    Location
    Canada
    Posts
    32
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Holy moly thank you sir. Works perfectly.


    Enjoy the rest of your weekend!

  4. #4
    Clicker Fusion 2.5Fusion 2.5+ DLC

    Join Date
    Jan 2018
    Posts
    314
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    you can also add condition "paused=1" line 3 and condition "paused=0" line 4

Similar Threads

  1. Strange Issue with animations
    By TheHandwovenBox in forum Fusion 2.5
    Replies: 5
    Last Post: 1st December 2018, 12:56 PM
  2. Strange issue in Beta 285.5
    By Littlemaxy in forum Android Export Module 2.5
    Replies: 2
    Last Post: 23rd May 2016, 06:04 PM
  3. I have a strange INI issue
    By KLiK-iT in forum Fusion 2.5
    Replies: 4
    Last Post: 9th May 2016, 06:32 PM
  4. strange edit box issue
    By Redsquirrel in forum Fusion 2.5
    Replies: 0
    Last Post: 16th April 2015, 11:19 AM
  5. Strange Sub-App Issue
    By Uzalu in forum Multimedia Fusion 2 - Technical Support
    Replies: 4
    Last Post: 22nd December 2009, 01:53 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •