User Tag List

Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18

Thread: Fusion 2.5 Dev + is running in Pop!OS but can't run a frame

  1. #1
    Clicker

    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)

    Join Date
    Sep 2015
    Posts
    62
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Fusion 2.5 Dev + is running in Pop!OS but can't run a frame

    Hi all, I'm attempting to migrate away from Windows as a whole and have Fusion running well now via Proton 6.3-5 on Pop!OS.

    However I get an error when I attempt to run a frame or a program that says, "This application has been built with an incompatible version of Clickteam Fusion."

    I'm guessing it compiles ok but it isn't responding well to running the temporary executable.

    If I could get past this point, I could likely ditch Windows once and for all. Does anyone have any experience with this or ideas on a workaround?

    Thanks kindly for your time.

  2. #2
    Clicker

    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)

    Join Date
    Sep 2015
    Posts
    62
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi again. Yves, would I be better off reaching out directly to Clickteam customer service for this? Is the forum an incorrect place to posit the question above?

  3. #3
    Clickteam Clickteam

    Join Date
    Jun 2006
    Location
    France
    Posts
    14,123
    Mentioned
    279 Post(s)
    Tagged
    3 Thread(s)
    Sorry I've no idea about why this message is displayed in your case... I think it's usually displayed when the EXE of the runtime doesn't correspond to the version of the editor, but I don't see why it would do it in your case.

  4. #4
    Clicker Fusion 2.5Fusion 2.5+ DLCAndroid Export ModuleiOS Export ModuleInstall Creator Pro
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    blurymind's Avatar
    Join Date
    Feb 2014
    Location
    Huddersfield, United Kingdom
    Posts
    506
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Its because you are running it through wine/proton - the playtesting feature used to work, but seems like after the 2.5+ dlc it broke. This is a problem for steam users running it through proton on linux. Shame since the steam deck coming out soon with steamos based on arch linux will have a crippled fusion 2.5+

  5. #5
    Clicker Fusion 2.5Fusion 2.5+ DLCAndroid Export ModuleiOS Export ModuleInstall Creator Pro
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    blurymind's Avatar
    Join Date
    Feb 2014
    Location
    Huddersfield, United Kingdom
    Posts
    506
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    The solution to this on the steam forum is to "please run Update from inside Fusion to get the latest update."

    https://steamcommunity.com/app/24817...85/?l=schinese

    Problem is that the update command is disabled in the steam version. Is it updated to the latest release on steam?
    @Yves?

  6. #6
    Clicker Fusion 2.5Fusion 2.5+ DLCAndroid Export ModuleiOS Export ModuleInstall Creator Pro
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    blurymind's Avatar
    Join Date
    Feb 2014
    Location
    Huddersfield, United Kingdom
    Posts
    506
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    It is indeed because the version on steam is from last year!
    oldFusion.png

    and the check for update command does not work

    @Yves why is this not being updated on steam?

  7. #7
    Clicker Fusion 2.5Fusion 2.5+ DLCAndroid Export ModuleiOS Export ModuleInstall Creator Pro
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    blurymind's Avatar
    Join Date
    Feb 2014
    Location
    Huddersfield, United Kingdom
    Posts
    506
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    After testing this with the installers from my passport page -I can confirm that this problem is only present on the steam version. If you manually install it, then install the update patch and finally the plus patch - playtesting works on linux.

    If you however do it though steam - playtesting does not work and you get that error message

  8. #8
    Forum Moderator Fusion 2.5 MacFusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export Module
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)Firefly 3D Module (Steam)
    NaitorStudios's Avatar
    Join Date
    May 2010
    Location
    Brazil
    Posts
    664
    Mentioned
    9 Post(s)
    Tagged
    0 Thread(s)
    Steam handles the updates, so that option is deactivated.
    What you can do is get the beta code and add to Fusion properties on Steam so you can update to the latest beta, it might work (or not)

  9. #9
    Clicker Fusion 2.5 DeveloperHTML5 Export Module

    Join Date
    Jun 2006
    Posts
    1,487
    Mentioned
    10 Post(s)
    Tagged
    0 Thread(s)
    This brings up a good question. What version or versions of Linux does Clickteam see being supported?

  10. #10
    Forum Moderator Fusion 2.5 MacFusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export Module
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)Firefly 3D Module (Steam)
    NaitorStudios's Avatar
    Join Date
    May 2010
    Location
    Brazil
    Posts
    664
    Mentioned
    9 Post(s)
    Tagged
    0 Thread(s)
    It's not "officially" supported, getting it to run is pure luck.
    It doesn't use anything too fancy tho, except DX11 on 2.5+ DLC.

    It may be possible that the Steam version doesn't work properly on Linux because of the piracy protection, although I think the whole software wouldn't work, not only the runtime.
    So it's most likely that it's just because a software is launching another and this causes some conflicts, it may be corrupting the app exe on run, who knows ...

Page 1 of 2 1 2 LastLast

Similar Threads

  1. Replies: 0
    Last Post: 25th October 2018, 10:49 PM
  2. Replies: 2
    Last Post: 2nd July 2018, 09:47 PM
  3. Running Fusion 2.5 on Mac with Wine 1.7.33
    By Youthinkasido in forum Fusion 2.5
    Replies: 1
    Last Post: 25th October 2015, 11:00 PM
  4. Event running before frame transition
    By Bruto in forum Multimedia Fusion 2 - Technical Support
    Replies: 2
    Last Post: 31st January 2009, 06:08 PM
  5. Running up the side of the frame on platforms
    By Pixxel in forum Multimedia Fusion 2 - Technical Support
    Replies: 15
    Last Post: 11th July 2006, 03:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •