User Tag List

Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 21

Thread: Build 293.1 Android Build failed with an exception.

  1. #1
    Clicker Multimedia Fusion 2

    Join Date
    Jun 2007
    Posts
    189
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Build 293.1 Android Build failed with an exception.

    Hi
    this is my first try ever to build apk file and my fusion developer version is R293.1 with android exporter up to date.
    i installed android studio and i pasted the android SDK Pathname box in the preferences and pasted in the Java SDK directory: (C:\Program Files\Android\Android Studio\jre).
    the error message i receive is this:

    Configure project :app
    WARNING: The option 'android.useDeprecatedNdk' is deprecated.
    The current default is 'false'.
    It has been removed from the current version of the Android Gradle plugin.
    NdkCompile is no longer supported

    FAILURE: Build failed with an exception.

    * What went wrong:
    Could not determine the dependencies of task ':app:compileDebugJavaWithJavac'.
    > Trailing char < > at index 44: C:\Users\username\AppData\Local\Android\Sdk \package.xml

    * Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

    * Get more help at https://help.gradle.org

    BUILD FAILED in 784ms


    so, what shall i do to fix it?
    thanks in advance.

  2. #2
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    7,179
    Mentioned
    298 Post(s)
    Tagged
    4 Thread(s)
    please add what other extension you are using
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  3. #3
    Clicker Multimedia Fusion 2

    Join Date
    Jun 2007
    Posts
    189
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    do you mean objects i use in the app?

  4. #4
    Clicker Multimedia Fusion 2

    Join Date
    Jun 2007
    Posts
    189
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    m..i do not think it is something related to objects (extensions) i use, because i was just made very simple application with one active object and 8 direction movement, and i received the same error when i was trying to Build apk.

  5. #5
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    7,179
    Mentioned
    298 Post(s)
    Tagged
    4 Thread(s)
    well something is affecting the manifest file, not sure what could it be, what name are you use for this project
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  6. #6
    Clicker Multimedia Fusion 2

    Join Date
    Jun 2007
    Posts
    189
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    i named the app "test" and when i am trying to build it, i simply use 1 for the name of the apk.
    and again, this is very simple app with one active.

  7. #7
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    7,179
    Mentioned
    298 Post(s)
    Tagged
    4 Thread(s)
    Update to the latest beta version 293.9
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  8. #8
    Clicker Multimedia Fusion 2

    Join Date
    Jun 2007
    Posts
    189
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    how can i update it?
    if i use the "check for updates" in the fusion menu, it tells me that my build is up to date where can i find this update?

  9. #9
    Clicker Multimedia Fusion 2

    Join Date
    Jun 2007
    Posts
    189
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    ok Fernando, i updated it to version 293.9 and i still receive the same error.
    also, i tried to create android build with the standard edition, and i can confirm that i can create apk files with the standard edition with out error, so it is something with the developer edition..
    what now?

  10. #10
    Forum Moderator Fusion 2.5 MacFusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export Module
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)Firefly 3D Module (Steam)
    NaitorStudios's Avatar
    Join Date
    May 2010
    Location
    Brazil
    Posts
    835
    Mentioned
    9 Post(s)
    Tagged
    0 Thread(s)
    What is the full name you have set for your package on Android options? Please don't say it's just "test"...
    It should be "com.yourcompany.yourapplication", for example "com.piki.test", I don't think Android Studio lets it build apps that don't follow this template...
    (at least I can't remember of any app installed on my phone that doesn't follow this)

    Also, make sure you have set the build API to the actual newest Android API you have installed, cause it seems like it sometimes can point to the latest API that might not be installed which also causes errors.

Page 1 of 3 1 2 3 LastLast

Similar Threads

  1. FAILURE: Build failed with an exception.
    By Mystr in forum Android Export Module 2.5
    Replies: 4
    Last Post: 29th September 2020, 05:34 PM
  2. Failed to build Android .apk
    By mrknd94 in forum Android Export Module 2.5
    Replies: 4
    Last Post: 21st July 2020, 02:17 PM
  3. Build failed with an exception.
    By VoyVivika in forum Android Export Module 2.5
    Replies: 3
    Last Post: 9th November 2019, 01:20 AM
  4. Build failed Android
    By Melubnio in forum Android Export Module 2.5
    Replies: 2
    Last Post: 17th October 2016, 05:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •