User Tag List

Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12

Thread: Can you set minimum Android version lower than 4.4?

  1. #1
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)
    Hyoct's Avatar
    Join Date
    Jan 2020
    Location
    Somewhere in Earth
    Posts
    26
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Question Can you set minimum Android version lower than 4.4?

    Hey there, I was wondering if it's possible to build a Fusion Android app with a minimum version lower than 4.4 (Build R293.10)

    Thanks!

  2. #2
    Forum Moderator Fusion 2.5 MacFusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export Module
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)Firefly 3D Module (Steam)
    NaitorStudios's Avatar
    Join Date
    May 2010
    Location
    Brazil
    Posts
    1,129
    Mentioned
    9 Post(s)
    Tagged
    0 Thread(s)
    I get the feel, I have an old Galaxy Y with Android 2.3.5 or something, I wanted to turn it into a virtual pet lol

  3. #3
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    7,303
    Mentioned
    298 Post(s)
    Tagged
    4 Thread(s)
    Short answer, yes.
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  4. #4
    Forum Moderator Fusion 2.5 MacFusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export Module
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)Firefly 3D Module (Steam)
    NaitorStudios's Avatar
    Join Date
    May 2010
    Location
    Brazil
    Posts
    1,129
    Mentioned
    9 Post(s)
    Tagged
    0 Thread(s)
    Yes? How exactly? Does it depend on the Build API? Cause that Minimum Android version goes only back to 4.4, which I was expecting it to prevent installing the apk on old devices...
    Edit: The Build API selector can only go back to 18

  5. #5
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)
    Hyoct's Avatar
    Join Date
    Jan 2020
    Location
    Somewhere in Earth
    Posts
    26
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    How would I be able to set it lower?

  6. #6
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    7,303
    Mentioned
    298 Post(s)
    Tagged
    4 Thread(s)
    Why you want set lower?, 4.4 is android 18 and the code is done fitting this base API. Also, all C/C++ library were built using API 18

    Google

    https://android-developers.googleblo...elly-bean.html


    Amazon

    https://developer.amazon.com/docs/fi...fire-os-6.html

    hope this helps
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  7. #7
    Forum Moderator Fusion 2.5 MacFusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export Module
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)Firefly 3D Module (Steam)
    NaitorStudios's Avatar
    Join Date
    May 2010
    Location
    Brazil
    Posts
    1,129
    Mentioned
    9 Post(s)
    Tagged
    0 Thread(s)
    Well, for me it was to create and side-load apps on Gingerbread phone, it can't even connect to PlayStore anymore, so thought it would be cool if I could make some apps for it lol

  8. #8
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    7,303
    Mentioned
    298 Post(s)
    Tagged
    4 Thread(s)
    Gingerbread really?, this version has a heap size limitation, so any big game is not really possible and with the current code won't really run OK.
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  9. #9
    Forum Moderator Fusion 2.5 MacFusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export Module
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)Firefly 3D Module (Steam)
    NaitorStudios's Avatar
    Join Date
    May 2010
    Location
    Brazil
    Posts
    1,129
    Mentioned
    9 Post(s)
    Tagged
    0 Thread(s)
    Funny thing is that it was the phone I've used when the Android exporter was released, despite being an awful phone it did managed to run impressively well back then.
    I think I still have some Fusion APKs compatible with it!

  10. #10
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)
    Hyoct's Avatar
    Join Date
    Jan 2020
    Location
    Somewhere in Earth
    Posts
    26
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Yeah, what he said. I also recall being able to build with as low as 4.0, which is the case to one of my games. It has over 100k installs and the new updates are giving compatibility issues to those users who have older Android versions.

Page 1 of 2 1 2 LastLast

Similar Threads

  1. Witch Android API version should I use?
    By Outcast in forum Android Export Module 2.5
    Replies: 9
    Last Post: 27th February 2017, 10:31 AM
  2. Different calculation on PC version to Android version??
    By KLiK-iT in forum Android Export Module 2.5
    Replies: 5
    Last Post: 5th March 2016, 12:28 PM
  3. Build API, Minimum Android Version, Target Android Version?
    By KLiK-iT in forum Android Export Module 2.5
    Replies: 4
    Last Post: 9th July 2014, 12:50 PM
  4. Get android API version
    By N13astra in forum Android Export Module Version 2.0
    Replies: 0
    Last Post: 14th March 2014, 03:08 AM
  5. Minimum flash player version?
    By AndyH in forum SWF/Flash Export Module Version 2.0
    Replies: 2
    Last Post: 20th April 2011, 02:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •