User Tag List

Results 1 to 7 of 7

Thread: How to debug?

  1. #1
    Clicker Multimedia Fusion 2 DeveloperSWF Export Module

    Join Date
    Jul 2006
    Location
    Pittsburgh, PA, USA
    Posts
    777
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    How to debug?

    I made a game and programmed AI for an enemy, but when I duplicate the enemy it stops working. I've spent the last couple days fixing some of it, but there still seems to be just 1 bug left. I can't find it. Do you have any suggestions on how to find the bug? Thanks.

    Oh, and if you want to download the file, click here. The download will begin as soon as you click on the link.

    EDIT: Controls:
    Arrow keys - Move
    A - Attack
    S - Shield
    D - Jump

  2. #2
    No Products Registered

    Join Date
    Jul 2006
    Location
    Texas
    Posts
    1,225
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: How to debug?

    To find the bug, figure out what's going wrong. Figure out what part of your code could possibly be influencing that, and look it over a few thousand times until you finally figure it out! Good luck!!!

    EDIT: Could you please tell us what exactly that last bug is???

    EDIT2: Press D and S repeatedly while moving. You fall into oblivion!

  3. #3
    Clicker Multimedia Fusion 2 DeveloperSWF Export Module

    Join Date
    Jul 2006
    Location
    Pittsburgh, PA, USA
    Posts
    777
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: How to debug?

    Thanks! I found it! ...I think. I still need help, though. It's the last 2 events; 41 & 42. They look like this:

    X("Enemy")-X("Player")<0
    Enemy>>set position>>(1,0) from Enemy

    X("Enemy")-X("Player")>0
    Enemy>>set position>>(-1,0) from Enemy

    The problem was that all of the enemies moved together. I have no idea how to fix it though. Maybe I could use a fastloop? Wait, I don't even know what a fastloop is!

  4. #4
    Clicker Multimedia Fusion 2 DeveloperSWF Export Module

    Join Date
    Jul 2006
    Location
    Pittsburgh, PA, USA
    Posts
    777
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: How to debug?

    Actually, I have no idea what the problem is exactly. I'm sure, however, that those last 2 events are the problem.

    P.S. How did you find that S+D bug? Did you just try tapping them randomly?

  5. #5
    No Products Registered

    Join Date
    Jun 2006
    Posts
    259
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: How to debug?

    I think the problem is from you using a compare two general values statement, and thats only choosing the last created enemy (unless you want to fast loop through all of them.)

    Try switching those events to "compare X position of enemy to a value..." then saying "Is greater than x position of player" and "Is lower than x position of player." Make sure you are choosing the enemy as the first part, and the player as the second.

  6. #6
    Clicker Multimedia Fusion 2 DeveloperSWF Export Module

    Join Date
    Jul 2006
    Location
    Pittsburgh, PA, USA
    Posts
    777
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: How to debug?

    Well, it works better, but it still isn't working right.

    *I updated the file download.

    EDIT: My new problems are...
    1. The first enemy (the one on the platform) isn't working properly. I don't know how to explain it. He behaves wierd.
    2. The enemies sometimes don't stop at walls.

    Thank you SO MUCH, xerus. You solved the bug that I was most concerned about.

  7. #7
    Clicker Multimedia Fusion 2 DeveloperSWF Export Module

    Join Date
    Jul 2006
    Location
    Pittsburgh, PA, USA
    Posts
    777
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: How to debug?

    I fixed it completely! The AI is beautiful! I guess I can start to make the game now.
    *I updated the file download at the top again.

Similar Threads

  1. [RC3] debug log going nuts!
    By Bipolar_Games in forum Android Export Module Version 2.0
    Replies: 4
    Last Post: 9th December 2012, 04:29 PM
  2. My Debug system.
    By Outcast in forum Multimedia Fusion 2 - Technical Support
    Replies: 6
    Last Post: 22nd July 2012, 12:55 PM
  3. Best way to debug?
    By RhysD in forum iOS Export Module Version 2.0
    Replies: 13
    Last Post: 28th April 2011, 05:07 PM
  4. How do you Debug an Extension?
    By Jaffob in forum Extension Development
    Replies: 12
    Last Post: 13th September 2010, 12:20 PM
  5. Debug Window
    By MajorityCA in forum Multimedia Fusion 2 - Technical Support
    Replies: 4
    Last Post: 5th April 2009, 04:55 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •