User Tag List

Results 1 to 6 of 6

Thread: HWA Additive Blending issue

  1. #1
    No Products Registered

    Join Date
    Jun 2006
    Posts
    1,630
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    HWA Additive Blending issue

    Can anyone with the latest HWA version make a quick test for me?
    I attached a png with very soft borders.. when I add the Additive blending effect, it becomes all square, instead of correct soft border. I sent the file to Yves and he couldn't reproduce.. can anyone confirm this?

    Thanks very much
    Attached files Attached files

  2. #2
    Clicker Multimedia Fusion 2iOS Export Module

    Join Date
    Jul 2006
    Posts
    79
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: HWA Additive Blending issue

    I can confirm it -- it does in fact turn into an almost solid square with Additive Blending. Could it have something to do with the Alpha Channel?

  3. #3
    No Products Registered

    Join Date
    Jun 2006
    Posts
    1,630
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: HWA Additive Blending issue

    Thanks Zeitgeist1989! I guess it has something to do with very soft borders, rather than Alpha Channel itself, since objects using transparency (PNG) does not necessarily present this kind of issue, if the object has harder border.

  4. #4
    No Products Registered

    Join Date
    Oct 2006
    Location
    Sweden
    Posts
    1,141
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: HWA Additive Blending issue

    Alpha channels don't seem to work at all if Additive Blending is activated... To get a correct result, blend the image against a black background and use it without alpha
    Like this:

  5. #5
    No Products Registered

    Join Date
    Jun 2006
    Posts
    1,630
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: HWA Additive Blending issue

    The problem seems to be Alpha channels with very soft borders, rather than Alpha channels itself. The test below is a bouncy smiley with harder border, it still does have alpha channel, but has far less transparency variation than the image example above



    I attached the smiley png file if someone would like to test it.
    Attached files Attached files

  6. #6
    No Products Registered

    Join Date
    Oct 2006
    Location
    Sweden
    Posts
    1,141
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: HWA Additive Blending issue

    The alpha channel is still being ignored with Additive blending... Remove the alpha channel from the smiley and you will see why.

    While the glow had a completely blue image without alpha, the smiley looks pretty much the same...


Similar Threads

  1. Additive Blending in iOS
    By SevenSails in forum iOS Export Module Version 2.0
    Replies: 7
    Last Post: 13th December 2012, 05:13 PM
  2. Additive blend
    By scaneider in forum Hardware Accelerated Runtime
    Replies: 2
    Last Post: 12th October 2012, 10:34 PM
  3. [Bug] - Alpha Blending
    By scottige in forum Android Export Module Version 2.0
    Replies: 2
    Last Post: 26th February 2012, 03:50 PM
  4. Active with Additive blending question
    By mobichan in forum Multimedia Fusion 2 - Technical Support
    Replies: 6
    Last Post: 8th June 2008, 02:26 PM
  5. New INK EFFECT algorithm...Better than Additive
    By Steven_Provost in forum Hardware Accelerated Runtime
    Replies: 6
    Last Post: 1st February 2008, 08:13 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •