User Tag List

Results 1 to 5 of 5

Thread: [BUG] Very weird behavior

  1. #1
    No Products Registered

    Join Date
    Jun 2006
    Posts
    1,630
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    [BUG] Very weird behavior

    Please see file attached. It has two frames with very simple and identical events.. The object of this example is pick the lighter piece and put into the hole. It has just 6 events, 3 groups of objects and two active objects.

    Why one frame works and the other frame doesn't? :confused: :confused:
    Attached files Attached files

  2. #2
    Clicker Fusion 2.5 Developer

    Join Date
    May 2007
    Posts
    548
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: [BUG] Very weird behavior

    Hmm... it has to do with the order of the objects somehow.

  3. #3
    No Products Registered

    Join Date
    Jun 2006
    Posts
    1,630
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: [BUG] Very weird behavior

    I think you are right, byo. Try adding an event: if active (lighter) is overlapping the darker (hole), set lighter object to "bring to front". Then it is not working anymore

  4. #4
    Clicker Fusion 2.5 Developer

    Join Date
    May 2007
    Posts
    548
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: [BUG] Very weird behavior

    True. If you change the order of the objects in edit time there is a difference. The active following the mouse seems moving slower when this active is on the back and then it works.

  5. #5
    No Products Registered

    Join Date
    Jun 2006
    Posts
    1,630
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: [BUG] Very weird behavior

    yeah, I noticed that the clicking event is not working for the object below.. seems like the picked object is blocking/preventing the cursor object to click the hole object.

Similar Threads

  1. Really weird animation behavior
    By J3sseM in forum Multimedia Fusion 2 - Technical Support
    Replies: 11
    Last Post: 12th April 2013, 10:50 AM
  2. 256 R34 Behavior Bug : Object is not created but its behavior runs anyways
    By Shmuper in forum Multimedia Fusion 2 - Technical Support
    Replies: 8
    Last Post: 2nd March 2013, 07:15 AM
  3. strange behavior for sub.app under swf
    By Fernando in forum SWF/Flash Export Module Version 2.0
    Replies: 5
    Last Post: 1st April 2011, 01:02 PM
  4. Relevant to :Jar has different behavior than exe!
    By Hristos in forum File Archive
    Replies: 0
    Last Post: 10th April 2009, 07:27 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •