User Tag List

Results 1 to 5 of 5

Thread: Two bugs

  1. #1
    Clicker Fusion 2.5
    Fusion 2.5 (Steam)

    Join Date
    Sep 2007
    Location
    Austria
    Posts
    289
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Two bugs

    1) User clicks on object -> set var A (object) to 1.
    var A (object) >= 1 and each second add 1 to var A (object)
    var A (object) = 2 jump to frame 7.

    I use this method for creating a short delay. It normally works but not now. Run application -> it works. Frame editor -> it does not jump to frame 7. Normally, it should end the frame but nothing happens.

    2) I have some counters. One does not have an entry in the event editor. The counter is not used. When I want to delete it I get the message that it refers to a bad object...in the event editor another counter is replaced by the bad object although I did not delete this one.

    e.g. counter Monster and counter Powerup.
    In the event editor powerup is not used whereas monster has some events such as "monster > 5 then..."

    I want to delete Powerup...get the "bad object"-message...and the event "monster > 5 then..." is replaced by "bad object"...although I deleted the other counter (Powerup).

    Strange.

  2. #2
    Forum Moderator Fusion 2.5 DeveloperHTML5 Export ModuleiOS Export ModuleSWF Export Module
    DavidN's Avatar
    Join Date
    Jun 2006
    Location
    Boston, MA, USA
    Posts
    4,044
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Two bugs

    Put the file with the bad objects up for a developer to take a look at it - this obviously shouldn't happen! (Which version are you using?)

    For the first one, you should use Run Application to test transitions between frames... I have noticed that occasionally the application won't end when a frame jump would normally occur on Run Frame, but I haven't seen any kind of pattern to it.

  3. #3
    Clickteam Clickteam
    Jeff's Avatar
    Join Date
    Jun 2006
    Location
    Battle Ground Washington
    Posts
    11,824
    Mentioned
    8 Post(s)
    Tagged
    2 Thread(s)

    Re: Two bugs

    If you can put up an old file and provide a series of steps to recreate the bad object on demand -- That would be so helpful.

    Please be sure your running build 248 before sending it in as it could have been fixed in that update.

  4. #4
    Clicker Fusion 2.5
    Fusion 2.5 (Steam)

    Join Date
    Sep 2007
    Location
    Austria
    Posts
    289
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Two bugs

    Jeff Yes, I am using build 248.

    1) Download my file. Unzip it. I sent you the link via pm.
    2) Open my file.
    3) Go to "Level 1" and open it with the frame editor.
    4) At the bottom of the play area you will find some counters with "123" icons. One counter is called "Neustartdelay", another one is called "Schnarchormüdigkeit".
    5) Leave them as they are and open the event editor. All groups of events are open, all object folders are closed in order to make it easier what I want to show you.
    6) Find the counter "Neustartdelay" and scroll down. Nothing is ticked. The counter is not used.
    7) Click on the counter right next to "Neustartdelay" called "Schnarchormüdigkeit". You will find some conditions such as "Schnarchormüdigkeit=8..." and "Schnarchormüdigkeit=24".
    8) Go back to the frame editor and delete the counter "Neustartdelay". Remember that it is not used in the event editor.
    9) Now the "bad objects"-message is displayed.
    10) Go to the event editor. BOTH counters are gone although only "Neustartdelay" has been deleted. "Schnarchor..." is gone, too.
    11) Instead of these two counters you will find "bad object 80".
    12) Now take a look what has happened to events formerly related to the counter "Schnarchormüdigkeit" (see point 7).

    "Schnarchormüdigkeit=8" or "Schnarchormüdigkeit=24" have been replaced by "bad object 80="8" and so on and so forth.

  5. #5
    No Products Registered

    Join Date
    Mar 2007
    Location
    Sydney, Australia
    Posts
    1,369
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Two bugs

    bad objects! Ahh the memories :P

Similar Threads

  1. Bugs
    By Looki in forum Fusion 2.5
    Replies: 5
    Last Post: 7th October 2013, 02:33 AM
  2. [Bugs]
    By ProdigyX in forum Android Export Module Version 2.0
    Replies: 1
    Last Post: 10th February 2012, 10:51 PM
  3. Two bugs
    By Phi in forum Multimedia Fusion 2 - Technical Support
    Replies: 4
    Last Post: 2nd January 2012, 04:08 PM
  4. 2 Bugs
    By LIJI in forum Multimedia Fusion 2 - Technical Support
    Replies: 6
    Last Post: 7th September 2006, 08:02 PM
  5. Some bugs?
    By Clicktastic in forum Multimedia Fusion 2 - Technical Support
    Replies: 9
    Last Post: 11th July 2006, 01:57 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •