User Tag List

Results 1 to 5 of 5

Thread: Samples and Music not playing in sub-app

  1. #1
    Forum Moderator Fusion 2.5 DeveloperHTML5 Export Module
    Chaos's Avatar
    Join Date
    Aug 2006
    Location
    Burnsville, MN, USA
    Posts
    806
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Samples and Music not playing in sub-app

    I hope this might just be something silly I'm not checking but essentially: I have my game, it has samples saved internally, and music played through Onu - works just fine on its own. However, I'm essentially creating a 'loading' program which will just load the levels to help break file size apart so I don't have one gigantic EXE.

    However, when I load said engine (.ccn) into a separate programmed loader (.exe) - the game runs fine, but plays no sounds/music. I've checked the boxes for the sounds play if app loses focus and everything just to be sure, but can't seem to get it to work.

    Any insight or ideas would be most excellent.

    Thanks!

  2. #2
    No Products Registered

    Join Date
    Jul 2006
    Posts
    2,289
    Mentioned
    0 Post(s)
    Tagged
    1 Thread(s)

    Re: Samples and Music not playing in sub-app

    Do you have the Onu extension present in the loader?

  3. #3
    Forum Moderator Fusion 2.5 DeveloperHTML5 Export Module
    Chaos's Avatar
    Join Date
    Aug 2006
    Location
    Burnsville, MN, USA
    Posts
    806
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Re: Samples and Music not playing in sub-app

    yup, it wouldn't run otherwise

  4. #4
    Clickteam Clickteam

    Join Date
    Jun 2006
    Location
    France
    Posts
    12,717
    Mentioned
    48 Post(s)
    Tagged
    2 Thread(s)

    Re: Samples and Music not playing in sub-app

    Did you manually select the sound filters in the Sound Filters properties of the application? (if the main application doesn't play sounds and the "automatic" option is selected in the sound filters property, no filter will be included)

    EDIT: that doesn't explain why ONU doesn't play the music though...

  5. #5
    Forum Moderator Fusion 2.5 DeveloperHTML5 Export Module
    Chaos's Avatar
    Join Date
    Aug 2006
    Location
    Burnsville, MN, USA
    Posts
    806
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Re: Samples and Music not playing in sub-app

    Ahh, that fixed it! I unchecked the 'automatic' for the filters in the loader program, and it works perfectly. Thanks Yves!

    You guys are the best

Similar Threads

  1. Playing samples causes slowdown
    By Alonso in forum Multimedia Fusion 2 - Technical Support
    Replies: 5
    Last Post: 23rd December 2013, 03:28 AM
  2. Playing Samples = slowdown
    By Bipolar_Games in forum Android Export Module Version 2.0
    Replies: 0
    Last Post: 23rd March 2012, 11:18 PM
  3. Playing Samples?
    By Arnax in forum Android Export Module Version 2.0
    Replies: 0
    Last Post: 18th February 2012, 07:12 AM
  4. My application crashes WHEN PLAYING SAMPLES!?
    By Fr34kSh0w in forum Multimedia Fusion 2 - Technical Support
    Replies: 5
    Last Post: 22nd April 2011, 06:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •