User Tag List

Results 1 to 5 of 5

Thread: Why Don't filters work properly for Groups?

  1. #1
    Clicker Multimedia Fusion 2Firefly 3D Module
    dragonguy's Avatar
    Join Date
    Apr 2008
    Location
    RULE BRITANNIA!
    Posts
    3,071
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Why Don't filters work properly for Groups?

    If you have an event like say Object's Alterable Value <= 0 then destroy it, then the filter will work on each instance, to find all the the ones which have such an Alterable Value A at 0 or less and destroy them accordingly.

    But if you have an event like say Group's Altrable Value <= 0 then destroy it, then the filter will work on each type of object in the group instead of each instance, so if one enemy was shot enough times to die then all the ones of that type will be destroyed, this kind of thing forces me uncommonly use groups.

    I'm not sure but I think the filter only screws up on Red Conditions like 'Group.Bad was Clicked with Left Mouse Button'.

  2. #2
    No Products Registered

    Join Date
    Oct 2006
    Location
    Sweden
    Posts
    1,141
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Why Don't filters work properly for Groups?

    Could you upload an example app. I've never had this kind of problem with qualifiers before...

  3. #3
    Clicker Multimedia Fusion 2Firefly 3D Module
    dragonguy's Avatar
    Join Date
    Apr 2008
    Location
    RULE BRITANNIA!
    Posts
    3,071
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Why Don't filters work properly for Groups?

    Hmmm last time this happened to me is when I was still on Build 247, iv'e just tested it using a Red Condition on Build 248 and it appears to work perfectly however I haven't tested on Black Conditions yet.

  4. #4
    Clicker Fusion 2.5Firefly 3D Module

    Join Date
    Mar 2007
    Posts
    495
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Re: Why Don't filters work properly for Groups?

    Sometimes Qualifiers have an odd way of selecting the right objects.

    You've got to be quite cunning with how you use them.
    If you upload the file someone will probably be able to see what's going wrong. Often a little bit of trial and error is what's needed but you've gotta have worked with MMF for quite a while to get an idea about how to play on with it.

  5. #5
    No Products Registered

    Join Date
    Mar 2007
    Location
    Sydney, Australia
    Posts
    1,369
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Why Don't filters work properly for Groups?

    I dont really have problems using groups, but the way usually use them is fastlooping. Would be interesting to see if this is a bug or user error, as it could potentially cause me greif later down the track with my project

Similar Threads

  1. [BUG] Set Font Size, Resize Borders doesn't work properly!
    By Bipolar_Games in forum Android Export Module Version 2.0
    Replies: 3
    Last Post: 6th October 2013, 12:16 AM
  2. MP3 compression doesn't work properly anymore
    By MJK in forum SWF/Flash Export Module Version 2.0
    Replies: 4
    Last Post: 21st June 2012, 09:50 AM
  3. Stop Any Sample Playing - does not work properly?
    By mobo in forum iOS Export Module Version 2.0
    Replies: 0
    Last Post: 20th May 2012, 02:19 AM
  4. My exported game doesn't work properly.
    By kromblite in forum SWF/Flash Export Module Version 2.0
    Replies: 28
    Last Post: 22nd April 2012, 11:53 PM
  5. Does The Big Box object work properly for 64-bit?
    By RGBreality in forum Multimedia Fusion 2 - Technical Support
    Replies: 10
    Last Post: 22nd September 2011, 04:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •