User Tag List

Results 1 to 4 of 4

Thread: Small problem with platform engine

  1. #1
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCSWF Export Module
    N64Mario's Avatar
    Join Date
    Nov 2008
    Location
    USA
    Posts
    1,308
    Mentioned
    15 Post(s)
    Tagged
    0 Thread(s)

    Small problem with platform engine

    I'm attempting my own custom platform engine using floating point movement. There's a few bugs I'm not sure how to fix.

    Here's the MFA of my static platform engine WIP.
    - The first bug being that when sliding around, standing on the ice, sometimes you still move a few 1 pixels. Specifically, if the velocity shows 0.02 or something like that. Although I thought I made the velocity so it's supposed to decelerate on the ice until the velocity hits 0, but sometimes it doesn't go all the way to 0.
    Also, what does the 'e' stand for in the number line? Is that some sort of error?
    - The other problem I have is with the gravity. Sometimes before hitting the floor, its like there's an aftershock. It seems his slight tip toe touches the floor for a second before he actually 'lands'. I'm not sure why this is, maybe it's a velocity, position error.
    I was wondering if fast loops can be used anywhere, or would make use here?


    On a unrelated note, am I able to install MMF2 on another PC if I installed it once on the computer that I am using? In other words, multiple install? I recently bought a nice laptop which has Vista on it. I was going to take it with me for when I go on vacation. I was going to install MMF2 on it if it lets me. Though I suppose I would need the update fix for MMF2 to run on Vista.

  2. #2
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleSWF Export ModuleUnicode Add-on
    Looki's Avatar
    Join Date
    Aug 2006
    Location
    Karlsruhe, Germany
    Posts
    3,739
    Mentioned
    5 Post(s)
    Tagged
    1 Thread(s)

    Re: Small problem with platform engine

    For the ice part, try using
    Set Velocity to max(0,Velocity-0.02)
    and Set Velocity to min(0,Velocity+0.02)
    rather than just adding/subbing 0.02

    For example, the velocity is 0.01, you subtract 0.02, boom, -0.01.

    What 'e'? Plus, I'm not able to reproduce that gravity bug.

    Of course you can install MMF on your laptop, too.

  3. #3
    Clickteam Clickteam
    LB's Avatar
    Join Date
    Jun 2007
    Location
    Richardson, Texas, North America
    Posts
    8,937
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)

    Re: Small problem with platform engine

    You mean the letter 'e' in the editing the counter pictures? That's for when numbers go really high and it uses scientific notation.
    Working as fast as I can on Fusion 3

  4. #4
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCSWF Export Module
    N64Mario's Avatar
    Join Date
    Nov 2008
    Location
    USA
    Posts
    1,308
    Mentioned
    15 Post(s)
    Tagged
    0 Thread(s)

    Re: Small problem with platform engine

    Quote Originally Posted by Looki
    For the ice part, try using
    Set Velocity to max(0,Velocity-0.02)
    and Set Velocity to min(0,Velocity+0.02)
    rather than just adding/subbing 0.02

    For example, the velocity is 0.01, you subtract 0.02, boom, -0.01.

    What 'e'? Plus, I'm not able to reproduce that gravity bug.

    Of course you can install MMF on your laptop, too.
    That seems to work, thanks.

    BTW, it seems that sometimes when I 'hug' a wall too close, sometimes you can not jump up. So I have to walk backwards from the wall first. This maybe due to a position/collision error in my programming. I'm not sure. Which is why I asked if fast loops would help here.
    While I took a look at DavidN's fastloop tutorial, it doesn't seem to work for floating point movement engines.

Similar Threads

  1. Problem with animation on slopes and HTML5 runtime, platform engine - Please help
    By faber in forum Multimedia Fusion 2 - Technical Support
    Replies: 0
    Last Post: 12th December 2013, 10:05 PM
  2. PMO or not PMO on a platform engine?
    By 7Heroes in forum Multimedia Fusion 2 - Technical Support
    Replies: 3
    Last Post: 21st July 2009, 12:21 AM
  3. Best Platform Engine?
    By YAS in forum Multimedia Fusion 2 - Technical Support
    Replies: 15
    Last Post: 28th October 2007, 05:52 PM
  4. Platform Engine
    By chrilley in forum File Archive
    Replies: 6
    Last Post: 26th September 2006, 01:20 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •