User Tag List

Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 25

Thread: Bug - Memory leak with Sub-Apps

  1. #1
    Clicker Fusion 2.5 MacFusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleiOS Export ModuleSWF Export ModuleInstall Creator Pro
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    UrbanMonk's Avatar
    Join Date
    May 2008
    Location
    Southern U.S.A.
    Posts
    847
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Bug - Memory leak with Sub-Apps

    I reported this a while back, and it was fixed for software mode.

    It seems the bug still exists in HWA mode though.

    Maybe it's just my computer, so can anyone check this out and see if you are getting the same results.

    Run this mfa in HWA mode and check the amount of memory used. Then restart the frame and check it again. I seems to use 6mb more memory after every restart. The bug is less noticeable in DirectX 8 mode.

    EDIT: I'm using mmf dev R249 B6

    Thanks!

    Link here:
    http://www.jsoftgames.com/memoryleak.zip

  2. #2
    Clickteam Clickteam

    Join Date
    Jun 2006
    Location
    France
    Posts
    13,070
    Mentioned
    119 Post(s)
    Tagged
    2 Thread(s)

    Re: Bug - Memory leak with Sub-Apps

    Weird, I can't reproduce it with MMF2 Dev HWA B249 Beta6. What version of Windows and what video card do you use?

    Is anyone else able to reproduce it?

  3. #3
    Clicker Fusion 2.5 MacFusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleiOS Export ModuleSWF Export ModuleInstall Creator Pro
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    UrbanMonk's Avatar
    Join Date
    May 2008
    Location
    Southern U.S.A.
    Posts
    847
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Re: Bug - Memory leak with Sub-Apps

    Windows Vista. Nvidia Geforce 8600M GT

    Everything else runs perfect.
    And as I said this problem used to also exist in the standard build as well, but it disappeared after beta 5 I believe.

    In DirectX8 I get about a 2000K memory usage increase with every restart.

    IN DirectX9 I get 3000K increase

    In standard mode it stays at a steady 6796K usage, and fluctuates about 100K between restarts then returns to the 6796K again.

  4. #4
    No Products Registered

    Join Date
    Mar 2007
    Location
    Sydney, Australia
    Posts
    1,369
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Bug - Memory leak with Sub-Apps

    I cannot reproduce this bug in DX8 or 9.
    Windows XP. Geforce 9800gtx

  5. #5
    Clicker Multimedia Fusion 2 Developer

    Join Date
    Jul 2006
    Location
    Denmark
    Posts
    1,812
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Bug - Memory leak with Sub-Apps

    I can confirm it.

    First 60mb, then 63mb, then 67mb etc

  6. #6
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,124
    Mentioned
    151 Post(s)
    Tagged
    3 Thread(s)

    Re: Bug - Memory leak with Sub-Apps

    I cannot reproduce it

    using vista x64, Intel mobile chipset
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  7. #7
    Clickteam Clickteam

    Join Date
    Jun 2006
    Location
    France
    Posts
    13,070
    Mentioned
    119 Post(s)
    Tagged
    2 Thread(s)

    Re: Bug - Memory leak with Sub-Apps

    MechaBowser, what's your version of Windows and your video card? Thanks.

  8. #8
    Clicker Multimedia Fusion 2 DeveloperiOS Export Module
    Nifflas's Avatar
    Join Date
    Jul 2006
    Posts
    2,613
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Bug - Memory leak with Sub-Apps

    No such problem here, build 249 #6, ATI Mobility Radeon X1350

  9. #9
    Clicker Multimedia Fusion 2 Developer

    Join Date
    Jun 2006
    Location
    Darlington, UK
    Posts
    3,298
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Bug - Memory leak with Sub-Apps

    Mine varies in memory use by over 1MB, but every time I thought it was leaking it would drop again on the next restart.

    No problem.

  10. #10
    Clicker Fusion 2.5 MacFusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleiOS Export ModuleSWF Export ModuleInstall Creator Pro
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    UrbanMonk's Avatar
    Join Date
    May 2008
    Location
    Southern U.S.A.
    Posts
    847
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Re: Bug - Memory leak with Sub-Apps

    Alright I compiled a .exe and tested it again.

    Here is a screenshot of task-manager when it first starts:

    http://www.jsoftgames.com/firststart.bmp

    And after 50 restarts:

    http://www.jsoftgames.com/50restarts.bmp

    I also updated the original link to include a complied exe and both the screenshots:

    http://www.jsoftgames.com/memoryleak.zip

Page 1 of 3 1 2 3 LastLast

Similar Threads

  1. Memory Leak?
    By Storsorgen in forum Multimedia Fusion 2 - Technical Support
    Replies: 1
    Last Post: 25th October 2013, 05:22 PM
  2. Memory leak fixed Ini++ v1.5
    By Jax in forum Released Extensions
    Replies: 8
    Last Post: 28th July 2013, 05:34 AM
  3. String Tokenizer memory leak
    By Nobuyuki in forum Multimedia Fusion 2 - Technical Support
    Replies: 3
    Last Post: 11th April 2011, 09:51 AM
  4. Memory leak?
    By Blue66 in forum Multimedia Fusion 2 - Technical Support
    Replies: 1
    Last Post: 22nd March 2009, 09:57 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •