User Tag List

Results 1 to 9 of 9

Thread: Annoying lag in HWA

  1. #1
    No Products Registered

    Join Date
    Jun 2010
    Location
    Sutton, Surrey, UK
    Posts
    90
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Annoying lag in HWA

    Hey, i'm using HWA in MMF2 for the 1st time and i'm stunned by the effects that everybody has created! Annoying thing though, I set my game to Direct3D 9 and it creates an annoying lag every second or so, which never existed before. My game is high in memory in Standard mode, taking about 200-300mb and having alot going on at once, but never suffered from this lag. The lag effects the games camera and controls, so it's very big of a deal. How do I fix this? Thanks soo much

  2. #2
    Clicker

    Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleSWF Export ModuleXNA Export ModuleInstall Creator Pro
    nivram's Avatar
    Join Date
    Jul 2006
    Location
    Bandon, Oregon
    Posts
    6,729
    Mentioned
    9 Post(s)
    Tagged
    0 Thread(s)

    Re: Annoying lag in HWA

    What kind of video card do you have? If it is like my brain it probably will not work, as you are shifting from computer memory to video card for HWA.

    Marv
    ​458 TGF to CTF 2.5+ Examples and games
    http://www.castles-of-britain.com/mmf2examples.htm

  3. #3
    Clicker Multimedia Fusion 2 Developer

    Join Date
    Jul 2006
    Location
    Denmark
    Posts
    1,812
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Annoying lag in HWA

    Any notable extensions in use?

  4. #4
    No Products Registered

    Join Date
    Jun 2010
    Location
    Sutton, Surrey, UK
    Posts
    90
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Annoying lag in HWA

    Hey thanks for the reply Marv!
    I'm not really knowledgeable about video cards and the lot, but My card is a "NVIDIA GeForce 6150SE nForce 430" and has a total memory of "313mb"
    I will also point out I only have 1gb of ram.
    My computer is utmost OLD, but yeah...

    EDIT: Thanks MechaBowser for a reply aswell
    I am using:
    Edit box
    Function Eggtimer
    Advance Direction Object
    Background System Box
    ForEach
    Trackbar

    Heh...come to think of it, its probably caused by one of those extensions...


    EDIT2: After further studying... I figured out that it only does this lag when the screen is scrolling. The faster its scrolling the more severe the lag is. No lag at all when no scrolling.

  5. #5
    Clicker Multimedia Fusion 2 Developer

    Join Date
    Jun 2006
    Location
    Darlington, UK
    Posts
    3,298
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Annoying lag in HWA

    I'll be honest...

    That graphics chip was bottom of the range when it was new, four years ago.

  6. #6
    No Products Registered

    Join Date
    Jun 2010
    Location
    Sutton, Surrey, UK
    Posts
    90
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Annoying lag in HWA

    Heh so i'm pretty much screwed aren't I?
    Ah well... No shaders for me

    EDIT: Awp! Suprise suprise! It was actually something to do with my GUI ingame. Seems the app doesn't like Semi-transparency...

  7. #7
    Clicker Multimedia Fusion 2 Developer

    Join Date
    Jun 2006
    Location
    Darlington, UK
    Posts
    3,298
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Annoying lag in HWA

    It's not a background system box it doesn't like is it?

  8. #8
    Forum Moderator Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export ModuleMac Export Module
    AndyH's Avatar
    Join Date
    Jun 2006
    Location
    UK
    Posts
    1,445
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Re: Annoying lag in HWA

    Have you put the FPS (screen frame rate) to 60 or above? If not try setting it at 60 or 61 fps, then tick on the v-sync option to see if there is a difference. Not that I'd expect to see much of a lag at the default 50FPS but worth a try.

    Also as mentioned above some objects are not optimised for HWA so could make things worse, and images not aligned to a size of the power of 2 (eg: 2,4,8,16,32,64,128,256,etc) will use up more memory as MMF has to enlarge the canvas upto the next closest size so that could contribute to using lots of video memory and if your gfx card doesn't have a lot and/or is slow at transferring gfx from main memory to graphics memory it can cause a slow down.

    It is a lot easier to build a game with HWA in mind from the start, but quite frankly I have not had too many issues transferring normal MMF games to HWA.
    Andy H @ ovine.net
    Awful Jokes - a new cartoon every day: http://awful.ovine.net/
    Ovine's games: http://www.ovine.net

  9. #9
    No Products Registered

    Join Date
    Jun 2010
    Location
    Sutton, Surrey, UK
    Posts
    90
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Annoying lag in HWA

    Quote Originally Posted by AndyH
    ...images not aligned to a size of the power of 2 (eg: 2,4,8,16,32,64,128,256,etc) will use up more memory as MMF has to enlarge the canvas upto the next closest size so that could contribute to using lots of video memory and if your gfx card doesn't have a lot and/or is slow at transferring gfx from main memory to graphics memory it can cause a slow down.
    Didn't know that, though I always wondered why other languages I have used depend on having the sizes of the power of 2. Thanks for letting me know!

Similar Threads

  1. Very annoying !
    By Keli in forum Multimedia Fusion 2 - Technical Support
    Replies: 5
    Last Post: 20th January 2010, 04:38 PM
  2. [BUG] Sub-App bug, very annoying.
    By LB in forum Multimedia Fusion 2 - Technical Support
    Replies: 2
    Last Post: 15th June 2009, 09:39 PM
  3. Annoying bug!!
    By Game_Master in forum Multimedia Fusion 2 - Technical Support
    Replies: 4
    Last Post: 8th December 2007, 10:58 AM
  4. Annoying me
    By gamefreak202 in forum Multimedia Fusion 2 - Technical Support
    Replies: 2
    Last Post: 28th November 2007, 12:58 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •