User Tag List

Results 1 to 3 of 3

Thread: Beta 1: "Bad" group/sound problem?

  1. #1
    Forum Moderator Fusion 2.5 DeveloperHTML5 Export ModuleiOS Export ModuleSWF Export Module
    DavidN's Avatar
    Join Date
    Jun 2006
    Location
    Boston, MA, USA
    Posts
    4,044
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Beta 1: "Bad" group/sound problem?

    I was hoping to narrow this down more precisely, but this is a strange one - if you build and try to run this MFA as-is, then you'll get the problem where it cuts back to the desktop during loading. Remove the blank group "Explode Loop", however, and all will be well (though the game won't work - I've cut out a heap of stuff to get it into this state).

    With no actions or events in the group, I'm wondering if there's something wrong with the group itself.

    By the way, is there any sort of logging that would be useful to turn on in the XCode editor, to help track these non-starting issues down?
    Attached files Attached files

  2. #2
    Forum Moderator Fusion 2.5 DeveloperHTML5 Export ModuleiOS Export ModuleSWF Export Module
    DavidN's Avatar
    Join Date
    Jun 2006
    Location
    Boston, MA, USA
    Posts
    4,044
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Beta 1: "Bad" group?

    Got it, this looks promising:

    Code:
    9/4/10 1:53:01 PM	b-noactions[22718]	*** Terminating app due to uncaught exception 'NSRangeException', reason: '*** -[NSConcreteData subdataWithRange:]: range {196621, 2835767023} exceeds data length 175466'
    *** Call stack at first throw:
    (
    	0   CoreFoundation                      0x02829919 __exceptionPreprocess + 185
    	1   libobjc.A.dylib                     0x029775de objc_exception_throw + 47
    	2   CoreFoundation                      0x027e2078 +[NSException raise:format:arguments:] + 136
    	3   CoreFoundation                      0x027e1fea +[NSException raise:format:] + 58
    	4   Foundation                          0x00271e4a -[NSData(NSData) subdataWithRange:] + 381
    	5   b-noactions                         0x00004c2c -[CFile getSubData:] + 95
    	6   b-noactions                         0x0007eea1 -[CSound load:] + 296
    	7   b-noactions                         0x0001054b -[CSoundBank load] + 655
    	8   b-noactions                         0x000150f8 -[CRunFrame loadFullFrame:] + 4149
    	9   b-noactions                         0x00008964 -[CRunApp startTheFrame] + 269
    	10  b-noactions                         0x00007e9c -[CRunApp playApplication:] + 276
    	11  b-noactions                         0x00003b36 -[CRunView timerEntry] + 457
    	12  Foundation                          0x0024dc99 __NSFireTimer + 125
    	13  CoreFoundation                      0x0280ad43 __CFRUNLOOP_IS_CALLING_OUT_TO_A_TIMER_CALLBACK_FUNCTION__ + 19
    	14  CoreFoundation                      0x0280c384 __CFRunLoopDoTimer + 1364
    	15  CoreFoundation                      0x02768d09 __CFRunLoopRun + 1817
    	16  CoreFoundation                      0x02768280 CFRunLoopRunSpecific + 208
    	17  CoreFoundation                      0x027681a1 CFRunLoopRunInMode + 97
    	18  GraphicsServices                    0x0308e2c8 GSEventRunModal + 217
    	19  GraphicsServices                    0x0308e38d GSEventRun + 115
    	20  UIKit                               0x004c5b58 UIApplicationMain + 1160
    	21  b-noactions                         0x00002912 main + 104
    	22  b-noactions                         0x000028a1 start + 53
    )
    Something to do with CSound? That makes sense if it's trying to grab a file that doesn't exist - but there shouldn't be a sound called there!

    This is from what seems to be the Mac version of Event Viewer - Applications/Utilities/Console . The stacktraces should stand out among the "Console Messages" view, and you can just Command+C them out of there.

  3. #3
    Forum Moderator Fusion 2.5 DeveloperHTML5 Export ModuleiOS Export ModuleSWF Export Module
    DavidN's Avatar
    Join Date
    Jun 2006
    Location
    Boston, MA, USA
    Posts
    4,044
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Beta 1: "Bad" group?

    Removing the one sound effect remaining in the application, rather than the blank group, also allows the game to start.

Similar Threads

  1. [bug] Negated "Is Group Active" doesnt work!
    By StingRay in forum SWF/Flash Export Module Version 2.0
    Replies: 3
    Last Post: 1st March 2013, 07:28 AM
  2. problem "app purchases" beta 6 ?
    By rom in forum iOS Export Module Version 2.0
    Replies: 3
    Last Post: 19th November 2012, 10:00 AM
  3. How many "sound channels" work at once for IOS devices
    By BrashMonkey in forum iOS Export Module Version 2.0
    Replies: 4
    Last Post: 23rd March 2012, 11:02 AM
  4. Sound "pause" event trouble
    By 300happy in forum SWF/Flash Export Module Version 2.0
    Replies: 1
    Last Post: 20th September 2010, 09:37 AM
  5. Removing the "p" sound from a wave file
    By Sebaceous in forum Multimedia Fusion 2 - Technical Support
    Replies: 7
    Last Post: 1st May 2009, 09:27 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •