User Tag List

Page 1 of 2 1 2 LastLast
Results 1 to 10 of 20

Thread: RC #1 - Bug - Sounds + App Resume + Question

  1. #1
    Clicker Multimedia Fusion 2 DeveloperiOS Export ModuleSWF Export Module

    Join Date
    Jan 2009
    Posts
    1,052
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    RC #1 - Bug - Sounds + App Resume + Question

    When you ask a question, then press the home button and then come back to the game and answer the question, if a sound (like music) was playing before you press the home button, then the sound is not played any longer.

    1) Play sound loop (like music) with OpenGL (not with Audio Player),
    2) Ask a quesion,
    3) Press Home button,
    4) Return to the game,
    5) Answer the qestion,
    6) Music is not playing anymore.

    It works ok when no question is asked. I mean, you press the home button and then come back and the music is there. And also, when you ask and respond a question without pressing the home button. If you do the same with Audio Player, the music is resumed before you answer the question when you return to the game.

    To sum up:

    1) If you press the home button when sounds are playing, when you come back to the app the sounds are resumed with no problem, both in OpenAL and Audio Player.

    2) If you ask a question and then press the home button, when you come back to the app the sounds played with the Audio Player are resumed before the user replies. And after answering, OpenAL doesn't resume sounds that were paused nor replay them (unless you restart the frame); OpenAL only plays sounds that weren't paused before deactivating the app.

  2. #2
    Clicker Multimedia Fusion 2 DeveloperiOS Export ModuleSWF Export Module

    Join Date
    Jan 2009
    Posts
    1,052
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: RC #1 - Bug - Sounds + App Resume + Question

    Of course the workaround should be checking whether the music is not playing, and play it again (but music shall restart from the begining).

  3. #3
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleMac Export ModuleUniversal Windows Platform Export ModuleSWF Export Module
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    Koji_Kabuto's Avatar
    Join Date
    Jul 2006
    Location
    Venezuela
    Posts
    2,847
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)

    Re: RC #1 - Bug - Sounds + App Resume + Question



    I have hope that everything is polished before the final version of IOS Exporter.

  4. #4
    Clicker Multimedia Fusion 2 DeveloperiOS Export ModuleSWF Export Module

    Join Date
    Jan 2009
    Posts
    1,052
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: RC #1 - Bug - Sounds + App Resume + Question

    > Of course the workaround should be checking whether the music is not playing, and play it again (but music restarts from the begining).

    Checked. This doesn't work. It's like the channels on the OpenGL get dirty. Not even stopping the channel before restarting the music works.

    I will verify what happens if I play the music with Audio Player.

  5. #5
    Clicker Multimedia Fusion 2 DeveloperiOS Export ModuleSWF Export Module

    Join Date
    Jan 2009
    Posts
    1,052
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: RC #1 - Bug - Sounds + App Resume + Question

    Ok, when you press the home button and then get back, sometimes openGL gets confused if you ask a question before the game is deactivated and doesn't play some or all sounds any longer, when an answer is provided when the game is reactivated.

    With Audio Player this works ok, but if you check for reactivation to ask a question, the sound is not paused.

  6. #6
    Clicker Multimedia Fusion 2 DeveloperiOS Export ModuleSWF Export Module

    Join Date
    Jan 2009
    Posts
    1,052
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: RC #1 - Bug - Sounds + App Resume + Question

    To sum up:

    1) If you press the home button when sounds are playing, when you come back to the app the sounds are resumed with no problem, both in OpenAL and Audio Player.

    2) If you ask a question and then press the home button, when you come back to the app the sounds played with the Audio Player are resumed before the user replies. And after answering, OpenAL doesn't resume sounds that were paused nor replay them (unless you restart the frame); OpenAL only plays sounds that weren't paused before deactivating the app.

  7. #7
    Clicker Multimedia Fusion 2 DeveloperiOS Export ModuleSWF Export Module

    Join Date
    Jan 2009
    Posts
    1,052
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: RC #1 - Bug - Sounds + App Resume + Question

    Please tell me this will be solved for the next RC

  8. #8
    Clicker Multimedia Fusion 2 DeveloperiOS Export ModuleSWF Export Module

    Join Date
    Jan 2009
    Posts
    1,052
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: RC #1 - Bug - Sounds + App Resume + Question

    News about this?

  9. #9
    Clicker Fusion 2.5 DeveloperFusion 2.5 DeveloperiOS Export ModuleMac Export ModuleSWF Export ModuleUnicode Add-on
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    JasonDarby's Avatar
    Join Date
    Jun 2006
    Location
    UK
    Posts
    4,937
    Mentioned
    0 Post(s)
    Tagged
    1 Thread(s)

    Re: RC #1 - Bug - Sounds + App Resume + Question

    You're going to have to be a little patient BH...

  10. #10
    Clickteam Clickteam
    Anders's Avatar
    Join Date
    Jun 2006
    Location
    Denmark, ┼rhus
    Posts
    3,456
    Mentioned
    5 Post(s)
    Tagged
    1 Thread(s)

    Re: RC #1 - Bug - Sounds + App Resume + Question

    Im working on this

Page 1 of 2 1 2 LastLast

Similar Threads

  1. Resume sounds in game after using the iPhones music player.
    By Aasland in forum iOS Export Module Version 2.0
    Replies: 5
    Last Post: 15th March 2012, 10:09 PM
  2. "Resume all sounds" doesn't resume, it restarts
    By JoKa in forum iOS Export Module Version 2.0
    Replies: 0
    Last Post: 7th March 2012, 12:56 PM
  3. Sounds Don't Pause/Resume properly in SWF format.
    By N64Mario in forum SWF/Flash Export Module Version 2.0
    Replies: 5
    Last Post: 5th October 2011, 08:23 PM
  4. Sounds sounds sound
    By Corlen in forum Multimedia Fusion 2 - Technical Support
    Replies: 1
    Last Post: 20th November 2007, 07:26 AM
  5. Sounds question (sample volume)
    By Blizna in forum Multimedia Fusion 2 - Technical Support
    Replies: 3
    Last Post: 29th December 2006, 10:40 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •