User Tag List

Page 6 of 8 FirstFirst ... 4 5 6 7 8 LastLast
Results 51 to 60 of 73

Thread: Federico Aliprandi - Test Reports

  1. #51
    Clicker Multimedia Fusion 2 DeveloperiOS Export ModuleSWF Export ModuleXNA Export Module

    Join Date
    Jul 2010
    Location
    Italy
    Posts
    368
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    BUG: I still get the compile time error "Impossible to find the type or namespace 'CRunMvtInAndOut'; probably either a using directive or an assembly reference is missing" on line 120 of the file CRMvt.cs, if I use the In And Out Movement.

    BUG: If I use INI files, everything goes extremely slow. I don't understand why, because in all the events using INI I use the "Run this event once" condition. Also, most of those INI conditions aren't reached at the beginning, because there are other conditions above (for example "Score > 10000", etc...). Attached an mfa reproducing the problem. Note: there is only one frame with many events, but you only have to look inside the "critical area" that I described inlcuding it in two big comments. I've tested and I understood the problem is given only by those two group of events.

    NOTE: Sorry, I've attached the mfa zipped because, also after removing all sound effects and music, I couldn't get it lighter than 1.3 MB and the limit on this forum is of 1.0 MB.
    Attached files Attached files

  2. #52
    Clicker Multimedia Fusion 2 DeveloperiOS Export ModuleSWF Export Module
    Francois's Avatar
    Join Date
    Jul 2006
    Location
    Montpellier, France
    Posts
    6,920
    Mentioned
    0 Post(s)
    Tagged
    1 Thread(s)
    Run this event once is actually not tested in the conditions. It is tested at the beginning of the actions. So all the conditions of the group are actually tested, even if the actions are not executed. I really have to change that.
    I have not checked your application, but this might explain why. Also, changing the movement of an object is a rather lengthy operation.

  3. #53
    Clicker Multimedia Fusion 2 DeveloperiOS Export ModuleSWF Export Module
    Francois's Avatar
    Join Date
    Jul 2006
    Location
    Montpellier, France
    Posts
    6,920
    Mentioned
    0 Post(s)
    Tagged
    1 Thread(s)
    I found the reason for the slowdown.
    It seems that XNA is EXTREMEMLY slow when you try to convert an empty string (or a string that do not contain a number) into a number. It takes ages.
    In your critical area, you were doing that a lot in the conditions.
    I will correct that for the next version. For the moment, you just have to make sure that all the entries of the INI file you are testing contain a valid number, and the speed of the game will be good.

  4. #54
    Clicker Multimedia Fusion 2 DeveloperiOS Export ModuleSWF Export ModuleXNA Export Module

    Join Date
    Jul 2010
    Location
    Italy
    Posts
    368
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Great, thanks!

  5. #55
    Clicker Multimedia Fusion 2 DeveloperiOS Export ModuleSWF Export ModuleXNA Export Module

    Join Date
    Jul 2010
    Location
    Italy
    Posts
    368
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    BUG: The position of Counter objects of type string, as well as Score objects of type string, when exported to any XNA runtime (Phone, Windows, XBox) is different. In particular it seems that it moves up of a few pixels. This does not happen with String objects.
    Here is an image of the difference between the C++ and the XNA Windows runtime:
    CounterPositionBug.jpg
    And here is the simple mfa containing a Counter object on a white frame 800x480.
    CounterPosition.mfa

  6. #56
    Clicker Multimedia Fusion 2 DeveloperiOS Export ModuleSWF Export ModuleXNA Export Module

    Join Date
    Jul 2010
    Location
    Italy
    Posts
    368
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    BUG: The "Automatically set animation direction" property of the Vector movement is ignored in XNA Runtime. Attached an mfa showing the bug.
    Attached files Attached files

  7. #57
    Clicker Multimedia Fusion 2 DeveloperiOS Export ModuleSWF Export ModuleXNA Export Module

    Join Date
    Jul 2010
    Location
    Italy
    Posts
    368
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    BUG: When a Counter of type Animation reaches the maximum value, in XNA an IndexOutOfRangeException is thrown in CCounter.cs. Attached a screenshot showing the exception in Visual Studio, and an mfa reproducing the bug.
    Images attachées Images attachées
    Attached files Attached files

  8. #58
    Clicker Multimedia Fusion 2 DeveloperiOS Export ModuleSWF Export ModuleXNA Export Module

    Join Date
    Jul 2010
    Location
    Italy
    Posts
    368
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    BUG: If the developer tries to read a value from an INI file, before using the action "INI: Set current file", in C++ runtime the application doesn't crash, but in XNA runtime it crashes with an ArgumentNullException at row 479 of CRunkcini.cs.

    Anyway, I know this is a very little bug, because it's fault of the game developer try to read a value of an INI file without specifying what file. I reported it only because in C++ runtime the behaviour is ignoring the error without to crash, while in XNA the behaviour is different.
    Attached files Attached files

  9. #59
    Clicker Multimedia Fusion 2 DeveloperiOS Export ModuleSWF Export Module
    Francois's Avatar
    Join Date
    Jul 2006
    Location
    Montpellier, France
    Posts
    6,920
    Mentioned
    0 Post(s)
    Tagged
    1 Thread(s)
    Animation counter bug corrected.
    INI problem corrected.
    Vector movement automatic direction bug corrected.
    Corrected the text counter Y positionning problem. There will still remain a difference between the C++ display and the XNA display though.

  10. #60
    Clicker Multimedia Fusion 2 DeveloperiOS Export ModuleSWF Export ModuleXNA Export Module

    Join Date
    Jul 2010
    Location
    Italy
    Posts
    368
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thank you very much for correcting those bugs!

    I have some more info about the old XNA XBox runtime bug of freezing the game when trying to play an mp3. I hope these can be of help for understanding what could be the cause of the problem.
    It seems like if the runtime needs to be stopped for a little while for the mp3 to be loaded correctly. Like we know, if you have an action that tries to play an mp3, the game starts to update the screen about every 2 seconds (and the music doesn't start). In particular, I realized that while there is this slowdown the other sounds are played immediatly. I mean that the other "Play sample" actions (not on mp3) seem not to suffer of this delay. For instance, I have a menu in a frame of my game. In this frame, in the "Start of frame" event I play and loop an mp3 music. I have events for pressing Up and Down key on the gamepad, with an action that plays a wav sound, and another to move the menu selection up or down. If I press the Down key twice, I hear immediatly the wav sound twice, but only after about 2 seconds I see the selected voice on the menu to be the third.
    I've tried to set a break point in Visual Studio at the line

    MediaPlayer.Play(song)

    in CSound.cs

    When I run the game, when I reach the menu Frame (that contains the mp3), the debugger stops to that line. Then I set another break point at the line

    base.Update(gameTime)

    of Game1.cs. Then I press F5, to continue to run my game until it reaches the base.Update(gameTime) instruction. At that moment, the mp3 starts to play. Then I cancel the break point on base.Update(gameTime) and press F5, and the game starts responding immediatly: there is no delay in updating the screen and the mp3 plays and loops correctly.

    Maybe a possible solution to the problem could be to automatically pause the application until it loads the complete mp3 file, and only then unpause it?
    I hope these tests I've made could be of help for understanding how to solve this bug.
    Thank you in advanced!

Page 6 of 8 FirstFirst ... 4 5 6 7 8 LastLast

Similar Threads

  1. Test Reports
    By James in forum Android Export Module Version 2.0
    Replies: 28
    Last Post: 16th December 2012, 08:02 PM
  2. Tom Schreiber - Test Reports
    By mobichan in forum XNA Export Module Version 2.0
    Replies: 44
    Last Post: 5th December 2011, 06:24 AM
  3. Ls2 - Test Reports
    By Ls2 in forum Android Export Module Version 2.0
    Replies: 7
    Last Post: 27th July 2011, 10:58 PM
  4. Federico Aliprandi - Test Reports
    By K1kk0z90 in forum Android Export Module Version 2.0
    Replies: 1
    Last Post: 20th July 2011, 01:27 PM
  5. Evilized79 - Test reports
    By Evilized79 in forum Android Export Module Version 2.0
    Replies: 4
    Last Post: 15th June 2011, 07:35 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •