User Tag List

Results 1 to 8 of 8

Thread: Moo sock doesnt work

  1. #1
    No Products Registered

    Join Date
    Jul 2010
    Posts
    36
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Moo sock doesnt work

    Hi there,

    Since a few day, moosock doesn't work. I only can be connected to a website but i can't send GET url. I've already tried to unistal/instal MMF and to open old .mfa and .exe file but that doesn't work too. How can i fix the problem?

  2. #2
    Clicker Fusion 2.5 MacFusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export ModuleXNA Export ModuleUnicode Add-on
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    Phi's Avatar
    Join Date
    Jan 2010
    Location
    England
    Posts
    1,848
    Mentioned
    15 Post(s)
    Tagged
    0 Thread(s)

    Re: Moo sock doesnt work

    MooSock is not completely free of bugs. A better alternative for using with HTTP would be the "Get object".

    If you need more customisation, my company/team is developing "DarkSocket", which is a replacement for MooSock. It's not released yet though.

  3. #3
    No Products Registered

    Join Date
    Jul 2010
    Posts
    36
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Moo sock doesnt work

    Yep, moosock has worked perfectly until last week and this is not normal that it does not work at all today. There is probably a way to solve the problem. I've got some old .mfa files (that was ok with moosock and that I don't edited) but it's the same problem.

    I've tried to replace moosock by GetObject but I only can do one request, otherwise nothing happened or my pc crash. Please help me to find a solution. It would be great if "DarkSocket" was able to properly replace moosock but I am suspicious. If a bug happened with this extension, I will return to the starting point.

  4. #4
    Clickteam Clickteam
    LB's Avatar
    Join Date
    Jun 2007
    Location
    Richardson, Texas, North America
    Posts
    8,937
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)

    Re: Moo sock doesnt work

    I have never experienced crashes with performing multiple requests with the Get object, and I can say that it still works fine to this day.

    Could you post a sample MFA on the MFA Repository demonstrating the crash?
    Working as fast as I can on Fusion 3

  5. #5
    No Products Registered

    Join Date
    Jul 2010
    Posts
    36
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Moo sock doesnt work

    I found why my pc crashed. In fact the problem come to ini + + when I load data from a Sring - which is this same object ini- (i bypassed this problem,using a "tempory" ini). It's now possible for me to replace moosock by getObject^^.

    I just hope getObject will not stop working for no reason, as moosock : /

  6. #6
    No Products Registered

    Join Date
    Jul 2010
    Posts
    36
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Moo sock doesnt work

    Does somebody have the file data/runtime/INI++.mfx ?
    It has disappeared from my computer.

  7. #7
    Clickteam Clickteam
    LB's Avatar
    Join Date
    Jun 2007
    Location
    Richardson, Texas, North America
    Posts
    8,937
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)

    Re: Moo sock doesnt work

    If you're experiencing random extensions having problems out of nowhere and disappearing, I'd recommend a virus scan. Also many developers do not want users redistributing their extensions...
    Working as fast as I can on Fusion 3

  8. #8
    Clicker

    Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleSWF Export ModuleXNA Export ModuleInstall Creator Pro
    nivram's Avatar
    Join Date
    Jul 2006
    Location
    Bandon, Oregon
    Posts
    6,736
    Mentioned
    9 Post(s)
    Tagged
    0 Thread(s)

    Re: Moo sock doesnt work

    You can re-download the INI++ extension in the Released Extension sub-forum. Then re-install it.

    Marv
    ​458 TGF to CTF 2.5+ Examples and games
    http://www.castles-of-britain.com/mmf2examples.htm

Similar Threads

  1. Android Exporter doesnt work
    By gnodab2 in forum Android Export Module Version 2.0
    Replies: 1
    Last Post: 11th November 2013, 01:47 PM
  2. XNA Win Phone 7 Effects doesnt work
    By Droggelbecher in forum XNA Export Module Version 2.0
    Replies: 3
    Last Post: 21st August 2012, 08:08 AM
  3. why doesnt this work?
    By Pritchy96 in forum Vitalize
    Replies: 6
    Last Post: 26th April 2008, 11:09 PM
  4. Colorizer Object doesnt work with HWA
    By Patrick in forum Extension Development
    Replies: 14
    Last Post: 25th October 2007, 10:40 AM
  5. cannot understand why my pathfinding doesnt work
    By integrality in forum Multimedia Fusion 2 - Technical Support
    Replies: 8
    Last Post: 8th September 2006, 12:59 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •