User Tag List

Results 1 to 3 of 3

Thread: Error in main with Simulator

  1. #1
    Clicker Multimedia Fusion 2 DeveloperiOS Export ModuleSWF Export ModuleXNA Export Module

    Join Date
    Jul 2010
    Location
    Italy
    Posts
    368
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Error in main with Simulator

    Hi all!
    If I test any iOS application with iPhone 4.3 Simulator, if I kill the app, and then I open it again, I get an error in the main function. Attached a screenshot.
    Is it normal? Do you get this error in Simulator but testing on a real iPhone 4 device works for you? Unfortunately at the moment I only have an iPod touch 2nd gen. I have iOS 4, but without multitasking, and I don't get this error closing and reopening my applications.
    Note: I get this error with both Release and Beta versions of the exporter, with projects using only released extensions and projects using also Beta extensions.
    Thanks in advanced for your help!
    Images attachées Images attachées

  2. #2
    Clicker Fusion 2.5 DeveloperiOS Export ModuleSWF Export Module
    mikec's Avatar
    Join Date
    Dec 2006
    Location
    UK
    Posts
    176
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Error in main with Simulator

    That usually happens if you force close the simulator without first pressing the stop button in xcode.

    By closing the simulator while xcode is still running the app, it's like unplugging the device so xcode throws the error, the error is not with the app but with the way you are killing it. I wouldnt worry about it.

  3. #3
    Clicker Multimedia Fusion 2 DeveloperiOS Export ModuleSWF Export ModuleXNA Export Module

    Join Date
    Jul 2010
    Location
    Italy
    Posts
    368
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Error in main with Simulator

    You're right, stopping debug instead of killing the application from Simulator solves the problem. Thank you!

Similar Threads

  1. I can't get it to run on xcode simulator.
    By SiXX in forum iOS Export Module Version 2.0
    Replies: 5
    Last Post: 4th January 2013, 03:32 AM
  2. iOS Simulator only displays in Portrait?
    By WhatPixelYouOn in forum iOS Export Module Version 2.0
    Replies: 6
    Last Post: 30th October 2012, 11:18 AM
  3. Very slow and laggy iOS simulator
    By fatgirlinohio in forum iOS Export Module Version 2.0
    Replies: 4
    Last Post: 3rd October 2012, 09:23 PM
  4. Paste to background error on iPhone and simulator
    By mrmdesign in forum iOS Export Module Version 2.0
    Replies: 2
    Last Post: 19th August 2011, 03:29 PM
  5. RTS Turret simulator ext.?
    By legocacher in forum Multimedia Fusion 2 - Technical Support
    Replies: 5
    Last Post: 5th April 2010, 11:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •