User Tag List

Results 1 to 10 of 10

Thread: Trouble loading images from machine using Flash Image Plus Gold (mfa included)

  1. #1
    Clicker Multimedia Fusion 2iOS Export Module

    Join Date
    Apr 2009
    Posts
    157
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Trouble loading images from machine using Flash Image Plus Gold (mfa included)

    Okay, so I've been building this swf application and decided to use Flash Image Plus Gold to load two images from the users computer onto the frame area.

    *.mfa attached*

    In the .mfa, the image loading events are at the start of the group "Front images". I'm trying to be able to get the app to load an image from the users machine when that user selects one of the Active objects but I can't work out how to be able to load these images.

    Then after that, I'm also trying to be able to constantly set the x and y values of this uploaded image to the same as a black box (image 1 board) that I have over the top as an invisible selection marker as well as the width and height. I'm not sure how to be able to set the width and height of images at the moment. The only method I can think would be some sort of algorithm in the x and y scale setting.

    I'm using a counter to be set to either 0 (none), 1 (left image) and 2(right image) and then this will be tested when options such as move, resize, delete and change image are selected. Then the black boxes over each image will be invisible at the end and act as the selections so that the user can click the images and be able to use resize/move/change and delete tools on them. So obviously, this needs to be linked so that the image plus import always has the same x,y,width and height values.

    Also, sorry if I posted this in the wrong place. I didn't know whether this belonged here or somewhere else.
    Attached files Attached files

  2. #2
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleMac Export ModuleSWF Export ModuleUnicode Add-on
    Pharanygitis's Avatar
    Join Date
    Aug 2006
    Location
    Germany
    Posts
    1,037
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    i can't open it.. you have renamed the screen capture extension.. please remove the "screen capture" from the example and upload it again

  3. #3
    Clicker Multimedia Fusion 2iOS Export Module

    Join Date
    Apr 2009
    Posts
    157
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Oops, sorry about that.

    New .mfa without ScreenCapture.
    Attached files Attached files

  4. #4
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleMac Export ModuleSWF Export ModuleUnicode Add-on
    Pharanygitis's Avatar
    Join Date
    Aug 2006
    Location
    Germany
    Posts
    1,037
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    You have forgott to set the "click-zone" correctly! In the Event "Load file from local maschine" is the width and height NOT the width/height from the image! its the width/height from the Click/Button-zone (i change the description in the next update)! And set the extension self to x 0 and y 0. Move you the extension, you move the complete drawing-area
    hoody3.mfa

  5. #5
    Clicker Multimedia Fusion 2iOS Export Module

    Join Date
    Apr 2009
    Posts
    157
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Okay, thanks for that. I don't know whether I'm missing something or getting something wrong but when it's exported to Flash, I still can't get the image to show up. The file select works fine now.

    Perhaps it's loading speed is quite long.

  6. #6
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleMac Export ModuleSWF Export ModuleUnicode Add-on
    Pharanygitis's Avatar
    Join Date
    Aug 2006
    Location
    Germany
    Posts
    1,037
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Here, a small example about the positions

  7. #7
    Clicker Multimedia Fusion 2iOS Export Module

    Join Date
    Apr 2009
    Posts
    157
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)


    So, if I do this then surely the image should appear where the extension is placed?
    I don't get any image loading when I've selected from a file. I made sure it was only a .png or .jpeg that I was importing but I don't get anything showing up.

  8. #8
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleMac Export ModuleSWF Export ModuleUnicode Add-on
    Pharanygitis's Avatar
    Join Date
    Aug 2006
    Location
    Germany
    Posts
    1,037
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Now, change the x and y in the "Load file from local maschine"-action to 0

  9. #9
    Clicker Multimedia Fusion 2iOS Export Module

    Join Date
    Apr 2009
    Posts
    157
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Yeah, I've done that and whenever I export it and go to test (once exported as a swf), I can work the file select very well but when I select an image from my files to display, it just won't appear. The extensions on the top layer as well so any image it loads should be on top, right?

    Thank you for helping me through this!

  10. #10
    Clicker Multimedia Fusion 2iOS Export Module

    Join Date
    Apr 2009
    Posts
    157
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hang on. I've just tested your example and it works on my laptop. I'll get my swf export back onto my laptop and test it here.

    When I was using my PC a few minutes ago (for exporting to swf), your example and all of my exports wouldn't show any image after file selection. My PC could be outdated on some software since it's been inactive for a while. It also runs on Vista, so that could also be a reason.

Similar Threads

  1. Images loading from url
    By crayzorechos in forum iOS Export Module Version 2.0
    Replies: 7
    Last Post: 29th April 2013, 05:03 PM
  2. Re sizing Flash Images Plus machine loaded file
    By Apex in forum SWF/Flash Export Module Version 2.0
    Replies: 2
    Last Post: 17th November 2011, 12:51 PM
  3. Flash Images Plus Internal File loading still doesn't work
    By Demi in forum SWF/Flash Export Module Version 2.0
    Replies: 10
    Last Post: 10th November 2011, 10:49 PM
  4. Loading images
    By Anders in forum Extension Developers Lobby
    Replies: 2
    Last Post: 11th May 2008, 07:07 PM
  5. Loading Tiles with APO (EXAMPLE INCLUDED!)
    By baracuda in forum Multimedia Fusion 2 - Technical Support
    Replies: 3
    Last Post: 28th May 2007, 11:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •