User Tag List

Results 1 to 3 of 3

Thread: Problems with Active Direct Show video playback in display mode DirectX9

  1. #1
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleInstall CreatorUnicode Add-on

    Join Date
    Jul 2006
    Posts
    1,017
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Exclamation Problems with Active Direct Show video playback in display mode DirectX9

    Hello everyone,

    I want to create an adventure game for a project in my studies. The different locations will be connected with short movie transitions. Should be pretty simple...

    To test MMF's behavior with video playback, I've done this very basic application. It shows the first upcoming problems with video playback in display mode Direct3D9. The current setting is Active Direct Show with display mode Direct3D8 and the video playback works as expected without problems. But if you change the display mode to Direct3D9 the video will be displayed brightened. And that's very ugly and useless for my wanted use. Good, it works under Direct3D8 but I want Direct3D9 (shaders etc.).

    What is the problem here? Is it a bug? And what can we do against it?

    Btw. Activate the group "Direct Show" (and deactivate group "Active Direct Show") to see how horrible it "works" with the Direct Show object (brightened in both Direct3D modes).

    It would also be nice if someone confirm this issue or maybe can notice another behavior.

    Thanks for every help
    Gustav

  2. #2
    Clickteam Clickteam

    Join Date
    Jun 2006
    Location
    France
    Posts
    13,025
    Mentioned
    108 Post(s)
    Tagged
    2 Thread(s)
    Hmm, I don't see any difference on my machine. Maybe it's a codec issue?

  3. #3
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleInstall CreatorUnicode Add-on

    Join Date
    Jul 2006
    Posts
    1,017
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks for testing, Yves. In Windows Media Player the videos looks like in MMF under Direct3D8 (normal), in VLC player like Direct3D9 (brightened). That's very odd.
    I remember that I noticed this issue long time ago on my old computer (Win Vista 32bit). But it crossed no project last time. Now it does.

    This is how it looks on my computer (Win7 64bit):
    Attachment 5390

    I can't imagine what this could cause. Especially this differences in the brightness of the Direct3D display modes inside MMF.
    And this issue shows it's not assured that it looks always the same for every user. Maybe it's the WMV format.
    I'll look around in the internet for similar cases, I didn't found something yet.

    It would be great if some other people could test this demo and post here how it looks like on their computers. Thanks in advance. ^^

Similar Threads

  1. Active Direct Show doesn't show the image of MP4(H.264) video
    By ASD in forum Multimedia Fusion 2 - Technical Support
    Replies: 0
    Last Post: 28th November 2012, 04:47 PM
  2. Video playback above active objects
    By Boba Fonts in forum Hardware Accelerated Runtime
    Replies: 2
    Last Post: 30th October 2010, 10:11 PM
  3. Direct Show & Audiere Object mp3 playback issues..
    By MikeB in forum Multimedia Fusion 2 - Technical Support
    Replies: 0
    Last Post: 23rd March 2009, 09:17 PM
  4. Direct Show problems
    By JoOCoGames in forum Multimedia Fusion 2 - Technical Support
    Replies: 16
    Last Post: 7th January 2008, 12:16 PM
  5. direct show / agrandissement de vidéo
    By REM in forum Multimedia Fusion 2 - Technical Support
    Replies: 5
    Last Post: 15th December 2007, 02:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •