User Tag List

View Poll Results: iOS SDK

Voters
30. You may not vote on this poll
  • iOS 5 SDK

    24 80.00%
  • iOS 4 SDK

    6 20.00%
  • iOS 3 SDK

    0 0%
Page 3 of 3 FirstFirst 1 2 3
Results 21 to 26 of 26

Thread: Poll: Which iOS SDK do you use?

  1. #21
    Forum Moderator Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export ModuleMac Export Module
    AndyH's Avatar
    Join Date
    Jun 2006
    Location
    UK
    Posts
    1,445
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Yes I found that too. My ipad updated to 5.1 and I had to update to the latest xcode app with iOS 5.1 sdk included before I could deploy to it again.
    Andy H @ ovine.net
    Awful Jokes - a new cartoon every day: http://awful.ovine.net/
    Ovine's games: http://www.ovine.net

  2. #22
    Clicker Fusion 2.5 DeveloperFusion 2.5 DeveloperiOS Export ModuleSWF Export ModuleMac Export ModuleUnicode Add-on
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    JasonDarby's Avatar
    Join Date
    Jun 2006
    Location
    UK
    Posts
    4,925
    Mentioned
    0 Post(s)
    Tagged
    1 Thread(s)
    I am on X-code 4.02 i think, my iPad 2 is running 5.0.1, my iPhone is 5.0 and my iPad 1 who knows... the 3g i guess is a dead device for making things on now right? They don't make it easy do they

    So if i use 5.1 sdk that means i have to use the latest CT exporter version?

  3. #23
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export ModuleXNA Export ModuleUnicode Add-on
    Fanotherpg's Avatar
    Join Date
    Jul 2006
    Location
    High Wycombe, Buckinghamshire, UK
    Posts
    3,665
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    5.

  4. #24
    Clicker Multimedia Fusion 2 DeveloperiOS Export ModuleSWF Export Module

    Join Date
    Jan 2012
    Posts
    107
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    My ipod upgraded itself to 5.1, and now I cant deploy to it. Furthermore, to get the latest xcode, I need to pay 30 bucks for lion.

    Anyone know a way to around this? Wish I never let the ipod update .... grumble

  5. #25
    Clickteam Clickteam
    Anders's Avatar
    Join Date
    Jun 2006
    Location
    Denmark, ┼rhus
    Posts
    3,455
    Mentioned
    4 Post(s)
    Tagged
    1 Thread(s)
    Can't you revert back to iOS5 through the XCode Organizer?

  6. #26
    Clicker Multimedia Fusion 2 DeveloperiOS Export ModuleSWF Export Module

    Join Date
    Jan 2012
    Posts
    107
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I can't seem to find a backup image for the old version :/

    I thought I had made it when I let iTunes upgrade to 5.1, but evidently that image wasn't saved


    Edit: - I eventually dug deep into the iTunes folder and found an 'ipsw' file for the 5.1 iOS download. Now that I knew what the image extension was, I dropped into xTerm and did a:

    find ./ -iname '*.ipsw'

    And found the 5.0.1 image in my .Trash folder. I wonder if iTunes put it there.

    Anyways, trying to restore to this image gives me an error that "This device isn't eligible for the requested build". I read somewhere that evidently Apple is preventing people from reverting back to iOS 5.0, and the only solutions Im finding online are to use jailbreaking tools to do it.

    It might indeed be that Lion is now required for development.


    Edit #2 - After failing the ipod restore, I decided to eat the $30 and upgrade to Lion. Unfortunately I cannot, as it does not support my single core mac mini.....

    This is frustrating. Anyone else still able to develop on Snow Leopard?


    Edit #3 - This dirty hack fixed my problem. You can't install the new xcode on Snow Leopard the official way, but you can duck into the unix commandline and copy the files over manually.

    http://www.iphonedevsdk.com/forum/ip...sdk-5-1-a.html

    Just in case this link goes dead, here are the steps:

    1. Download the dmg file for the new Xcode (4.3.1 for Lion)
    2. View the contents of the dmg file, which causes it to be mounted
    3. Duck into a terminal, and type the following. (Make sure Xcode is closed!)

    Hint: if you type the 'mount' command, it will show you mounted filesystems. The Xcode dmg file should show up in a location like /Volumes/Xcode/ - which is the source location in the copy commands below ...




    sudo cp -R /Volumes/Xcode/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS5.1.sdk /Developer/Platforms/iPhoneOS.platform/Developer/SDKs/

    sudo cp -R /Volumes/Xcode/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator5.1.sdk /Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/

    sudo cp -R /Volumes/Xcode/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/5.1\ \(9B176\) /Developer/Platforms/iPhoneOS.platform/DeviceSupport/

    sudo rm -f /Developer/Platforms/iPhoneOS.platform/DeviceSupport/Latest

    cd /Developer/Platforms/iPhoneOS.platform/DeviceSupport/

    sudo ln -s ./5.1\ \(9B176\) ./Latest



    Now, Xcode will still be at version 4.2, but it will compile and deploy to a device running 5.1. I wont ever be upgrading my iOS again until I know I can afford a new mac!

Page 3 of 3 FirstFirst 1 2 3

Similar Threads

  1. New Logo Poll
    By EnhancedStar in forum Articles
    Replies: 0
    Last Post: 4th February 2013, 12:28 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •