User Tag List

Results 1 to 9 of 9

Thread: Notice: iOS 5.1 SDK Incompatible with Snow Leopard

  1. #1
    Clickteam Clickteam
    Anders's Avatar
    Join Date
    Jun 2006
    Location
    Denmark, ┼rhus
    Posts
    3,455
    Mentioned
    4 Post(s)
    Tagged
    1 Thread(s)

    Notice: iOS 5.1 SDK Incompatible with Snow Leopard

    Hi everybody.
    I just wanted to make sure that everybody knows this:
    If you upgrade your device to iOS 5.1 you will then need OSX Lion to be able to compile for and deploy on your device!
    Apple has removed support for Snow Leopard when it comes to the iOS 5.1 SDK.

  2. #2
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleSWF Export ModuleMac Export Module
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    Koji_Kabuto's Avatar
    Join Date
    Jul 2006
    Location
    Venezuela
    Posts
    2,851
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    So Andos, to buy new Mac's.

  3. #3
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export ModuleXNA Export ModuleUnicode Add-on
    Fanotherpg's Avatar
    Join Date
    Jul 2006
    Location
    High Wycombe, Buckinghamshire, UK
    Posts
    3,665
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Nah. Not planned expenses :/ hate it. Anyone know if it would overwrite bootcamp?

  4. #4
    Clicker Fusion 2.5 DeveloperiOS Export ModuleSWF Export Module

    Join Date
    Oct 2010
    Location
    Hertfordshire
    Posts
    165
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    This is a little anoying.
    Even though the upgrade to Lion is pretty cheap, it looks like it may not even run on my old Mac Mini 1.83GHZ Core 2 Duo.
    At the very least I will definitely need to buy more ram and the worst case scenario could mean buying a whole new machine.
    Can I just continue running everything as is or will it not work that way?

    Thanks in advance for any tips.

  5. #5
    Clicker Fusion 2.5 DeveloperiOS Export ModuleSWF Export Module

    Join Date
    Oct 2010
    Location
    Hertfordshire
    Posts
    165
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Yay! I just found out that it will run on a Core 2 Duo! It just won't work on a Core Duo. I have found out that the little 2 is very important.
    Time to shop for 1gb of ram....

  6. #6
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleiOS Export ModuleSWF Export Module
    Tuna's Avatar
    Join Date
    Feb 2008
    Location
    Central Texas
    Posts
    1,853
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Wow, that's just great. THanks for the heads up...

  7. #7
    Clicker Multimedia Fusion 2 DeveloperiOS Export ModuleSWF Export Module

    Join Date
    Jan 2012
    Posts
    107
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Im on snow leopard, so when my ipod upgraded, my development pipeline was dead. I needed the 5.1 SDK to deploy to the device, which requires Xcode 4.3, which requires Lion, which requires better hardware than my recently-purchased imac can provide..... This was unacceptable to me, as my game had just launched. Im rather upset that Apple would cut out devs like this ....

    Then I found these instructions, which let you install the 5.1 SDK on Snow Leopard. Warning, these probably void warranty's, etc ....

    http://www.iphonedevsdk.com/forum/ip...sdk-5-1-a.html

  8. #8
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleiOS Export ModuleSWF Export Module
    Tuna's Avatar
    Join Date
    Feb 2008
    Location
    Central Texas
    Posts
    1,853
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by kinase View Post
    Im on snow leopard, so when my ipod upgraded, my development pipeline was dead. I needed the 5.1 SDK to deploy to the device, which requires Xcode 4.3, which requires Lion, which requires better hardware than my recently-purchased imac can provide..... This was unacceptable to me, as my game had just launched. Im rather upset that Apple would cut out devs like this ....

    Then I found these instructions, which let you install the 5.1 SDK on Snow Leopard. Warning, these probably void warranty's, etc ....

    http://www.iphonedevsdk.com/forum/ip...sdk-5-1-a.html
    THANK YOU!

    I haven't done it yet, but this looks very promising!

  9. #9
    Clicker Multimedia Fusion 2 DeveloperiOS Export ModuleSWF Export Module

    Join Date
    Jan 2012
    Posts
    107
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Don't do it if you don't have to, but it has seemed to solve my problem. I can once again compile and deploy.... but I havent tried submitting anything to apple with this new Xcode fix. For all I know, compiled binaries wont validate anymore - who knows.

Similar Threads

  1. Objet Quiz incompatible
    By imothep85 in forum SWF/Flash Export Module Version 2.0
    Replies: 3
    Last Post: 29th August 2012, 12:55 AM
  2. Mac os requirements snow leopard or lion?
    By rubes in forum iOS Export Module Version 2.0
    Replies: 20
    Last Post: 18th August 2012, 07:50 PM
  3. Mac os leopard intel ou nvidia ?
    By ABRAMAN in forum iOS Export Module Version 2.0
    Replies: 1
    Last Post: 5th November 2011, 08:04 AM
  4. Is the EDIT BOX incompatible with HWA full screen?
    By Tuna in forum Hardware Accelerated Runtime
    Replies: 4
    Last Post: 28th June 2010, 05:07 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •