Page 1 of 9 1 2 3 ... LastLast
Results 1 to 10 of 89

Thread: ClickConverse b103 (beta) - Report any bugs here

  1. #1
    Clickteam Clickteam
    Simon's Avatar
    Join Date
    Jun 2006
    Location
    UK
    Posts
    2,120
    Blog Entries
    3

    Exclamation ClickConverse b103 (beta) - Report any bugs here

    Please report any bugs you find with Build 103 here. Please do not post feature requests here, I have made a separate thread for those. This thread will be heavily moderated to keep it to bug reports only so I can keep a track of everything.

    Cheers,

    Simon.
    Last edited by Simon; 31st July 2012 at 12:40 PM.

  2. #2
    Clickteam Clickteam
    Olivier's Avatar
    Join Date
    Jun 2006
    Posts
    2,887
    Blog Entries
    2
    When I have two rooms open, and their windows are tabbed, clicking on a user in the peer list brings up the window of a user from the other room.

  3. #3
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export ModuleXNA Export ModuleUnicode Add-on
    Fanotherpg's Avatar
    Join Date
    Jul 2006
    Location
    High Wycombe, Buckinghamshire, UK
    Posts
    3,666
    Blog Entries
    6
    Oliviers used to happen only when you got more people in one room thab another and you clicked on a freespace in one window which was occupied by user in another.

    Anyway we don't need to repost bugs mentioned in other thread?

    This foum section dowsn't appear to have valid icon on my iPhone4.
    Last edited by Fanotherpg; 10th April 2012 at 04:58 PM.
    End is near.

  4. #4
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleSWF Export Module
    LB's Avatar
    Join Date
    Jun 2007
    Location
    Richardson, Texas, North America
    Posts
    8,923
    The D: smiley goes to instead, and there is no

    Also the forum icon is broken.

  5. #5
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export ModuleXNA Export ModuleUnicode Add-on
    Fanotherpg's Avatar
    Join Date
    Jul 2006
    Location
    High Wycombe, Buckinghamshire, UK
    Posts
    3,666
    Blog Entries
    6
    MMF2 Unicode is not appearing as a software on the list.
    End is near.

  6. #6
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export ModuleXNA Export ModuleUnicode Add-on
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    Phi's Avatar
    Join Date
    Jan 2010
    Location
    England
    Posts
    1,667
    Blog Entries
    7
    b102: /save has no default path, it should use Gwerdy's format & timestamp preferably for easy categorisation. Also, the font face isn't saved
    You're definitely making things happen Simon, congrats.
    Darkwire Software Lead Programmer (C++11 & C#)
    Darkwire Software | Extension List | Open-source extensions

  7. #7
    Clickteam Clickteam
    Simon's Avatar
    Join Date
    Jun 2006
    Location
    UK
    Posts
    2,120
    Blog Entries
    3
    I'll add a default save name, but it may not be identical to gwerdy.

    As for font face... I've taken this from a file saved out last night from the client's HTML/CSS definition:

    body {font-family: verdana; font-size: 12px; margin: 5px; background-color: rgb(255,255,255); color: rgb(50,50,50);}
    It works just fine for me... could you elaborate further?

  8. #8
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export ModuleXNA Export ModuleUnicode Add-on
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    Phi's Avatar
    Join Date
    Jan 2010
    Location
    England
    Posts
    1,667
    Blog Entries
    7
    Simon, please reconsider the save name, I don't think saving the logs to the application folder is a good practice for chatrooms. Also, I'm not sure but you might be missing leading 0s from some of the timestamp.
    Darkwire Software Lead Programmer (C++11 & C#)
    Darkwire Software | Extension List | Open-source extensions

  9. #9
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export ModuleXNA Export ModuleUnicode Add-on
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    Phi's Avatar
    Join Date
    Jan 2010
    Location
    England
    Posts
    1,667
    Blog Entries
    7

    White-out bug

    I saved a HTML document when the CC window whited out. The document shows no chat messages at all, although CSS is saved correctly. This indicates a file handle issue, and/or if WebX is saving the document itself, an issue with the object.
    Here's the codes:
    HTML Code:
    <html>
    <head>
    <title>Click Converse: Saved Transcript</title>
    <meta http-equiv="Content-Type" content="text/html;charset=ISO-8859-1">
    <style type="text/css">	html		{height: 100%;}
    	body		{font-family: verdana; font-size: 12px; margin: 5px; background-color: rgb(255,255,255); color: rgb(0,0,0);}
    	.lineCont		{display: block; clear: both;width: 100%; vertical-align: middle;}
    	.lineHead		{display: block; float: left; padding: 1px 0px 0px 0px; vertical-align: bottom;}
    	.lineMsg		{display: block; width: 100%; word-wrap: break-word; padding: 1px 3px 0px 0px; vertical-align: bottom;}
    
    	.textNote		{color: rgb(136,0,0);}
    	.textError		{color: rgb(255,0,0);}
    
    	.textEvent	{color: rgb(64,153,46);}
    
    	.textPM		{color: rgb(11,10,245);}
    	.textME		{color: rgb(111,32,189);}
    
    	.userName	{color: rgb(0,0,0); font-weight: bold;}
    
    	.textModNote	{color: rgb(255,0,0); border: 1px dashed #223344;}
    	.textNEN		{display: block; background-color: #ffdddd; color: #000000;}
    
    	.inlineLink		{color: rgb(50,40,255);}
    	.inlineLink:hover	{color: rgb(0,255,0);}
    
    	img.inlineBullet	{vertical-align: top; margin-right: 1px;}
    	.emoticonCase	{position: absolute; height: 14px; width: 18px; vertical-align: top;}
    	.emoticonPush	{display: inline; width: 20px; margin-right: 5px;}
    	img.emoticon	{vertical-align: middle; margin: 2px;}
    </style>
    </head>
    
    <body></body>
    </html>
    Darkwire Software Lead Programmer (C++11 & C#)
    Darkwire Software | Extension List | Open-source extensions

  10. #10
    Clickteam Clickteam
    Simon's Avatar
    Join Date
    Jun 2006
    Location
    UK
    Posts
    2,120
    Blog Entries
    3
    Thanks for the report :-)

    That's an interesting one and I instantly sse not something with a straightforward answer...

    The default document which is created when a new chat window is opened contains a standard document definition, CSS and some javascript which interacts with MMF and the page.

    New lines are added by creating a new node and appending it to the DOM, by calling a function from MMF. IE doesn't see this added content reliably (if at all) when you make a standard save request. Instead, I have a function to return the innerHTML of the whole page, which MMF can then read.

    At this point it recreates the document but without the javascript (which is unnecessary for a log save, in MMF. The return is injected into this.

    That you hsve the output file you do means WebX has either not returned the data at all, that it did return data but this overflowed a buffer or something, or, that the WebX had silently reset and restored the initial document (which was blank).

    I shall have to ask Fernando what he thinks... it certainty hasn't locked up MMF so I'm leaning toward WebX creating a data loss here somewhere.

    Cheers, Si.

Page 1 of 9 1 2 3 ... LastLast

Similar Threads

  1. Bugs iOS7 report
    By Koji_Kabuto in forum iOS Export Module Version 2.0
    Replies: 12
    Last Post: 30th October 2013, 02:27 PM
  2. [RC6] Bugs Report
    By Koji_Kabuto in forum Android Export Module Version 2.0
    Replies: 15
    Last Post: 14th March 2013, 02:22 PM
  3. [RC3] Bugs Report
    By Koji_Kabuto in forum Android Export Module Version 2.0
    Replies: 32
    Last Post: 7th March 2013, 08:58 AM
  4. SQLite3 BUGS - Please report any
    By byo in forum Multimedia Fusion 2 - Technical Support
    Replies: 4
    Last Post: 3rd May 2009, 06:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •