User Tag List

Results 1 to 5 of 5

Thread: [Beta 32 bug] Sounds

  1. #1
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleiOS Export ModuleSWF Export ModuleXNA Export ModuleMac Export ModuleInstall Creator Pro
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    kiko's Avatar
    Join Date
    Apr 2012
    Location
    Murcia -Spain
    Posts
    242
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Exclamation [Beta 32 bug] Sounds

    I have seen that the sound system of the exporting Android still have problems, basically in two situations:

    1- When you have diferent sound configured with different options (one "Preload", another "Load On Call" and/or another "Play from Disk"), if try play various file sounds configured with the same option the sounds no play.
    In other words, you can play "sound.wav" config with "preload" and other sound configured with "Load on call", but you not play two different sounds configured with "preload" option at time.

    2- Randomly during the execution of an app (created with Android Exporter) and after some time of open it, in certain frames the sounds stop working.
    I detect this problem in frames of third level, for exmaple:

    frame 1
    frame 2 -> frame 3 -> frame 4
    frame 5

    In frame 4, randomly after some time, the sounds not play. If you close the app and open another time, the sounds in this frame play ok, and randomly after some time the sounds not play another time.

    I do not know if any other people have the same problem.

  2. #2
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleSWF Export ModuleMac Export Module
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    Koji_Kabuto's Avatar
    Join Date
    Jul 2006
    Location
    Venezuela
    Posts
    2,851
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    That may me this happening to me, as many sounds are in preload are not reproducing.

  3. #3
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleiOS Export ModuleSWF Export ModuleXNA Export ModuleMac Export ModuleInstall Creator Pro
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    kiko's Avatar
    Join Date
    Apr 2012
    Location
    Murcia -Spain
    Posts
    242
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Dear JosÚ,

    You can fix it taking care of the type of sound played at the same time
    For example: You have an app that use 3 sound ("shot.ogg","effect.ogg" and "music.ogg")
    You can take problems if all sound are the same config, for example "preload" and two or more sound are playing at time.
    But if you config the "shot.ogg" with "preload" option, "effect.ogg" with "load on call" and "music.ogg" with "play from disk" option, the sounds works fine.

    On the other hand and setting the sounds correctly, we can find other problems as I indicated in paragraph 2 of this thread.

    I guess in the next beta will be solved

  4. #4
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleSWF Export ModuleMac Export Module
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    Koji_Kabuto's Avatar
    Join Date
    Jul 2006
    Location
    Venezuela
    Posts
    2,851
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    If Kiko, is a good way to fix at the moment. But hopefully James can correct this for the next beta.

  5. #5
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleiOS Export ModuleSWF Export ModuleXNA Export ModuleMac Export ModuleInstall Creator Pro
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    kiko's Avatar
    Join Date
    Apr 2012
    Location
    Murcia -Spain
    Posts
    242
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Yes, of course

Similar Threads

  1. [Beta 30] Some sounds don't actually play at all
    By EdSabbath in forum Android Export Module Version 2.0
    Replies: 9
    Last Post: 11th June 2012, 10:09 AM
  2. [bug] beta 30 - sounds
    By qenio in forum Android Export Module Version 2.0
    Replies: 3
    Last Post: 24th May 2012, 04:01 PM
  3. Beta / SDK 4.1 - Not all sounds do play
    By BHGames in forum iOS Export Module Version 2.0
    Replies: 1
    Last Post: 15th November 2010, 12:36 PM
  4. Beta 3: Preload Wav Sounds?
    By UrbanMonk in forum iOS Export Module Version 2.0
    Replies: 3
    Last Post: 29th October 2010, 06:55 AM
  5. Beta 3 Sounds over frames
    By Jeff in forum iOS Export Module Version 2.0
    Replies: 3
    Last Post: 20th October 2010, 07:41 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •