User Tag List

Results 1 to 6 of 6

Thread: Get object not working in SWF

  1. #1
    Clickteam Clickteam

    Join Date
    Jun 2006
    Location
    California, USA
    Posts
    1,247
    Mentioned
    0 Post(s)
    Tagged
    1 Thread(s)

    Unhappy Get object not working in SWF

    I am attempting to use the GET object to pull information from the Google API. This works great in an EXE but fails when I attempt to run the same as a Flash runtime. I get no error when I compile but there also seems to be no connection with the Google API. I have also added a crossdomain.xml to the server where I am hosting the Flash file and it still does not work. Lastly I have set the scriptaccess in the HTML file to "always" which did not help.

    I have attached an example file.
    Attached files Attached files
    DT
    Special Projects Director

  2. #2
    Forum Moderator

    Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleSWF Export ModuleXNA Export ModuleInstall Creator Pro
    nivram's Avatar
    Join Date
    Jul 2006
    Location
    Bandon, Oregon
    Posts
    6,768
    Mentioned
    12 Post(s)
    Tagged
    0 Thread(s)
    Mr. Holder. May I suggest trying another website to see if it works. I think Google has gone weird with us normal people trying to do stuff with them.

    Marv
    ​458 TGF to CTF 2.5+ Examples and games
    http://www.castles-of-britain.com/mmf2examples.htm

  3. #3
    Clickteam Clickteam

    Join Date
    Jun 2006
    Location
    California, USA
    Posts
    1,247
    Mentioned
    0 Post(s)
    Tagged
    1 Thread(s)
    I tried using our own server to pull information. There seems to be no connection established.
    DT
    Special Projects Director

  4. #4
    Clicker Multimedia Fusion 2 DeveloperiOS Export ModuleSWF Export Module
    Francois's Avatar
    Join Date
    Jul 2006
    Location
    Montpellier, France
    Posts
    6,920
    Mentioned
    1 Post(s)
    Tagged
    1 Thread(s)
    Can you try on by uploading your app and loading something with the GET on the same domain? I am not 100% sure, but I think Flash restricts the use to the same domain...

  5. #5
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleSWF Export Module

    Join Date
    Apr 2007
    Posts
    208
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Particularly when you run it locally and not on a web server at all. Flash has increased security for locally running sites, which you can alter if you change the global flash settings. I was able to add a directory to a list of trusted directories.

  6. #6
    Clicker Multimedia Fusion 2 DeveloperSWF Export Module

    Join Date
    Jun 2006
    Posts
    6,773
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by DT
    I have also added a crossdomain.xml to the server where I am hosting the Flash file
    crossdomain.xml has to go on the server you want to access, not the server on which your SWF lives. I guess in this case it's impossible.

Similar Threads

  1. Can't get GET object working on WP
    By MJK in forum XNA Export Module Version 2.0
    Replies: 15
    Last Post: 1st November 2012, 01:55 AM
  2. Encrypt Object not working
    By ToxicKiwiGames in forum Multimedia Fusion 2 - Technical Support
    Replies: 2
    Last Post: 9th June 2011, 06:48 PM
  3. Get object not working with Flash
    By Zoglu in forum SWF/Flash Export Module Version 2.0
    Replies: 1
    Last Post: 17th May 2011, 11:05 PM
  4. Get object not working
    By gamefreak202 in forum Multimedia Fusion 2 - Technical Support
    Replies: 10
    Last Post: 26th November 2010, 12:39 AM
  5. INI Object not working?
    By Durnus in forum Multimedia Fusion 2 - Technical Support
    Replies: 9
    Last Post: 2nd July 2006, 08:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •