User Tag List

Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16

Thread: Can't get GET object working on WP

  1. #1
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export ModuleXNA Export Module
    MJK's Avatar
    Join Date
    Jun 2006
    Location
    Espoo, Finland
    Posts
    1,162
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Can't get GET object working on WP

    I read from the forum that others have got GET working on WP, but it failed for me after multiple tries.

    This is what I did:

    (start new blank app/project, add Get object and string object)

    Start of frame
    - Get URL "http://www.mydomain.com/scores.php"

    On get complete (tried also with always)
    - Set alterable string to Received$("Get Object")

    This works within MMF, in flash and iOS, but in XNA on WP device and emulator the string stays empty.

    What could be wrong?

  2. #2
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export ModuleXNA Export Module
    MJK's Avatar
    Join Date
    Jun 2006
    Location
    Espoo, Finland
    Posts
    1,162
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Bump. I'm stuck here as I use Get for all custom online high scores in my games.

    Would anyone who's got this working be willing to provide a small example of Get which receives content from any URL and works fine in WP devices and WP emulator?

  3. #3
    Clickteam Clickteam
    Jeff's Avatar
    Join Date
    Jun 2006
    Location
    Battle Ground Washington
    Posts
    11,825
    Mentioned
    8 Post(s)
    Tagged
    2 Thread(s)
    Perhaps if you can find the threads where a person got it to work in WP and see if they can help.
    I don't know what could be blocking it - I don't have a WP to do any testing. Are there properties like in Android that you might have to enable?

  4. #4
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export ModuleXNA Export Module
    MJK's Avatar
    Join Date
    Jun 2006
    Location
    Espoo, Finland
    Posts
    1,162
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Indeed there was one setting that needed to be manually adjusted.

    Thanks to Keith I got this one sorted out. The solution is the same as described here: http://community.clickteam.com/showthread.php?t=71713
    (however in my case, I didn't get any error/warning in debug mode before)

  5. #5
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export ModuleXNA Export Module
    MJK's Avatar
    Join Date
    Jun 2006
    Location
    Espoo, Finland
    Posts
    1,162
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Still struggling a bit with Get object. I got receiving working based on Keith's advice (see above), but sending/posting is not yet working for me.

    When I use a long url with Get object like "http://domain.com/sendscore.php?name="+name+"&score="+score+"&info3= "+info3+"&info4="+info4+"&info5="+info5+"&mdfive=" +mdFive$( "String Parser" )

    i get this error:




    If I add the variables as POST data, there's no error BUT nothing is sent to the database even though "On get complete" is triggered.

    -----
    EDIT: String Parser MD5 action crashes or more specifically setting string alterable value to mdFive$( "String Parser" ). Example mfa attached.
    Attached files Attached files

  6. #6
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleXNA Export Module
    Dobermann's Avatar
    Join Date
    Feb 2009
    Location
    France
    Posts
    837
    Mentioned
    38 Post(s)
    Tagged
    0 Thread(s)
    You have a solution to send data to the web to save hi-scores? That's the only one thing i wasn't able to do when making Jazz Jackrabbit for WP with the XNA beta. I would like to add online hi-scores support!

  7. #7
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export ModuleXNA Export Module
    MJK's Avatar
    Join Date
    Jun 2006
    Location
    Espoo, Finland
    Posts
    1,162
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Yes, well I'm trying to use the same solution like in my other games, exe, flash, iOS, etc. Every other runtime works OK, but in XNA, there are two separate problems: 1) Get object sending/posting hasn't yet worked i.e. no data is being posted to the database (receiving works ok). 2) String Parser MD5 crash

    I think there is a public tutorial on the online high scores somewhere on the clickteam site, and my method is just a modification of that approach.

  8. #8
    Clicker Multimedia Fusion 2 DeveloperiOS Export ModuleSWF Export Module
    Francois's Avatar
    Join Date
    Jul 2006
    Location
    Montpellier, France
    Posts
    6,920
    Mentioned
    1 Post(s)
    Tagged
    1 Thread(s)
    - String parser problem corrected.
    - The code to send POST messages to a server was in fact not implemented. I have done it.

  9. #9
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export ModuleXNA Export Module
    MJK's Avatar
    Join Date
    Jun 2006
    Location
    Espoo, Finland
    Posts
    1,162
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Great stuff, thanks!

  10. #10
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleXNA Export Module
    Dobermann's Avatar
    Join Date
    Feb 2009
    Location
    France
    Posts
    837
    Mentioned
    38 Post(s)
    Tagged
    0 Thread(s)
    I'll try to update my Jazz Jackrabbit game with online hi-scores! :p

Page 1 of 2 1 2 LastLast

Similar Threads

  1. Get object not working in SWF
    By DT in forum SWF/Flash Export Module Version 2.0
    Replies: 5
    Last Post: 10th September 2012, 04:09 PM
  2. Encrypt Object not working
    By ToxicKiwiGames in forum Multimedia Fusion 2 - Technical Support
    Replies: 2
    Last Post: 9th June 2011, 06:48 PM
  3. Get object not working with Flash
    By Zoglu in forum SWF/Flash Export Module Version 2.0
    Replies: 1
    Last Post: 17th May 2011, 11:05 PM
  4. Get object not working
    By gamefreak202 in forum Multimedia Fusion 2 - Technical Support
    Replies: 10
    Last Post: 26th November 2010, 12:39 AM
  5. INI Object not working?
    By Durnus in forum Multimedia Fusion 2 - Technical Support
    Replies: 9
    Last Post: 2nd July 2006, 08:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •