User Tag List

Results 1 to 7 of 7

Thread: [BUG RC1] Vibrate - Android Object

  1. #1
    Clickteam Clickteam
    Danny's Avatar
    Join Date
    Aug 2007
    Location
    United Kingdom
    Posts
    3,008
    Mentioned
    21 Post(s)
    Tagged
    2 Thread(s)

    [BUG RC1] Vibrate - Android Object

    This doesn't work for me. I have tested on Sony Xperia U running version 2.3.7

    I tried 3 different combos:
    Every 50ms : Vibrate (250ms)
    Every 1 Second, 50ms : Vibrate (250ms)
    Every 3 Seconds : Vibrate (250ms)

    I just get a force close. Will try again, get the stacktrace and report back. I needed to post this otherwise I could've forgot
    Want to learn Clickteam Fusion 2.5?




  2. #2
    Clicker Multimedia Fusion 2 DeveloperSWF Export Module

    Join Date
    Jun 2006
    Posts
    6,773
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Check the "VIBRATE" permission in the application properties.

  3. #3
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleSWF Export ModuleInstall Creator Pro
    Ls2's Avatar
    Join Date
    Jun 2011
    Location
    Maceiˇ - Brazil
    Posts
    914
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Works here.

  4. #4
    Clickteam Clickteam
    Danny's Avatar
    Join Date
    Aug 2007
    Location
    United Kingdom
    Posts
    3,008
    Mentioned
    21 Post(s)
    Tagged
    2 Thread(s)
    I am stupid. /me holds up sign.

    Btw, I've been non-stop for 11 hours now on the Android testing and so far so good. Just one thing I wanted to ask Jamie, my MFA has been optimised to the DEATH, after all the graphical and coding optimisations I get a steady framerate of ~60fps, during battle I get ~30-45fps. I have managed to narrow down the drop in FPS to 'Create Object' and 'Bullet Collides with'. I have even tried setting both the bullet and enemy to boxmode to try save a little processing on the complexity of the actives yet still the dip. Would it be sensible to put this down to MMF's collision detection?

    Anyhow, it's not an issue, just tested with 4-5 devices and the drop always seems to be coming from both when the bullet is created and then when it collides with an object.

    On some conditions I have even tried to save on processing with:
    No of Objects("Bullet") > 0
    +Bullet Collides with Enemy

    But I get the same result eitherway. Apart from that it's working grand and I'm looking forward to getting it complete. Good Work!
    Want to learn Clickteam Fusion 2.5?




  5. #5
    Clicker Multimedia Fusion 2 DeveloperSWF Export Module

    Join Date
    Jun 2006
    Posts
    6,773
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    If you send me your MFA, I can try to profile it to see what's causing the slowdown.

  6. #6
    Clicker Fusion 2.5 DeveloperFusion 2.5 DeveloperAndroid Export ModuleiOS Export ModuleXNA Export Module
    DistantJ's Avatar
    Join Date
    Jan 2008
    Location
    Gloucester, UK
    Posts
    2,142
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Is your bullet using fine detection? Kinda sounds like the exporter drawing a complicated collision mask when creating the bullet, and then testing it on collision.

  7. #7
    Clickteam Clickteam
    Danny's Avatar
    Join Date
    Aug 2007
    Location
    United Kingdom
    Posts
    3,008
    Mentioned
    21 Post(s)
    Tagged
    2 Thread(s)
    Just an update on this issue I've been working on and it appeared to ultimately be the sound files :/ The game runs smooth without sound so now I'm trying to narrow down the optimal configuration for sound. Up until this point all I could assume was bullet creation/bullet collision, I had the sounds in there to audibly detect that the event was triggering, so it was the debugging solution that caused the problem in the first place. How ironic? Apart from the sound issue I am maintaining ~50fps constant with IGX including all weapons and complete dynamic starfield w/objects.
    Want to learn Clickteam Fusion 2.5?




Similar Threads

  1. Vibrate
    By Jymswiss in forum Android Export Module Version 2.0
    Replies: 2
    Last Post: 14th June 2013, 03:08 PM
  2. Vibrate Lag - Beta 7
    By xhedgehogx in forum iOS Export Module Version 2.0
    Replies: 1
    Last Post: 8th May 2012, 01:35 PM
  3. Vibrate iOS Object
    By Koji_Kabuto in forum iOS Export Module Version 2.0
    Replies: 2
    Last Post: 31st January 2012, 11:44 PM
  4. Beta 18: iPhone Vibrate does not work
    By Koji_Kabuto in forum iOS Export Module Version 2.0
    Replies: 9
    Last Post: 2nd April 2011, 03:16 PM
  5. Make the iPhone vibrate?
    By netninja in forum iOS Export Module Version 2.0
    Replies: 9
    Last Post: 23rd March 2011, 10:29 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •