User Tag List

Results 1 to 3 of 3

Thread: Issues with "Overlapping an Object / background" and 'User Clicks".

  1. #1
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleSWF Export Module
    redpandagames's Avatar
    Join Date
    Dec 2011
    Posts
    375
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Issues with "Overlapping an Object / background" and 'User Clicks".

    I'm really struggling to find a way around this...

    Basically, I have various objects that the player will move over.

    LOGIC:

    IF
    Player is overlapping an object
    Index 1 is greater than 0
    User clicks on "object 1"

    then move player x position +50

    This works fine, but if they player moves from over one object to over another object, the event will trigger without the player having to click again.

    It's almost like the event is firing too early, or the "mouse is up" isn't being detected early enough. It's a problem for me because the player will unnatrually skip forward without having to click, so it looks like they took an extra large jump. It doesn't matter whether the player is moving between unique objects or not.

    Any ideas? Also, it doesn't matter if I change the logic to "player is overlapping a background". Other people must have run into this...

    I really don't want to define logic for every square on my board...

  2. #2
    Clicker Multimedia Fusion 2 DeveloperiOS Export ModuleSWF Export Module
    Francois's Avatar
    Join Date
    Jul 2006
    Location
    Montpellier, France
    Posts
    6,920
    Mentioned
    0 Post(s)
    Tagged
    1 Thread(s)
    Just a suggestion : can you try putting the User clicks condition first of the group of event? This is a true event condition, the code to make it work in second position is a bit tricky...

  3. #3
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleSWF Export Module
    redpandagames's Avatar
    Join Date
    Dec 2011
    Posts
    375
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks. I tried this and it seems to be working, but I'll need to test it a little bit more to make sure.

Similar Threads

  1. "User clicks with left button" doesn't work
    By Ben Laserlove in forum Multimedia Fusion 2 - Technical Support
    Replies: 5
    Last Post: 3rd April 2017, 12:03 AM
  2. Sluggish response to "user clicks on an object"
    By ratty in forum Multimedia Fusion 2 - Technical Support
    Replies: 3
    Last Post: 4th July 2012, 11:52 PM
  3. is "paste image into background" & "add backdrop" the same thing?
    By jaaj302005 in forum Multimedia Fusion 2 - Technical Support
    Replies: 3
    Last Post: 5th December 2011, 08:45 PM
  4. Issues with "Clickteam Movement Controller" and "Runtime" Object
    By jimmyorpheus in forum iOS Export Module Version 2.0
    Replies: 1
    Last Post: 29th November 2011, 08:10 AM
  5. Quick Time object & "User clicks..." problem
    By kikiriki in forum Multimedia Fusion 2 - Technical Support
    Replies: 1
    Last Post: 14th December 2010, 12:05 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •