User Tag List

Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 25

Thread: Petit problème SDK avec Visual C++ 8.0

  1. #1
    Tyrael
    Guest

    Petit problème SDK avec Visual C++ 8.0

    Bonjour!
    Comme j'utilisait Dev-Cpp et que ca ne collait pas avec les SdK de MMF2 j'ai donc téléchargé le dernier Visual C++ (8.0 Express), donc j'ai suivi les instructions du fichier d'aide et quand j'ai fait "compiler" il me dit:
    "Edittime.cpp
    c:\documents and settings\[???]\bureau\mmf2sdk\inc\ccxhdr.h(38) : fatal error C1083: Impossible d'ouvrir le fichier include*: 'windows.h'*: No such file or directory"
    alors que le fichier est bien présent. Peut être a cause des majuscules?
    Bon donc voila je demande votre aide.
    Merci

  2. #2
    No Products Registered

    Join Date
    Jun 2006
    Posts
    37
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Petit problème SDK avec Visual C++ 8.0

    Je crois bien qu'il faut paramétrer le linker. (Il doit manquer des librairies ou des répertoires)

  3. #3
    Tyrael
    Guest

    Re: Petit problème SDK avec Visual C++ 8.0

    Euh je sait pas comment on fait...

  4. #4
    Tyrael
    Guest

    Re: Petit problème SDK avec Visual C++ 8.0

    Bon j'ai trouvé le problème mais je sait pas comment le régler:
    Dans le répertoire VC/Include qui se trouve dans le dossier de Visual C++ il manque des fichiers comme dans ce cas la windows.h ,alors moi j'ai mis windows.h que j'ai trouvé sur un autre compilateur et il m'as demandé un autre fichier, et j'ai continuer jusqu'a ce que je me retrouve a chercher un fichier que j'ai pas (winerror.h)
    Donc si vous avez une solution n'hesitez pas a m'aider!
    Merci

  5. #5
    Clickteam Clickteam

    Join Date
    Jun 2006
    Location
    France
    Posts
    13,190
    Mentioned
    141 Post(s)
    Tagged
    2 Thread(s)

    Re: Petit problème SDK avec Visual C++ 8.0

    Pour utiliser VC++ Express il faut installer le Platform SDK de Microsoft et ajouter les répertoires include et lib de ce SDK à la liste des répertoires include et lib de VC++. Je pense que tout ça est mentionné sur le site de VC++ sur microsoft.com.

    Yves.

  6. #6
    Tyrael
    Guest

    Re: Petit problème SDK avec Visual C++ 8.0

    Voila j'ai installé les SDK et la je copie donc ca devrait marcher merci!

  7. #7
    Clickteam Clickteam

    Join Date
    Jun 2006
    Location
    France
    Posts
    13,190
    Mentioned
    141 Post(s)
    Tagged
    2 Thread(s)

    Re: Petit problème SDK avec Visual C++ 8.0

    Juste un truc: il ne faut pas "copier" les répertoires include et lib dans ceux de VC++, il faut simplement ajouter leur nom de chemin à la liste des noms des répertoires include et lib dans les options de VC++ (ce sont les répertoires qu'il inspecte lorsqu'il cherche un fichier .h ou .lib qui n'est pas présent dans le répertoire du projet).

    Yves.

  8. #8
    Clicker Fusion 2.5

    Join Date
    Jul 2006
    Posts
    14
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Petit problème SDK avec Visual C++ 8.0

    Petite note aussi, Visual C++ Express Edition 2005 (8.0) n'est pas livré avec Microsoft Foundation Classes.
    Je pense que c'est pour cela que j'ai eu une erreur avec afxres.h non trouvé.Comme suscité, le Platform SDK est par contre lui téléchargeable gratuitement sur le site de Microsoft.

  9. #9
    Tyrael
    Guest

    Re: Petit problème SDK avec Visual C++ 8.0

    Bon moi j'ai téléchargé et j'ai "copié" (j'avait pas lu le message) et tout fonctionne a merveille!

  10. #10
    No Products Registered

    Join Date
    Jul 2006
    Posts
    93
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Petit problème SDK avec Visual C++ 8.0

    j'ai aussi un probleme, j'ai téléchargé le platform sdk, j'ai plus les erreurs de windows.h mais j'ai quand meme une série de 15 erreurs :

    Création de la bibliothèque .\Debug/Template.lib et de l'objet .\Debug/Template.exp
    Edittime.obj : error LNK2019: symbole externe non résolu __imp__LoadStringA@16 référencé dans la fonction "void __stdcall GetObjInfos(class mv *,struct tagEDATA_V1 *,char *,char *,char *,char *,char *)" (?GetObjInfos@@YGXPAVmv@@PAUtagEDATA_V1@@PAD2222@Z )
    Edittime.obj : error LNK2019: symbole externe non résolu __imp__EndDialog@8 référencé dans la fonction "int __stdcall setupProc(struct HWND__ *,unsigned int,unsigned int,long)" (?setupProc@@YGHPAUHWND__@@IIJ@Z)
    Edittime.obj : error LNK2019: symbole externe non résolu __imp__GetWindowLongA@8 référencé dans la fonction "int __stdcall setupProc(struct HWND__ *,unsigned int,unsigned int,long)" (?setupProc@@YGHPAUHWND__@@IIJ@Z)


    bon je vais pas mettre toute la liste hein ^^
    comment résoudre ce problème ?

Page 1 of 3 1 2 3 LastLast

Similar Threads

  1. petit probleme avec installateur pour mmf2
    By Gino in forum Multimedia Fusion 2 - Technical Support
    Replies: 2
    Last Post: 14th April 2009, 12:10 PM
  2. petit probleme avec moteur de platform (bug?)
    By rurkryber in forum Multimedia Fusion 2 - Technical Support
    Replies: 0
    Last Post: 10th December 2008, 09:44 PM
  3. Petit problème
    By titou94 in forum The Games Factory 2 - Technical Support
    Replies: 2
    Last Post: 12th February 2008, 06:45 PM
  4. petit probleme!
    By rurkryber in forum File Archive
    Replies: 2
    Last Post: 22nd October 2007, 05:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •