User Tag List

Results 1 to 4 of 4

Thread: A Bug!

  1. #1
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleSWF Export ModuleXNA Export Module
    Outcast's Avatar
    Join Date
    Jan 2011
    Location
    Sweden
    Posts
    3,150
    Mentioned
    8 Post(s)
    Tagged
    0 Thread(s)

    A Bug!

    I have found something that must be some kind of bug. I have isolated it in this example.

    You can aim the "cannon" with the mouse and press the left mouse button to shoot the "bullets" toward the blue object. It is set to fine collision but as you will see it behaves very strange. The bullets stop at the wrong place. Also this only happens if I have the event to scale the blue thing to 0.5 at the start of frame. If you erase that event it will work as expected. Any ideas why this is happening? Any way around it?
    Images attachées Images attachées
    Attached files Attached files

  2. #2
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleiOS Export ModuleSWF Export Module
    Skyhunter's Avatar
    Join Date
    Jan 2007
    Location
    Croatia
    Posts
    451
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Really strange. I v given movement to the rifle and when you shoot all across the object you see the outline is exactly the same object reversed horizontally and vertically.
    Ok, also if you remove the angle from the bullet and instead set the angle to an alt value, it works....

    It seems the problem is somehow connected to the angle of the bullet and the colliding object being scaled, when the angle is anything besides 0 it collides wrong. You could probably workaround by making the bullet invisible and make a double one just to follow it showing the proper angle, but this looks like something that needs to be fixed...

    https://dl.dropbox.com/u/14962632/Pu...Pbullet182.mfa

  3. #3
    Clickteam Clickteam
    Danny's Avatar
    Join Date
    Aug 2007
    Location
    United Kingdom
    Posts
    2,997
    Mentioned
    19 Post(s)
    Tagged
    2 Thread(s)
    I can confirm it is an issue and just to note it is only affecting HWA (D3D8/9).

    It would appear that after scaling the collision mask isn't scaled, it remains at 1.0 but seems to be skewed somehow, I suppose Yves or Francois will get what I mean when they download the mfa.
    Want to learn Clickteam Fusion 2.5?




  4. #4
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleSWF Export ModuleXNA Export Module
    Outcast's Avatar
    Join Date
    Jan 2011
    Location
    Sweden
    Posts
    3,150
    Mentioned
    8 Post(s)
    Tagged
    0 Thread(s)
    Thanks the workaround works It seems to be a bug yes!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •