User Tag List

Results 1 to 9 of 9

Thread: xcode 4.5.2 update

  1. #1
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleiOS Export ModuleSWF Export Module
    Tuna's Avatar
    Join Date
    Feb 2008
    Location
    Central Texas
    Posts
    1,853
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    xcode 4.5.2 update

    has anyone had any issues with Xcode 4.5.2? I'm always hesitant to update xcode and itunes and even OS X (haven't yet gone to 10.8.2) because i am concerned there could be issues.

    Thanks

  2. #2
    Clickteam Clickteam
    Olivier's Avatar
    Join Date
    Jun 2006
    Posts
    2,996
    Mentioned
    9 Post(s)
    Tagged
    1 Thread(s)
    I have updated a game using Xcode 4.5.2 and didn't encountered any problems. With the update I have noticed in "Build Settings" that the Architectures have changed to "armv7 armv7s", there's no support for "armv6" anymore. From what I understand, the update will allow you to support newer iOS versions, but no longer the older ones. For more detailed info, see Apple's release notes for Xcode: http://developer.apple.com/library/i...de/_index.html

  3. #3
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export ModuleXNA Export Module

    Join Date
    Aug 2006
    Posts
    137
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I always update when it comes to iOS. Apple doesnt really work like M$, I dont think there is such a thing as an 'optional' update when it comes to XCode & iOS.

    The days of being able to lock down a dev environment and stick with it seem to be gone.

  4. #4
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleiOS Export ModuleSWF Export Module
    Tuna's Avatar
    Join Date
    Feb 2008
    Location
    Central Texas
    Posts
    1,853
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Thanks Olivier... I'm not worried about armv6 so yeah, i'll go ahead and update.

    arsdigita, i hear that... its more a concern of incompatibility with MMF2/IOS exporter and the latest xcode/ios versions, so i usually hold off a while before updating.

  5. #5
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleiOS Export ModuleUnicode Add-on

    Join Date
    Oct 2011
    Posts
    217
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    4.5.2 seems to work OK.
    I had to upgrade, I could not renew developer certificates and provisioning without a recent XCode version.

  6. #6
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export ModuleXNA Export ModuleUnicode Add-on
    mobichan's Avatar
    Join Date
    Oct 2007
    Location
    Buffalo, NY
    Posts
    3,281
    Mentioned
    26 Post(s)
    Tagged
    0 Thread(s)
    I did run into problems where I couldn't get the ipa file to run on devices using pre-iOS 6.0. My solution was to install a previous xcode and suddenly everything worked again. But now I have no iphone5 simulator for testing.

  7. #7
    Clicker Fusion 2.5 MacFusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleiOS Export ModuleSWF Export ModuleInstall Creator Pro
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    UrbanMonk's Avatar
    Join Date
    May 2008
    Location
    Southern U.S.A.
    Posts
    847
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Mobichan, I've got the latest version and I'm able to test on a 4.(3?) device. It's a 3GS.
    I did have to change the version number in xCode though.

  8. #8
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export ModuleXNA Export ModuleUnicode Add-on
    mobichan's Avatar
    Join Date
    Oct 2007
    Location
    Buffalo, NY
    Posts
    3,281
    Mentioned
    26 Post(s)
    Tagged
    0 Thread(s)
    Yea, I did all the adjustments in xcode, but my publisher claimed he couldn't run my app on a whole slew of devices that weren't iOS6.0 I have since rolled back to the last xcode that supported armv6 (4.4.1). The only downside is I have no iphone5 simulator now. :9

  9. #9
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleiOS Export Module
    Diablohead's Avatar
    Join Date
    Jun 2006
    Posts
    478
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I updated about a week back and my game has no problems with the current iOS release for what I can see.

Similar Threads

  1. Broken touch control since xcode update
    By WhatPixelYouOn in forum iOS Export Module Version 2.0
    Replies: 4
    Last Post: 24th September 2013, 05:55 AM
  2. Update patch 257.23/257.24 Xcode 4.6.3 Bug
    By crayzorechos in forum iOS Export Module Version 2.0
    Replies: 8
    Last Post: 12th August 2013, 05:07 PM
  3. Build error in Xcode (latest update)
    By cfullerNY in forum iOS Export Module Version 2.0
    Replies: 6
    Last Post: 20th February 2012, 08:12 AM
  4. Xcode
    By wesleyd in forum iOS Export Module Version 2.0
    Replies: 6
    Last Post: 11th August 2011, 09:00 AM
  5. XCode
    By xhedgehogx in forum iOS Export Module Version 2.0
    Replies: 14
    Last Post: 28th July 2011, 08:45 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •