User Tag List

Results 1 to 7 of 7

Thread: Bug de compilation iOS

  1. #1
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export ModuleMac Export ModuleUnicode Add-on
    Vantales's Avatar
    Join Date
    Jun 2007
    Location
    Tahiti
    Posts
    246
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Bug de compilation iOS

    Bonjour à tous,

    J'enchaine les bugs en ce moment et je ne sais trop pourquoi ?

    Je suis sur Windows 7 Pro et MMF2 v2.0 (Build R256.34).
    J'essaye de faire une application toute simple pour Iphone avec, dans mon application, 4 scènes, du texte, des actifs, et des décors.

    N'ayant pas de mac, je suis obligé d'aller chez un ami pour compiler mon application.

    - La première fois que j'ai été, j'avais choisi comme type de construction : Projet Xcode iOS.
    Cela marchait nickel !
    Je suis donc retourné chez moi pour changer le nom de l'application (oui parce que j'avais laissé par défaut "Application"), et changer le type de construction en Projet final Xcode iOS.

    - La deuxième fois que j'ai été chez mon ami, le fichier ne voulait plus se compiler et il n'y avait aucun message d'erreur. J'ai quand même pu trouver la source de mon erreur qui était tout bêtement le nom de mon application (j'y avais mis un caractères interdit "&").
    Du coup, je suis donc retourné chez moi pour changer une fois de plus le nom de mon application.

    - La troisième fois (et c'est là où je bug), on arrive à ouvrir Xcode, et à générer l'application, mais là du coup, il affiche un écran tout noir et je ne peux rien faire à part fermer l'émulateur. Je me suis demandé si ce n'était pas dû au fait que j'avais basculé en type de construction : "Projet FINAL Xcode iOS". Alors du coup, j'ai remis en type de construction : "Projet Xcode iOS". Mais à ma grande surprise, cela ne marchait toujours pas.

    J'ai donc créé une nouvelle application avec cette fois 1 scène, et un texte uniquement. Mon type de construction était toujours "Projet Xcode iOS" ; et j'ai eu le même bug ; un écran tout noir sans que je puisse rien y faire.

    Et depuis, je suis coincé à ce bug et je ne sais pas quoi faire.

    Auriez-vous une idée ?

    Merci de votre participation.

    Cordialement,
    Olivier

  2. #2
    Clicker Multimedia Fusion 2 DeveloperiOS Export ModuleSWF Export Module
    Francois's Avatar
    Join Date
    Jul 2006
    Location
    Montpellier, France
    Posts
    6,920
    Mentioned
    0 Post(s)
    Tagged
    1 Thread(s)
    Utilises tu la toute derniere version? Va dans le forum "iOS Owners Lounge" (pour le voir il faut enregistrer ton plugin iOS dans le forum).
    Installe la, et dis moi si ca marche...

  3. #3
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export ModuleMac Export ModuleUnicode Add-on
    Vantales's Avatar
    Join Date
    Jun 2007
    Location
    Tahiti
    Posts
    246
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    D'abord, merci.

    Ensuite, j'ai pas bien compris la démarche à suivre ; pour voir le forum "iOS Owners Lounge", je dois enregistrer mon plugin iOS ?.... Je fais ça comment ?

  4. #4
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export ModuleMac Export ModuleUnicode Add-on
    Vantales's Avatar
    Join Date
    Jun 2007
    Location
    Tahiti
    Posts
    246
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Bonjour François,

    As-tu reçu mon fichier zip pour essai ?

    Cordialement,
    Olivier

  5. #5
    Clicker Multimedia Fusion 2 DeveloperiOS Export ModuleSWF Export Module
    Francois's Avatar
    Join Date
    Jul 2006
    Location
    Montpellier, France
    Posts
    6,920
    Mentioned
    0 Post(s)
    Tagged
    1 Thread(s)
    Je viens de lancer ton application sur mon Mac dans l'émulateur, tout se passe bien, je vois l'application. Il y a donc un probleme sur ton Mac. As tu bein la derniere version du plugin iOS MMF, et la derniere version de XCode?

  6. #6
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export ModuleMac Export ModuleUnicode Add-on
    Vantales's Avatar
    Join Date
    Jun 2007
    Location
    Tahiti
    Posts
    246
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Merci François !

    On a trouvé d'où venait le problème.

    En fait xcode avait gardé en mémoire la première version que j'avais fait (avec les caractères non autorisé dans le titre de l'application). On a tout simplement supprimé le ... comment on peut appeler ça ?... le "cache" du mac, et tout est revenu dans l'ordre.

    Enfin presque tout. En effet, l'application se lance dans l'émulateur ; seulement mes caractères (les accents pour être plus précis) s'affichent mal. Ils sont remplacé par des caractères incompréhensible.

    On a essayé de chercher sur xcode, mais j'y ai passé 4 heures ce soir, sans rien trouvé. Du coup je vais me replonger dans MMF histoire de trouver un genre de charset à paramétrer.

    Si quelqu'un à une idée, je suis preneur.

    Merci encore pour vos efforts.

    Cordialement,
    Olivier

  7. #7
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export ModuleMac Export ModuleUnicode Add-on
    Vantales's Avatar
    Join Date
    Jun 2007
    Location
    Tahiti
    Posts
    246
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Bonjour Tout le monde !

    Si comme moi vous avez des difficultés pour compiler votre application avec Xcode, voici un bon tuto qui explique assez bien comment procéder.
    http://xcodenoobies.blogspot.com/201...ssion-and.html

    Si vous n'avez pas de mac, il n'est pas nécessaire d'en acheter un ; vous pouvez avoir un accès à distance à un mac à l'adresse suivante :
    http://macincloud.com

    Voilà, j'espère que ces astuces en aidera plus d'un.

    Cordialement,
    Olivier

Similar Threads

  1. Pb compilation passage 253->254
    By Patrice in forum Multimedia Fusion 2 - Technical Support
    Replies: 2
    Last Post: 18th February 2012, 11:43 PM
  2. Compilation error
    By AdamDobay in forum Android Export Module Version 2.0
    Replies: 2
    Last Post: 7th August 2011, 10:58 AM
  3. Compilation OsX
    By Patrice in forum iOS Export Module Version 2.0
    Replies: 10
    Last Post: 4th August 2011, 05:06 PM
  4. Compilation Bug
    By Fanotherpg in forum SWF/Flash Export Module Version 2.0
    Replies: 13
    Last Post: 5th June 2011, 10:36 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •