User Tag List

Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 23

Thread: GLITCH! Please fix Animation Glitch!

  1. #1
    Clicker Multimedia Fusion 2 Developer
    Blue66's Avatar
    Join Date
    Jan 2008
    Posts
    133
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    GLITCH! Please fix Animation Glitch!

    Hi everyone!

    I'm having quite a struggle with random crashes of my game. I have been talking with Clickteam about this for a time and they already mentioned to fix an issue that might cause this in a patch. But even with the current version, it is not fixed!

    What happens is this (I hope I understand Clickteam correctly with that, if not, you're welcome to correct me)

    When you spawn lots of objects in rapid speed and give randomized animation sequences (to change appearence), sometimes the animation numbers of these sequences screw up somehow and become impossible values (for example animation sequence -14, which is not possible to do with regular events). Because Multimedia Fusion 2 cannot handle these animation sequences, it appears to use animations from entirely different objects (look at screenshot) or simply crashes the game. Clickteam already tried to do a work-around by catching "impossible values" and simply replacing it with 0, but this seems not to work in this case.

    This screenshot shows a random "sparkle" object appear at the enemy. But instead of showing the "sparkly object" animation, it takes the animation from a different object and appears as a solid block!


    I only have basic programming knowledge, but this glitch might possibly lead to memory leaks and other issues like crashing, so it's not a "visual glitch" that I'm addressing here. I'm posting this, because maybe this might be the reason for other people's issues with their games as well and they might report this glitch under different circumstances.

    Please Clickteam have another look at this issue, it might fix the random crashes of my game for good!
    Very much appreciated

  2. #2
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleiOS Export ModuleSWF Export Module
    Skyhunter's Avatar
    Join Date
    Jan 2007
    Location
    Croatia
    Posts
    451
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Could you create an example file recreating this issue? There might be an easy workaround...

  3. #3
    Clicker Multimedia Fusion 2 Developer
    Blue66's Avatar
    Join Date
    Jan 2008
    Posts
    133
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    What other event except "change animation sequence to..." is there to do a workaround?

  4. #4
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleiOS Export ModuleSWF Export Module
    Skyhunter's Avatar
    Join Date
    Jan 2007
    Location
    Croatia
    Posts
    451
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Well "change animation sequence to..." doesnt make any crashes or use animations from different objects in any of my games whatsoever, and i tend to use it a lot. So it's rather obvius your game is using it in a certain manner that causes these issues to occur...

    thats why an example of the mfa that does crash would be helpfull to see why and to see what fixes there might be to it...

  5. #5
    Clicker

    Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleSWF Export Module
    Konidias's Avatar
    Join Date
    Aug 2009
    Posts
    1,546
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Yeah... an example that can recreate the issue would be super helpful... I'm not sure Clickteam has much to go on with "please fix animation glitch!"

  6. #6
    Forum Moderator Fusion 2.5 DeveloperHTML5 Export Module
    Chaos's Avatar
    Join Date
    Aug 2006
    Location
    Burnsville, MN, USA
    Posts
    806
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    I actually have this happen all the time with CoI and found that using 'Load on Call' was the culprit in most cases. I haven't been able to forcefully re-create it, but again I've fixed pretty much all occurrences I've had of this by un-checking that pesky Load on Call box. I haven't been able to get a solid answer to what causes this from my talks with CT staff or other developers, but try what I mentioned above and let me know if it works for you.

  7. #7
    Clicker Multimedia Fusion 2 Developer
    Blue66's Avatar
    Join Date
    Jan 2008
    Posts
    133
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Skyhunter View Post
    Well "change animation sequence to..." doesnt make any crashes or use animations from different objects in any of my games whatsoever, and i tend to use it a lot. So it's rather obvius your game is using it in a certain manner that causes these issues to occur...

    thats why an example of the mfa that does crash would be helpfull to see why and to see what fixes there might be to it...
    I can guarantee you that I'm not doing anything "out of the ordinary" with my events. Basically I have an alterable value that gets set to a random(#) and then there are events for each #, that change the animation of the object to one that I have selected by hand from the animation selection menu of that object (no expressions are used with the animation sequences!). So with this method, it should be impossible to screw the animations up that bad that they get taken from entirely different objects. Maybe I'm using way more different animations within the same object as others, or maybe it's caused by the use of Global Events - but these two things are ordinary features of MMF2, so I suppose I'm allowed to use them as much as I want, right? I've already sent an MFA to Clickteam and they have acknowledged that it's a problem on their part, they know this issue exists and it was causing the game to crash for them too. They said they make a work-around for it in the current version, but like the screenshot shows, it is not working.

    Quote Originally Posted by Chaos View Post
    I actually have this happen all the time with CoI and found that using 'Load on Call' was the culprit in most cases. I haven't been able to forcefully re-create it, but again I've fixed pretty much all occurrences I've had of this by un-checking that pesky Load on Call box. I haven't been able to get a solid answer to what causes this from my talks with CT staff or other developers, but try what I mentioned above and let me know if it works for you.
    Thanks for your help - I've checked my MFA again and all the "load on call" have always been unchecked. I'm pretty sure I've never even touched that checkbox before, so in this case, I'm afraid it's not the problem/solution.

  8. #8
    Clicker Multimedia Fusion 2 Developer
    Blue66's Avatar
    Join Date
    Jan 2008
    Posts
    133
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Konidias View Post
    Yeah... an example that can recreate the issue would be super helpful... I'm not sure Clickteam has much to go on with "please fix animation glitch!"
    I'd love to do that, but my time is very limited. The issue is extremely hard to recreate and appears at random, so it might take days or weeks to create a "example MFA" with the same conditions to have this issue appear. As I mentioned in my first post, I've sent an early version of my game as MFA file to Clickteam before, but I will not make this public.

  9. #9
    Clicker Multimedia Fusion 2 DeveloperiOS Export ModuleSWF Export Module
    Francois's Avatar
    Join Date
    Jul 2006
    Location
    Montpellier, France
    Posts
    6,920
    Mentioned
    0 Post(s)
    Tagged
    1 Thread(s)
    Yes, if you coul disolate the problem a small application with just the object showing the problem that would be good.
    Do I already have your MFA?

  10. #10
    Clicker Multimedia Fusion 2 Developer
    Blue66's Avatar
    Join Date
    Jan 2008
    Posts
    133
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Yes, you should already have the MFA. We talked about this over PM in june last year. The MFA should be called something like Pandagame_frametest. If you don't have it anymore, I can upload it again for you.

    I'm not sure if the problem still exists if I just try to isolate the single object, since it uses animations from all other objects as well. It would take a lot of time to find the exact mix of objects that causes this issue again, because it appears at random and is not recreated that easily. Maybe it's better for this "investigation" to use the whole MFA that I've sent you back then.

    Many thanks!

Page 1 of 3 1 2 3 LastLast

Similar Threads

  1. Is this a glitch or what?
    By Tolkkiz in forum Multimedia Fusion 2 - Technical Support
    Replies: 1
    Last Post: 12th December 2009, 03:09 AM
  2. Animation Glitch.
    By Jenna in forum Multimedia Fusion 2 - Technical Support
    Replies: 6
    Last Post: 4th February 2009, 08:05 PM
  3. Really weird animation glitch
    By maestro1 in forum File Archive
    Replies: 4
    Last Post: 15th April 2008, 04:49 PM
  4. Strange Animation Glitch
    By ChrisFrankie in forum Multimedia Fusion 2 - Technical Support
    Replies: 3
    Last Post: 30th October 2007, 04:45 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •