User Tag List

Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17

Thread: audio sync

  1. #1
    Clicker Fusion 2.5 Developer

    Join Date
    Jan 2013
    Posts
    36
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    audio sync

    so this is an issue i see all the time with games done in mmf2 exported to SWFs and it is an issue that has always plagued me : sound clips are always very delayed when being played in games that are exported to SWFs.

    disabling the forced frequency seems to help it out slightly but there is always a pretty decent delay and it's very obnoxious to deal with. are there any solutions to this at all?

  2. #2
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleSWF Export Module
    happygreenfrog's Avatar
    Join Date
    May 2011
    Location
    I.L.T.D.O.I.R (I.L.T.D.O.I.R's Location: The Dimension Of Infinite Recursion)
    Posts
    4,307
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Does it only happen the first time a sound is played? I don't have any sound delay issues in my games, but if it only happens the first time a sound is played, then I think I have a solution...

  3. #3
    Clicker Fusion 2.5 Developer

    Join Date
    Jan 2013
    Posts
    36
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    it's every single time a sound is played. can i see an example of your game not having an issue with delay on sound cues because no joke, any game i've seen done with mmf2 i know is done with it thanks to delay that gets added by the swf exporter with sounds.

  4. #4
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export Module
    KLiK-iT's Avatar
    Join Date
    Sep 2011
    Location
    New Jersey
    Posts
    2,862
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    That is strange. I don't have any delays on my end either. Can you post an example of the issue so we can test it?

  5. #5
    Clicker Fusion 2.5 Developer

    Join Date
    Jan 2013
    Posts
    36
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    EDIT: scratch all of this i suppose. mmf2's conversions and methods seem to add delays, after converting file types and adjusting frequencies and other options and limiting the file sizes heavily i managed to get it down to having next to no delay. i guess i see it often because people just leave it on default and take in WAV files.

  6. #6
    Clicker Multimedia Fusion 2 DeveloperiOS Export ModuleSWF Export Module
    Francois's Avatar
    Join Date
    Jul 2006
    Location
    Montpellier, France
    Posts
    6,920
    Mentioned
    0 Post(s)
    Tagged
    1 Thread(s)
    Never heard any delay in sounds ever with the SWF runtime.
    This maybe due to the sampling frequency of your sounds. Have you tried changing it (try 20000)...

  7. #7
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export ModuleXNA Export ModuleInstall Creator Pro
    SoftWarewolf's Avatar
    Join Date
    Jul 2006
    Location
    Norway
    Posts
    929
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    seriously? i have major issues with sound delay, all mp3 converters i tried add a short delay to the beginning, so if anyone know which settings to use and how to convert sound files without adding delay, i am extremely interested to know.

  8. #8
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleSWF Export Module
    redpandagames's Avatar
    Join Date
    Dec 2011
    Posts
    375
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Are you sure that the sound files don't have silence at the beginning of the clip? I've never had an issue with this, but if you have a "fade in" on your sound, that could be causing a problem or make it seem like there is a delay.

    Just out of curiosity, what events are you using to play the sounds?

    I know that I have trouble running things if I have over 200 events, so excessive events could also be part of the problem.

  9. #9
    Clicker Multimedia Fusion 2 DeveloperAndroid Export ModuleSWF Export Module
    pzazz's Avatar
    Join Date
    Mar 2011
    Posts
    53
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I'm having the same delay problem. The sounds play with a noticeable delay. With a simple key tap the sound will play delayed to about the point where you lift your finger up, causing a kind of off beat feel which is very noticeable. Maybe a quarter of a second. This happens with the standard MMF2 samples and I use the standard 'play sample' event. This makes any kind of rhythm game impossible and generally looses a lot of a game's 'punchlines'. Weird that some people are having problems and some not. I assumed it was a problem with the flash format and not mmf2.

  10. #10
    Clicker Fusion 2.5 Developer

    Join Date
    Jan 2013
    Posts
    36
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    i retract what i had said as the sounds are still delayed and very inconsistently, one plays maybe 10ms after the event should be triggering it while another plays about 20ms after. lowering quality and the frequency of the source sound has helped but there is still a decent delay added on.

    Are you sure that the sound files don't have silence at the beginning of the clip?
    yes because when tested within mmf2 the sounds trigger perfect and as soon as the event calls for it. for flash i would expect maybe a minor delay to call for a sound playing but it's far too much of a delay when mmf2 exported applications ever attempt it.

    Weird that some people are having problems and some not.
    i have to question this because any mmf2 exported game to an SWF format i have tried has always had some delay added for sounds so maybe some people just don't notice it?

Page 1 of 2 1 2 LastLast

Similar Threads

  1. Should you always use V-Sync?
    By Shawn in forum Multimedia Fusion 2 - Technical Support
    Replies: 7
    Last Post: 22nd December 2012, 01:06 PM
  2. [Request] Onu Audio add-on: sync'ed up decks
    By Bipolar_Games in forum Extension Development
    Replies: 1
    Last Post: 6th August 2012, 01:55 AM
  3. audio out of sync
    By cfullerNY in forum XNA Export Module Version 2.0
    Replies: 5
    Last Post: 5th June 2012, 05:40 PM
  4. Out of sync audio?
    By brawltaunts22 in forum SWF/Flash Export Module Version 2.0
    Replies: 5
    Last Post: 2nd February 2012, 05:53 PM
  5. V-Sync
    By Cossin in forum Multimedia Fusion 2 - Technical Support
    Replies: 9
    Last Post: 11th August 2008, 05:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •