User Tag List

Results 1 to 5 of 5

Thread: Get Object with https:// (secure)

  1. #1
    Clicker Multimedia Fusion 2Android Export Module
    Fusion 2.5 (Steam)
    manwich's Avatar
    Join Date
    Apr 2013
    Posts
    29
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Get Object with https:// (secure)

    Does anyone have the Get object working with secure https:// links? Normal http links work fine but https links don't seem to return anything. I'm trying to access a server API that only allows secure requests.

  2. #2
    Clicker

    Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleSWF Export ModuleXNA Export ModuleInstall Creator Pro
    nivram's Avatar
    Join Date
    Jul 2006
    Location
    Bandon, Oregon
    Posts
    6,736
    Mentioned
    9 Post(s)
    Tagged
    0 Thread(s)
    No, sorry. You can not use "Get" on secure servers.

    Marv
    ​458 TGF to CTF 2.5+ Examples and games
    http://www.castles-of-britain.com/mmf2examples.htm

  3. #3
    Clicker Multimedia Fusion 2Android Export Module
    Fusion 2.5 (Steam)
    manwich's Avatar
    Join Date
    Apr 2013
    Posts
    29
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Darn. Ok, thanks.

  4. #4
    Clicker Multimedia Fusion 2Android Export Module
    Fusion 2.5 (Steam)
    manwich's Avatar
    Join Date
    Apr 2013
    Posts
    29
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    If anyone else is trying to do this, I found a workaround: use the Web View Object's "Download URL to file" feature to save the https site to a txt file, then load the file back in to a Rich Edit object or similar. Now to try and get it working on Android...

  5. #5
    Clicker

    Fusion 2.5 MacFusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export ModuleInstall Creator ProUnicode Add-on
    StingRay's Avatar
    Join Date
    Nov 2006
    Location
    Austria
    Posts
    1,044
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Hi! I've a client project where the client switched to ssl authentication after the project was started.

    so the user have to login inside the app. the app should check if the user exists - that would be easy with standard tools (GET and php?username=xxx&pw=yyy)

    but doesnt work with the HTTPS site. if i GET the url i'll get this error:

    Windows & iOS Device: "HTTP Basic: Access denied."


    if i POST username and password, and GET the url i will get the following error(s):

    On Windows:
    "400 The plain HTTP request was sent to HTTPS port - 400 Bad Request"

    On iOS-Device:
    "The page you were looking for doesnt exist (404)"


    I'm lost here. Is there some kind of workaround for iOS Device to make this work?!?

Similar Threads

  1. GetDomain$ does not work with HTTPS://
    By AndyH in forum SWF/Flash Export Module Version 2.0
    Replies: 16
    Last Post: 9th May 2011, 09:27 AM
  2. Bug in Flash Object - Https links
    By BHGames in forum SWF/Flash Export Module Version 2.0
    Replies: 14
    Last Post: 9th May 2011, 09:24 AM
  3. How secure are extensions like URL Encoder?
    By Shawn in forum Multimedia Fusion 2 - Technical Support
    Replies: 2
    Last Post: 3rd March 2009, 05:15 PM
  4. HTTPS in mmf2 help needed
    By SEELE in forum Multimedia Fusion 2 - Technical Support
    Replies: 2
    Last Post: 4th September 2008, 10:39 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •